Britgirl

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 3,011 total)
  • Author
    Posts
  • Britgirl
    Keymaster

    System users authentication doesn’t work on systems with pam.d placed in a different location than /etc/pam.d.

    It looks like you have the same issue which was reported a while back by another user. The problem is not in NoMachine, but the fact that you have pam.d iconfig files in two places in your OS. (https://kb.nomachine.com/TR02R09538)

    As a workaround, link pam.d to /etc/ directory before installing NoMachine:

    sudo ln -s /usr/share/defaults/etc/pam.d /etc/pam.d

    or add manually nx and nxlimits files to pam.d directory (/usr/share/defaults/etc/pam.d):

    cat /usr/share/defaults/etc/pam.d/nx
    auth       include       su
    account    include       su
    password   include       su
    session    include       su
    
    cat /usr/share/defaults/etc/pam.d/nxlimits
    session   optional pam_limits.so
    in reply to: Error 102 over IPv6 when connecting to Windows 7 #39065
    Britgirl
    Keymaster

    Hi tomku

    …I immediately realized, this is the reason. Many thanks!

    Good. So the problem was that IPv6 is not enabled by default by the Windows XP OS. Good. Soo problem solved 😉

    Good luck with your move!

    in reply to: Error 102 over IPv6 when connecting to Windows 7 #39034
    Britgirl
    Keymaster

    I can’t imagine NX to ignore IPv6

    In fact it doesn’t. IPv6 is fully supported, fully tested and fully working. We test IPv6 regularly, among our standard test procedures, before any new release.

    1) Can you tell us the IP address you are using?
    2) Where did you put it?

    Even an description of the error number would be appreciated

    In fact, there is the description: “Error 102: protocol doesn’t support address family”
    Where exactly was it shown? Where was it reported? Can you show us a screenshot?

    if I use the IPv6 address…….Nothing worked using SSH or HTTPS.

    3) What’s the IP address that you used.
    4) How are you using it with SSH or HTTPS?
    5) What are you connecting to?

    In other words, please provide all the information we need to reproduce the problem.

    Also, have you tried using the same IPv6 address with another application and it worked well?

    in reply to: Issue with Raspberry Pi 3B+ and app in command shell #39020
    Britgirl
    Keymaster

    Hi, I assume your Raspberry is headless. Did you follow the instructions in our tutorial?

    https://www.nomachine.com/tips-on-how-to-set-up-your-raspberry-pi-for-remote-access-via-nomachine

    See Tip 2: Connecting to a headless Raspberry.

    sudo vim /boot/config.txt
    hdmi_force_hotplug=1
    sudo reboot

    On RPi4 it’s not required anymore, but on RPi3 it is.

    in reply to: Fonts broken in NoMachine window #38996
    Britgirl
    Keymaster

    Hi, let me understand better:

    1) you’ve been using Xorg (not Wayland) connecting with NoMachine and had no problems up until recently?

    2) all of a sudden you’re getting small fonts in the NoMachine player? What have you changed on the host, in the time it was working and when the font problem started? Did you only update NoMachine to 7.10?

    2) have you followed your own tips from your original post in https://forums.nomachine.com/topic/no-text-showing-in-client-sceen-under-xorg-kde? e.g reboot?

    3) what is the ‘zoom level’ that you mention?

    We’ll try and reproduce it here. I’ll write what I wrote last time:

    Do the following, open a terminal on the affected host execute ‘xdpyinfo’ and ‘xrdb -query -all’ . What’s the output?

    If you change the font in the NoMachine Player settings, does the problem go away?

     

    Britgirl
    Keymaster

    Glad to hear that. Happy nomachining 🙂

    Britgirl
    Keymaster

    Great Jean-Paul, thanks for letting us know!

    Britgirl
    Keymaster

    Hi, this question has already been answered in forums 🙂 Take a look at the following:

    Disable IPv6? Or configure which interface to bind?

    Namely, you cam modify the server.cfg to exclude specific addresses

    #
    # Specify the network interface where the NX service will be bound.
    # Populate the field with an IP address or a domain name.
    #
    #NXdListenAddress “”

    A brief intro about the server/node configuration files is here if you are interested:

    The server.cfg and node.cfg files explained
    https://kb.nomachine.com/AR02N00877

    Britgirl
    Keymaster

    Hi leprechaun,

    I’ve gotten it to work just fine across my LAN and over the internet through my firewall.

    Great 🙂

    From what you’ve written I understand that connecting to a Raspberry device, everything is working well. But when connecting from a Raspberry device or smartphone with the NoMachine mobile app to your Windows 10, you cannot see applications windows. You see only the desktop.  Right?

    On my Windows 10 Machine it seems to work fine except none of the windows display remotely.

    What applications are actually running there? I mean, if I was physically in front of the Windows PC , what applications would be open?

    Is the Windows PC with multi-monitors? If so, take a look at this tutorial: https://www.nomachine.com/switching-the-view-between-multi-monitors-during-a-remote-desktop-session.

    Britgirl
    Keymaster

    Hi, take a look at this article in our knowledge base 🙂

    How to start the session by passing options to the client from command line
    https://kb.nomachine.com/AR02P00963

    Britgirl
    Keymaster

    This means that EGL capturing isn’t enabled.

    Tell us the output of sudo /etc/NX/nxserver --egl-capture yes

    Please also attach the modified scripts mentioned in the output of the command above.

    Also, what is the output of getcap /usr/bin/gnome-shell?

    in reply to: NoMachine abruptly disconnects user after login #38946
    Britgirl
    Keymaster

    The logs show that physical desktop sharing is disabled for user djoo.

    Try running: sudo /etc/NX/nxserver --useredit djoo --screensharing yes.

    in reply to: Broken Pipeline / Cannot write to FD#29 #38928
    Britgirl
    Keymaster

    Just to clarify a small detail. When you mention NoMachine session, which is on Ubuntu, knowing which desktop environment you are connecting to is useful for us. By “desktop environment” I mean KDE, Gnome or any other. OK, thanks for letting us know that the problem is solved. If it happens again, by all means open a support enquiry.

    in reply to: Broken Pipeline / Cannot write to FD#29 #38918
    Britgirl
    Keymaster

    Hi, it’s strange that after 1.5 years of working perfectly that your NoMachine server suddenly starts doing strange things 🙂 That can happen if you have changed something on the headless Ubuntu host, like updating it or changing some configuration perhaps?

    I (and others) cannot create new sessions on the server.

    What desktop environment are you trying to connect to? Does this mean that you can reconnect sessions already created before the problem started, and that it’s only new sessions which are not possible?

    I noticed from the logs that you are running a licensed Small Business Server. This means that you are entitled to receive technical assistance from our support team. Since the forums are public, it might be better to open a ticket and have our support team investigate directly. This will also avoid any sensitive information being accidentally published here. Full debug logs will be required, the ones you sent to us don’t appear to be the full set.

    Britgirl
    Keymaster

    We’ll check this out, but in the meantime, can you tell us the result of the command:
    sudo netstat -anlp | grep egl

Viewing 15 posts - 1 through 15 (of 3,011 total)