brotech

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 82 total)
  • Author
    Posts
  • Avatarbrotech
    Participant

    Hello,
    there is also in node configuration file
    /usr/NX/etc/node.cfg
    a key:

    #
    # Specify hostname for the NoMachine node.
    #
    NodeName testname

    please set here something short and it will be used instead of long domain name.

    Regards

    Avatarbrotech
    Participant

    Hello,

    this seems to be SSH limitation rather then NX, anyway You can change #UserNXDirectoryPath in node configuration file and this way shorten path a little.

    in reply to: Nxnode, nxserver services disabled #28663
    Avatarbrotech
    Participant

    Hello Aubert,
    there is article explaining what ‘disabled nxnode service’ means:

    https://www.nomachine.com/AR07Q01037
    When is the nxnode service disabled on Linux?

    I hope it helps

    Regards

    Avatarbrotech
    Participant

    Hello,
    the url to download recent package has been changed, now it is:

    https://www.nomachine.com/free/linux/64/deb
    

    Replaced ‘download’ by ‘www’. So, full command now is:

    wget https://www.nomachine.com/free/linux/64/deb -O nomachine.deb
    
    in reply to: Unable to connect after some amount of time #28638
    Avatarbrotech
    Participant

    Hello,
    seems that are some problems with correct handling of the Fedora 32 Login Window.

    The workaround should be to set in /usr/NX/etc/server.cfg:
    PhysicalDesktopAuthorization 0

    It disables asking for access to the desktop, so use only if there is no other user on that host which should access the desktop.

    And the second thing is that switch doesn’t work correctly after login/logout to desktop
    so you need to disconnect and connect again.

    Avatarbrotech
    Participant

    Hello am312,
    currently, NX doesn’t require Internet access to confirm the license.

    in reply to: Password required for private key connection #28560
    Avatarbrotech
    Participant

    Hello,
    yes it should work without additional methods.

    Can you please enable debug on server side, restart nxserver then reproduce issue, collect logs and send as mail attachment to address forum (at) nomachine.com with title
    “password-required-for-private-key-connection”

    Detailed instructions about collecting logs on both side(client and server)
    are available here:
    https://www.nomachine.com/AR10K00697 (for server side logs)
    and https://www.nomachine.com/DT10O00163#2 (client side).

    Regards

    Avatarbrotech
    Participant

    Hello,

    if I understood correctly, you are trying connect to ‘clients’, when client means only nxplayer.

    What have you installed on the Mac hosts that you want to connect?

    You should have Enterprise Desktop installed in order to share the desktop. You can add them to the Cloud Server using the command:

    /etc/NX/nxserver --serveradd hostname

    executed on Cloud Server as administrator or through sudo.

    After that students should see a list of available desktops in Cloud Server. If you would like assign a student to a particular ED host, without the need for them to select the host itself, You can use:

    /etc/NX/nxserver --useredit student_username --forward-connection ed_host:4000

    Regards

    in reply to: Large amount of folders #28487
    Avatarbrotech
    Participant

    Hello Ernest,
    in that location, NX creates a session’s directory. But when the session finishes,
    it is cleaned up. When a session ‘fails’, that directory is renamed to F-session_dir, which allows to find the reason why the session failed.

    Anyway, a ‘large amount’ of folders is the sign of problems on that host, and it is not a common case.

    Can you share the whole log directory (with that node subdirectory) ?

    $ cd “/Library/Application Support/NoMachine/var/”
    $ sudo tar cvfz NoMachine-log.tar.gz log

    And please send NoMachine-log.tar.gz as an attachment by e-mail to:
    forum[at]nomachine[dot]com with subject:
    “LARGE amount of folders”.

    regards

    Avatarbrotech
    Participant

    Hello Paul,

    The command /etc/NX/nxserver run nxserver depends on the configuration used
    during the installation. Which kind of package did you install ?

    Could you please share some details about your linux platforms/distro, and show for example the output of ‘uname -a’ command ?

    Regards

    in reply to: NX service not accessible #27814
    Avatarbrotech
    Participant

    Hello,
    it looks very likely to be: https://www.nomachine.com/TR04R09623
    “The nxservice service starts and stops after 10-30 seconds”
    workaround is inside.

    Please let me know if it helps.

    Avatarbrotech
    Participant

    This step:
    “get the latest version of NoMachine on the web site”

    can be done using the command as:

    wget https://download.nomachine.com/free/linux/64/deb -O nomachine.deb

    it will download the most recent deb package.

    in reply to: Newbie questions – Private key connections #27666
    Avatarbrotech
    Participant

    Hello,

    Generally you need to set up the key for every user in that user’s homedir/.nx/config directory. There is not a “one place for all users” directory.

    “Error cannot accept public key” is a generic error message to avoid publishing sensitive security information. You will need to take a look in the logs on the server side where the exact error should be reported. It could be to do with a missing file, wrong permissions etc.

    In case of problems with understanding, send to us nxserver.log and nxerror.log from C:/ProgramData/NoMachine/var/log directory.

    Avatarbrotech
    Participant

    Hello Zenith,

    logs which you sent don’t have enabled debug for NXServer. And so I cannot help you.

    Please to run this command on the server host:

    sudo /etc/NX/nxserver --debug --enable server

    You should see ouput as:

    NX> 900 Debug mode enabled for: server
    

    What does nxserver report to you when you run that command?

    Avatarbrotech
    Participant

    Hello Zenith, can you enable debug on server side using a command executed on your linux host (nxserver side) by root:

    /etc/NX/nxserver --debug --enable server

    or using sudo:
    sudo /etc/NX/nxserver --debug --enable server

    After enabling debug, please connect and login from your connecting client and with user ‘oem’.

    When the problem appears again please share nxserver.log, nxerror.log files from /usr/NX/var/log/ directory and additionally /var/log/auth.log file,
    and attach also server configuration file (/usr/NX/etc/server.cfg).

    All those files please send to forum[at]nomachine[dot]com with subject:
    “cant-login-authentication-failed-please-try-again”

    Reproducing problem with enabled debug should allow us to find a reason for problem.

    Regards

     

     

Viewing 15 posts - 1 through 15 (of 82 total)