brotech

Forum Replies Created

Viewing 15 posts - 46 through 60 (of 89 total)
  • Author
    Posts
  • in reply to: Cannot successfully open session #20077
    Avatarbrotech
    Participant

    Hello StMartin81,

    please enable logs for nxserver, nxnode and also nxwebplayer. You can do that using
    one command:

    sudo /etc/NX/nxserver –debug –enable all

    Then restart nxserver(sudo /etc/NX/nxserver –restart), reproduce problem, collect logs
    and please send again. In last logs there are only debug messages from server.

    If the physical session is available, it will be on the list for administrators or trusted users only, until
    FR mentioned by AMSCAE will be implemented and released.

    in reply to: Nxserver on Centos 7 is not connecting to MacOS Client #19888
    Avatarbrotech
    Participant

    Hello,

    this is strange. So far we have not been able to reproduce it, so please enable debug, restart nxserver, reproduce the problem and then collect logs and send to us.

    Detailed description is available here: https://www.nomachine.com/DT10O00163#1

    Send to forum[at]nomachine[dot]com the TAR.GZ archive.

    regards

    in reply to: NoMachine refuses to re-attach to physical session #19113
    Avatarbrotech
    Participant

    Hello fermulator,

    Sorry for the delay in replying, I thought we had already replied with the workaround.

    The problem you experience might be related to your recent OS updates, in particular to krb5-workstation package.

    We suspect that it’s:

    https://www.nomachine.com/TR07P08710

    The problem was solved in our test environment by downgrading krb5-workstation
    package from:

    Version     : 1.15.2
    Release     : 9.fc27

    to:

    Version     : 1.15.2
    Release     : 2.fc27

    in reply to: Server not running #18418
    Avatarbrotech
    Participant

    Hello,

    could you describe the platform, architecture and package used to install NoMachine? We haven’t seen this problem in our lab, so having this additional information will help us to reproduce.

    To speed up the investigation, please collect logs as described here:

    https://www.nomachine.com/DT10O00163

    Please send them to forum[at]nomachine[dot]com referring to your topic in the subject of the email mail.

    in reply to: How to resolve "The authenticity of host" message #18067
    Avatarbrotech
    Participant

    Hello,

    it appears to be the same issue. There is no temporary workaround unfortunately. Please sign up  to know when a fix has been released using the ‘notify me’ service.

    Regards

    in reply to: How to resolve "The authenticity of host" message #18049
    Avatarbrotech
    Participant

    Hello fun_9990,

    We tested the same environment you have and reproduced a similar problem tracked here:
    https://www.nomachine.com/TR03P08473

    To confirm that it’s the same issue you reported, please check in your nxerror.log file
    if a similar error is reported.

    Regards

    in reply to: Nxserver –daemon is not ready #16799
    Avatarbrotech
    Participant

    Hello,
    we would also expect different results just after installing. There are not any additional steps required.

    You used package i686 which is for 32bits platforms only. If your Centos system is 64bits
    then please uninstall and download/install package with the x86_64 extension.

    If this is not a case then something did go wrong and we need to take a look at the logs. So, please follow article:
    https://www.nomachine.com/DT10O00163 and share with us logs by sending them to forum[at]nomachine[dot]com.

    /b.

    in reply to: The server was unable to make the local display available #15708
    Avatarbrotech
    Participant

    Dear jwgish,

    thank you for logs. Unfortunately nxserver was not restarted, so these logs
    don’t provide the necessary information to investigate the problem.

    Please restart the server, you can do that from a console by running:

    sudo /etc/NX/nxserver –restart

    Then reproduce the problem (message: The server was unable to make the local display available or access to the local display is disabled.)

    Collect and send us the new set of logs.

    Additionally, please give us also the following information:

    1) OSX version

    2) Device type (e.g. Macbook Pro)

    3) If a user is physically logged-in to the desktop or if there is the Login window.

    4) If advanced configurations are set, e.g. LDAP etc…

    Regards

    in reply to: Error 60, no local display Mac 10.12.5 #15278
    Avatarbrotech
    Participant

    Hello,
    the server.cfg on OSX, which in your case is the client side, is not related to the issue which seems to happen on your Windows 10 – server side.

    Please check the firewall, and network between those two hosts, and if everything is OK, then please
    enable debug, collect logs on windows, and send to us. Please follow instructions from:
    https://www.nomachine.com/DT07M00098

    Regards

    in reply to: Nxserver.bin constantly restarting on Windows 7 #15277
    Avatarbrotech
    Participant

    Hello Jeribo,
    please enable debug, reproduce the problem and then send us the logs (to forum[at]nomachine[dot]com).
    Please follow the instructions here: https://www.nomachine.com/DT07M00098
    Regards

    Avatarbrotech
    Participant

    Hello redskate,
    we are not able to reproduce such problem in our lab. Could you please enable debug restart
    nxserver and send us logs if you can reproduce the issue ?

    You can find instructions about debug and collecting logs here: https://www.nomachine.com/DT07M00098.

    Regards

    Avatarbrotech
    Participant

    Hello,
    please try to use those 2 commands one by one (replace username by targeted user, and run both commands as that user):

    Xvfb :99 -auth /home/username/.Xauthority -screen 0 1024x768x24
    DISPLAY=:99 /etc/NX/nxserver –startsession

    The first one will run Xvfb server, and second start session on already created display.
    Command xvfb-run could help also but it terminates Xvfb when application finishes.

    The command nxserver –startsession will start the session and leave the session running in the background. This command will also report whether the session was started or failed.

    You could also copy xvfb-run to own script for example ‘startvirtualsession’, and modify by removing clean_up function. It could vary on version of Xvfb.

    in reply to: Cannot create custom session #14910
    Avatarbrotech
    Participant

    Hello,

    the described situation is completely normal if you install NoMachine Free version, which
    doesn’t support virtual sessions. You can verify it on your SuSE host using command:
    /etc/NX/nxserver --version

    If you really have Workstation version installed, then please enable debug in server and node configuration file, restart your nxserver then connect and log in using NoMachine player. If you are automatically connected to the system’s desktop, please send the logs to forum[at]nomachine[dot]com?

    Instructions about debug and collecting logs you can find there: https://www.nomachine.com/DT07M00098.

    Regards

    in reply to: Seeing two X server when trying to connect #14895
    Avatarbrotech
    Participant

    Hello

    In node configuration file (/usr/NX/etc/node.cfg) there is a key which allows to limit
    the physical desktop display available:
    #
    # Specify the physical display or range of X server displays which are
    # made available to NoMachine connections. It is possible to specify a
    # single display by display number, e.g. :0, or by port, e.g. 6000.
    # Range of displays can be specified as a dash separated list,
    # e.g. :0-:7 or, by port number, 6200-6204. By default all displays
    # detected as running will be made available for users.
    #
    #PhysicalDisplays :0

    Set it to :0 and you should see only one display available.
    Depending on the Linux distribution, after login to Login window
    the user’s desktop could start on Display :1 so set a range as :0-:10
    could be better on some distros, and on others :0 is enough.

    in reply to: Black screen on Ubuntu NX when connecting from Mac #14775
    Avatarbrotech
    Participant

    Hello,
    in case of headless please use the command from the article:

    https://www.nomachine.com/AR04K00667

    In the last section “Configure NoMachine to launch LXDE on Ubuntu 14.04” there is a nxsession
    script which should work correctly.
    Then set DefaultDesktopCommand “/usr/bin/nxsession” in node.cfg file.

     

Viewing 15 posts - 46 through 60 (of 89 total)