brotech

Forum Replies Created

Viewing 15 posts - 61 through 75 (of 89 total)
  • Author
    Posts
  • in reply to: Error is 134: Protocol error (Ubuntu) #14776
    Avatarbrotech
    Participant

    Hello,
    the problem is that the application run terminated immediately. We can see:
    2017-05-11 22:50:06 957.673 2075 NXNODE ERROR! Application terminated too early.

    So please check DefaultDesktopCommand key in node configuration key, and set it according to
    to your needs. There is also article about: https://www.nomachine.com/AR04K00667

    in reply to: Specify which display to connect to #14463
    Avatarbrotech
    Participant

    Hello,

    the PhysicalDisplays key in node configuration file allows to define a range of physical
    displays which are accepted, and all others will be ignored, so in your case range
    0-100 should be good enough.

    Regarding auto attach to physical desktop, nxserver needs to tell nxplayer that there
    is no other choice, which means you need to disable the possibility to create different kinds of sessions, and then nxplayer will auto attach to physical desktop.

    Rules are set per user, the user logged into the system, which is not necessarily the owner of the desktop. The set of rules, which you could set per user is for example:

    sudo /etc/NX/nxserver --ruleadd --class session --type unix-console --value no --user
    sudo /etc/NX/nxserver --ruleadd --class session --type unix-gnome --value no --user
    sudo /etc/NX/nxserver --ruleadd --class session --type unix-xsession-default --value no --user
    sudo /etc/NX/nxserver --ruleadd --class session --type windows --value no --user
    sudo /etc/NX/nxserver --ruleadd --class session --type unix-remote --value no --user
    sudo /etc/NX/nxserver --ruleadd --class session --type unix-application --value no --user
    sudo /etc/NX/nxserver --ruleadd --class session --type unix-default --value no --user
    sudo /etc/NX/nxserver --ruleadd --class session --type unix-xdm --value no --user
    sudo /etc/NX/nxserver --ruleadd --class feature --type enable-multinode --value no --user 

    If you apply this set of rules for, let’s say, user Adam, nxplayer will auto attach to physical desktop for user Adam. And it will still be possible for a different user to create virtual session. The rule without ”–user ” switch, will apply to all users.

    in reply to: Unable to start nxserver on RHEL 7 #14412
    Avatarbrotech
    Participant

    Hello,
    we added an article strictly related to your issue:

    Troubleshooting NoMachine in a Active Directory Domain
    https://www.nomachine.com/AR04O00925

    If you have any problems, let us know.
    Regards

    Avatarbrotech
    Participant

    Hello TeutonJon78.
    We are trying to reproduce problem which you described. In the meanwhile could you enable logs in server and node configurations file, then restart Windows, and after a while compress var/log directory and send to us ?

    The guide how to collect logs on windows is available here:
    https://www.nomachine.com/DT07M00098

    Please send them to forum[at]nomachine[dot]com with
    “After update to Windows 10 CU (1703) “No available session on server” as a title of the mail.

    Thank You

    Avatarbrotech
    Participant

    Hello,
    everything looks fine so far. Please attach mentioned /usr/NX/var/log/node directory.
    Could You also try to connect locally using nxplayer and then sent to us again nxd.log
    file ? (By locally I mean, running nxplayer on problematic host and connect to 127.0.0.1
    using it).

    Avatarbrotech
    Participant

    Hello Mark,
    it looks similar as the issue described in another thread, which happens on Kubuntu 16.04 LTS.
    The problem probably is related to internal network stack, and so far we have no clue about solution or even reason.

    Could you please attach also logs from /usr/NX/var/log/node directory ? It will help to confirm if
    is the same issue. Then, could You show a result of following system commands as:

    cat /etc/hosts
    ifconfig
    ping -c localhost
    uname -a
    

    There is anything different which you are using on that problematic ubuntu host? Iptables, apparmor, network card etc ?

    Avatarbrotech
    Participant

    Hello, could You paste Your script ?
    Hard to say if you are doing something wrong.

    For sure custom script as

    #!/bin/bash
    sleep 10

    will delay session start by 10 seconds.

    Avatarbrotech
    Participant

    Custom scripts UserScriptAfterSessionStart could be helpful here.

    The script is executed after the application starts but before the desktop is exported to the client side. The node will wait for exit of that script. So you could wait for some seconds,
    or check which process is the important one to wait for.

    Node executes it using these parameters:
    UserScriptAfterSessionStart “” session id, username, session type, display, main session id(*), main session type(*)

    (*) ‘main session id’ and ‘main session type’ parameters are available only when the user connects to an already running virtual desktop (session shadowing).

    Examples of scripts are here:
    https://www.nomachine.com/AR02L00787

    Avatarbrotech
    Participant

    Hello linuxuser,
    thank you for logs, based on them we could said that there is internal
    problem with network stack or configuration. Internal local connection to localhost
    is refused because it is wrongly recognized as a remote one.

    Could you show us results of the following commands:

    cat /etc/hosts
    ifconfig
    ping -c localhost

    About NoMachine icon color, differences are just cosmetic and depend on themes and operating systems.Can you confirm you’re using different themes on notebook and on desktop?

    Avatarbrotech
    Participant

    Hello Romz,
    instead of nxerror.log where there are often harmless errors, please take a look in: /usr/NX/var/log/nxserver.log file for any errors reported.

    If nothing useful is there, please enable debug in /usr/NX/etc/server.cfg and /usr/NX/etc/node.cfg file, restart NoMachine server (sudo /etc/NX/nxserver –restart), then reproduce the problem (connect using nxplayer on windows and get error 138 connection timeout out and send to us /usr/NX/var/log/nxserver.log file to forum at nomachine.com.

    Full instructions are here:
    https://www.nomachine.com/DT07M00098

    NoMachine server doesnt currently have problems when disabling IPv6.

    in reply to: Error when creating a new virtual desktop #12501
    Avatarbrotech
    Participant

    Hello Albert,

    problem appear on server side, so logs from server host will be more helpful. You can locate them at /usr/NX/var/log/ directory as nxserver.log and nxerror.log

    You should enable debug in node and server configurations files first.
    Those files are available at: /usr/NX/etc directory and its filenames are: server.cfg and node.cfg.
    Please set SessionLogLevel key to value 7 and uncomment it. Check the following article here for more details: https://www.nomachine.com/DT07M00098

    After enable debug please restart nxserver (sudo /etc/NX/nxserver –restart), reproduce problem and send to us logs at forum[at]nomachine[dot]com.

    You can archive whole logs directory using: sudo tar -zcvf nomachineLog.tar.gz /usr/NX/var/log

    in reply to: Unable to change desktop environment in Mint 18 #12451
    Avatarbrotech
    Participant

    Hello,

    for sure NoMachine is using /usr/NX/etc/node.cfg as a configuration file where DefaultDesktopCommand could be set.

    Could you give a little more information about your configuration?
    Are you using the NoMachine free product ? Verify by running a command /etc/NX/nxserver –version. E.g.,

    /etc/NX/nxserver –version
    NoMachine – Version 5.1.44

    Is MDM working and do you get the login window ? If yes then you need to focus on MDM setup and select desktop kind using MDM’s menu (press letter M in top-right corner of login box) because xfce4 is started by MDM and NoMachine allows access to the physical DISPLAY whatever is running on it. So, there is no DefaultDesktopCommand in use.

    Any problem or errors related to session run should be in /home/USERNAME/.xsession-errors file.

    in reply to: Enable to run only one application to my users #12444
    Avatarbrotech
    Participant

    Hello, NoMachine (free version) gives access to physical desktop limited to
    1 connection at the same time.

    So if you have any kiosk-mode application run as current desktop then attached user will have available only that application.

    in reply to: Unable to change desktop environment in Mint 18 #12422
    Avatarbrotech
    Participant

    Hello Xaint,
    I was able to reproduce similar problems when I installed ‘xfce4-session’ using apt.

    However after I installed meta-package xfce4 and both commands which you used work correctly out-of-box. I tried /etc/X11/Xsession xfce4-session and it works also.

    b.

    in reply to: Idle session termination #12420
    Avatarbrotech
    Participant

    There is no a automatic way to terminate idle sessions at the moment, so we’re evaluating whether to insert a Feature Request into our roadmap.

    You could set DisablePersistentSession “username” key in server configuration file, but then every network disconnection of that user will terminate a session, which doesn’t seem to be helpful in your case.

    # Disable persistent sessions for users. If the option is followed by
    # the keyword ‘all’, no user is allowed to run persistent sessions. Al-
    # ternatively, the option can be followed by a list of comma-separated
    # usernames. The default value is the empty string which corresponds
    # to disabling persistent sessions for no user. The values specified
    # override the values set for the ‘EnablePersistentSession’ key.
    #
    #DisablePersistentSession “”

    By default NoMachine sets: #EnablePersistentSession all

    Alternatively, you could try switching the –timeout values for ‘AgentExtra’ key, and ‘DisconnectedSessionExpiry’ , so decrease the value for disconnect on idle, and increase the time how long session could be disconnected. Again, it’s not optimal, but it might help.

     

     

     

     

Viewing 15 posts - 61 through 75 (of 89 total)