bsper2

Forum Replies Created

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • in reply to: Disable mDNS traffic #30365
    Avatarbsper2
    Participant

    Ok, I did have the “Don’t show other computers on the network” unchecked. It looks like this is a per user setting, getting controlled by ~/.nx/config/player.cfg

    I have many users connecting to these NoMachine servers, so I am looking for a way to set this across all users.

    I see the setting key would be:
    <option key=”Discover other NoMachine servers in the network” value=”false” />

    What is the best way to set that for all users? I looked to see if there was a system wide player.cfg file, or some setting in node.cfg or server.cfg but didn’t have much luck. Really want to avoid having to alter each users player.cfg file in place and maintain that setting change.

    in reply to: Disable mDNS traffic #30141
    Avatarbsper2
    Participant

    Ok, I’ve put in a request to get this log information cleared for sending outside our environment. If that goes through I will send the logs.

    in reply to: Disable mDNS traffic #29514
    Avatarbsper2
    Participant

    Hello irek,

    Correct 10.156.1.13 is the server where I have tried to disable the network broadcasts.

    I’ve logged into all five of our servers running NoMachine and confirmed that the “Don’t show other computers on the network” player preferences setting was already unchecked. Also verified all servers had the “Advertise this compute on the local network” setting unchecked.

    Also made sure this was turned off on the one client desktop which is sitting on the same network that the NoMachine servers sit on. All other clients which connect to these NoMachine servers are on a separate network. They come in through a tunnel with a firewall setup between them which will block all broadcast traffic. So I wouldn’t expect the broadcasts coming from the servers are a response to some type of network traffic they are receiving.

    in reply to: Disable mDNS traffic #29301
    Avatarbsper2
    Participant

    After turning on EnableServerPreferences in node.cfg and opening the Server Preferences window, I can confirm that the “Advertise this compute on the local network” was already unchecked.

    Next I will collect the logs and config and send a message to the email you provided. Will update ticket if we have a break-through.

    in reply to: Disable mDNS traffic #29175
    Avatarbsper2
    Participant

    Thanks for the assistance.

    Can confirm that nxserver has been restarted after setting ‘EnableNetworkBroadcast 0’ in server.cfg

    My environment requires change control, so I will be seeking approval to make changes to the debug level as well as setting ‘EnableServerPreferences 1’ in node.cfg. Once the change is approved I will email the server.cfg and log files as requested.

    Testing can be done with tcpdump. I run ‘tcpdump -ani eno2 port 5353’ (where eno2 is my interface name), and this is the type of output I get:
    10:29:08.286066 IP 10.156.1.13.mdns > 224.0.0.251.mdns: 0 PTR (QM)? _nomachine._tcp.local. (39)
    10:29:08.286081 IP 10.156.1.13.mdns > 224.0.0.251.mdns: 0 PTR (QM)? _nomachine._tcp.local. (39)
    10:29:08.286083 IP 10.156.1.13.mdns > 224.0.0.251.mdns: 0 PTR (QM)? _nomachine._tcp.local. (39)
    10:29:09.286597 IP 10.156.1.13.mdns > 224.0.0.251.mdns: 0 PTR (QM)? _nomachine._tcp.local. (39)
    10:29:09.286610 IP 10.156.1.13.mdns > 224.0.0.251.mdns: 0 PTR (QM)? _nomachine._tcp.local. (39)
    10:29:09.286613 IP 10.156.1.13.mdns > 224.0.0.251.mdns: 0 PTR (QM)? _nomachine._tcp.local. (39)

Viewing 5 posts - 1 through 5 (of 5 total)