buzz

Forum Replies Created

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • Avatarbuzz
    Participant

    Hello,

    I’m not a commercial user, so I do not have the ability to access NM via SSH. I can only use NX.

    Regardless, I had rebooted numerous times, uninstalled and reinstalled NM.

    And then it worked again.

    Thank you,

    buzz

    Avatarbuzz
    Participant

    This is resolved.

    I still do not know what caused the problem initially, but I found that, even though the nxserver.service was running, the server was in “stopped” status.

    On the host machine, which is usually headless, I used the NM 7.2.3 UI to enable the server, and it is now working as expected.

    If I did not have access to the server directly, how could I have started the server from a remote machine with SSH and FTP access to the server?

    Thank you,

    buzz

    Avatarbuzz
    Participant

    Hello,

    Thank you for your reply.
    I followed your instructions, and the resulting zip file contained 31 files in 31 folders.
    I am not able to review each file for private information I do not wish to share, so I will not send them.

    The problem still exists, and I completed a clean install of NM 7.2.3 this morning.

    However, I confirmed that:
    1. /usr/bin/startxfce4 is the correct command to start x on my system
    2. I connected a monitor to my server and launch x with this command
    3. I then attempted to connect to the active desktop with NM 7.2.3
    4. I received the same error after I entered my username and password
    5. Even with the desktop open on the server, the client still said it could not find the session and asked if I wanted to create a new one
    6. I selected yes, and the connection failed anyway

    I uninstalled NoMachine, deleted all remaining nx or NoMachine files and folders, installed NM 7.2.3 again.

    I still cannot connect–even with an x session running.

    I pulled this from the log at /usr/NX/etc/nxerror.log:
    18712 18712 06:56:51 804.193 Redis: Server started, Redis version 3.0.7.
    18712:signal-handler (1615039011) Received SIGTERM scheduling shutdown...
    18712 18712 06:56:51 904.587 Redis: User requested shutdown....
    18712 18712 06:56:51 904.636 Redis: Saving the final RDB snapshot before exiting..
    18712 18712 06:56:51 906.623 Redis: Redis is now ready to exit, bye bye....
    19061 19061 06:56:53 236.194 Redis: Server started, Redis version 3.0.7.
    19061 19061 06:56:53 236.426 Redis: DB loaded from disk: 0.000 seconds.
    19061 19148 06:56:55 303.275 ServerNetworkInfoHandler: WARNING! Obtaining network data failed with result -7.
    19061 19274 06:59:18 465.895 ServerNetworkInfoHandler: WARNING! Obtaining network data failed with result -7.
    19061:signal-handler (1615039359) Received SIGTERM scheduling shutdown...
    19061 19061 07:02:39 948.893 Redis: User requested shutdown....
    19061 19061 07:02:39 948.929 Redis: Saving the final RDB snapshot before exiting..
    19061 19061 07:02:39 953.782 Redis: Redis is now ready to exit, bye bye....
    19061 19061 07:02:39 956.906 HostDescriptorClose: WARNING! Descriptor FD#42 is invalid.
    388 388 07:03:03 650.698 Redis: Server started, Redis version 3.0.7.
    388 388 07:03:03 651.832 Redis: DB loaded from disk: 0.001 seconds.
    388 504 07:03:03 924.631 LocateClient/NameClient: WARNING! Ignoring empty command in context [AA].
    Warning: Ignoring empty command in context [AA].
    388 506 07:03:03 939.849 ServerNetworkInfoHandler: WARNING! Obtaining network data failed with result -3.
    388 549 07:03:04 183.825 ServerNetworkInfoHandler: WARNING! Obtaining network data failed with result -3.
    388 793 07:03:14 550.584 ServerNetworkInfoHandler: WARNING! Obtaining network data failed with result -7.
    388:signal-handler (1615039949) Received SIGTERM scheduling shutdown...
    388 388 07:12:29 541.913 Redis: User requested shutdown....
    388 388 07:12:29 542.030 Redis: Saving the final RDB snapshot before exiting..
    388 388 07:12:29 547.905 Redis: Redis is now ready to exit, bye bye....
    388 388 07:12:29 549.499 HostDescriptorClose: WARNING! Descriptor FD#35 is invalid.
    1572 1572 07:12:30 006.369 Redis: Server started, Redis version 3.0.7.
    1572 1572 07:12:30 006.596 Redis: DB loaded from disk: 0.000 seconds.
    1572 1600 07:12:32 075.226 ServerNetworkInfoHandler: WARNING! Obtaining network data failed with result -7.
    1572 1633 07:13:14 584.580 ServerNetworkInfoHandler: WARNING! Obtaining network data failed with result -7.

    I have no firewall running on this server (it’s just for home use). I also checked to see which ports were in use by nxserver:
    # ss -lntup
    Netid        State         Recv-Q        Send-Q         Local Address:Port      Peer Address:Port        Process
    udp          UNCONN        8448          0              172.17.0.1:5353         0.0.0.0:*            users ("nxserver.bin",pid=1572,fd=37))
    udp          UNCONN        8448          0              192.168.1.120:5353      0.0.0.0:*            users:(("nxserver.bin",pid=1572,fd=36))
    udp          UNCONN        0             0              0.0.0.0:5353            0.0.0.0:*            users:(("nxserver.bin",pid=1572,fd=35))

    and

    # lsof -i

    nxserver. 1572        nx   20u  IPv4  24826      0t0  TCP localhost.localdomain:24950 (LISTEN)
    nxserver. 1572        nx   35u  IPv4  24828      0t0  UDP *:mdns
    nxserver. 1572        nx   36u  IPv4  24841      0t0  UDP myBox.localdomain:mdns
    nxserver. 1572        nx   37u  IPv4  24842      0t0  UDP myBox:mdns

    Thank you for your help!

    buzz

    in reply to: Unable to contact settings server #19774
    Avatarbuzz
    Participant

    Hi, kroy,

    I modified the node.cfg file per your instructions, and my problem is resolved!  Thank you!

    Do you have an idea why this change is required?  I’ve been connecting to this machine via NoMachine for years, so I am curious what changed recently to require this update to the NoMachine configuration.

    Thank you again!

    buzz

    in reply to: Unable to contact settings server #19752
    Avatarbuzz
    Participant

    Hi, BritGirl,

    I just emailed the log files to you at the address you provided.

    Again, thank you for helping me with this!

    buzz

Viewing 5 posts - 1 through 5 (of 5 total)