Cato

Forum Replies Created

Viewing 14 posts - 106 through 119 (of 119 total)
  • Author
    Posts
  • in reply to: NoMachine Service failing on Windows 64 #8748
    AvatarCato
    Contributor

    Hello jgaalmeida,

    NoMachine curently doesn’t support domain users log-in when there’s no active connection to domain controller. We’re currently working on enabling log-in based on local domain cache. You wrote that you’ve never been able to establish connection to your host using NoMachine, I assume that you tried when connection to Active Directory server was established too.

    I recommend that you upgrade your NoMachine installation to the latest version. This might not fix your issue, but we will make sure that other already solved problems are gone. Next reproduce the problem when connected to domain controller, check also if similar problem occurs when local account is in use. After all send us new set of logs.

    Replying to your question, location of user’s profile has no influence on obtaining user’s Security Identifier, access to DC is what matters.

    • This reply was modified 5 years, 4 months ago by AvatarCato.
    in reply to: Can’t stop the service #8369
    AvatarCato
    Contributor

    Hello KeddeX,

    Answers to following questions might help us to solve your problem:

    1. Is your Windows host part of Windows domain?
    2. Are you logged on administrator account when you’re trying to disable NoMachine services?
    3. Are you providing credentials of user who is currently logged to Windows desktop?

    In addition, please gather client and server logs from affected host using manual from https://www.nomachine.com/AR10K00697.
    You can send them to forum[at]nomachine[dot]com.

    • This reply was modified 5 years, 5 months ago by AvatarCato.
    in reply to: Connect from Windows to Linux machine #7380
    AvatarCato
    Contributor

    Hello alaios,

    Please, reproduce the issue and gather both client and server logs according to instrunctions from https://www.nomachine.com/AR07K00677.
    Send them to forum[at]nomachine[dot]com.

    in reply to: No valid admin password #7379
    AvatarCato
    Contributor

    Hello noxav,

    Please gather server and client logs, after authentication failure, using instructions from https://www.nomachine.com/AR07K00677 and send them to forum[at]nomachine[dot]com.

    in reply to: Login fails to Administrator in Win 8.1 #7319
    AvatarCato
    Contributor

    Hello Craig,

    Make sure that you’re using credentials of current desktop owner. If you want to use domain administrator credentials, you need to log-on to Windows desktop as domain administrator and than authenticate in nxclient’s GUI, if you want to use local administrator credentials, you need to log-on as local administrator. Furthermore, it is not allowed to use blank password account. These constraints won’t be present in NoMachine 5 any more, which uses native Windows behaviour during nxclient’s authentication (if your system allows blank password auth, so will nxclient, the same applies to using credentials of other administrator).

    If your problem is different, check these two threads describing similar issues:

    https://www.nomachine.com/forums/topic/admin-changes
    https://www.nomachine.com/forums/topic/windows7-to-windows7-authentication-issue,

    If you still can’t find anything useful, please gather server and client logs using instructions from https://www.nomachine.com/AR07K00677 and send them to forum[at]nomachine[dot]com.

    in reply to: Windows7 to Windows7 – Authentication issue #6736
    AvatarCato
    Contributor

    Hello ammar,

    Logs indicate that Windows does not recognise account, you’re trying to use during NoMachine connection.

    There are two possible reasons of such behaviour which are known to me:

    1. You changed your account name and you’re trying to use new username.
    Check this thread: https://www.nomachine.com/forums/topic/admin-changes for reference.

    2. You’re trying to use domain account.
    If this is the case, you need to provide username in one of two following formats:
    ‘<username>@<domainname>’, or ‘<domainname>\<username>’.

    If you’re 100% sure that none of these applies to you, and you use administrator account for connection, do the following:

    1. Physically log on Windows account you’re trying to use for NoMachine connection.

    2. Click on grey NoMachine icon in toolbar. Select ‘Show the server status’, click on ‘Server preferences’.

    3. Click on small padlock icon in the bottom left corner.

    4. Provide the same credentials you’re using for NoMachine connection.

    Let me know, if you’re able to unlock the padlock. List of processes you sent looks ok, however, these are instructions to properly restart nxserver:

    1. Open command line as administrator. Open Windows ‘Start’ menu, type ‘cmd’ in search box, click right mouse button on ‘cmd’ icon,
    click on ‘Run as administrator’.

    2. Enter bin subdirectory of NoMachine installation dir: ‘cd <path_to_NoMachine_installation_dir>\bin’. Run ‘nxserver –restart’ command.

    in reply to: Windows7 to Windows7 – Authentication issue #6709
    AvatarCato
    Contributor

    Hello ammar,

    I would like to see more detailed list of NoMachine processes.
    In Task Manager click on ‘View’, choose ‘Select columns’ and check ‘Command line’ option. Take screenshot of the list of processes as you did before, including content of ‘Command line’ column. Gather the logs following this guide: https://www.nomachine.com/AR07K00677.
    Next, please restart nxserver. If the problem persists, gather the logs again. Send logs and list of processes to forum[at]nomachine[dot]com even if the problem is gone after restart.

    • This reply was modified 5 years, 11 months ago by AvatarCato.
    • This reply was modified 5 years, 11 months ago by AvatarBritgirl.
    • This reply was modified 5 years, 11 months ago by AvatarBritgirl.
    • This reply was modified 1 year, 2 months ago by AvatarBritgirl.
    in reply to: GNOME Keyring: automatic unlocking #6531
    AvatarCato
    Contributor

    Hello,

    currently NoMachine virtual sessions don’t support pam_gnome_keyring functionality.
    We’ll evaluate whether it’s possible to add support for it, but at a glance it would mean making architectural changes, which means adding such a feature isn’t as easy as it looks.

    in reply to: Admin changes? #6530
    AvatarCato
    Contributor

    Hello PegasusRider,

    Changing account name in Control Panel has only cosmetic effect, exactly as you noticed. Windows internally identifies users with Security
    Identifiers, and SID of your user is still mapped to old username. It seems that there’s way of remapping it to the new one. Please, be aware that this solution wasn’t thoroughly tested, and might cause unexpected behaviour in the future.

    1. Click on Start \ Run, type in ‘netplwiz’ and press ‘Enter’.
    2. In the list of users, select username you want to modify (your old username should be there).
    3. Select properties.
    4. Modify ‘Username’ field and click on ‘Apply’ button.

    You will have to log out and log in, for changes to take effect.
    NoMachine authentication should work fine, with new name after changes.

    in reply to: Authentication failing with server configured for LDAP #6307
    AvatarCato
    Contributor

    Hello sethgali,

    we need additional information to investigate the issue.
    Please, enable debug logs in pam_krb5 module.

    To do so:

    Find file in which pam_krb5.so module is explicitly included. Default NoMachine configuration resides in ‘/etc/pam.d/nx’ file.
    It contains ‘auth include su’ line, which means that auth stack is taken from su command configuration. Su configuration
    most likely includes stacks from other files, so you need to follow ‘include’ instructions until you find the entry:

    ‘auth <control flag> pam_krb5.so <options>’

    Add ‘debug’ as the last option.

    Set the log levels to 7 in NoMachine server, according to instructions: https://www.nomachine.com/AR07K00677.
    Reproduce the issue, gather NoMachine server-side logs, as well as system log file to which pam_krb5 writes (should be auth.log),
    and send them to forum[at]nomachine[dot]com referencing your topic.

    in reply to: Domain or admin password not accepted #6110
    AvatarCato
    Contributor

    Hello Scool,

    We failed to reproduce the issue described by you. However, similar behavior occurs when either username
    or domainname are misspelled.

    NoMachine supports 2 formats of domain usernames:

    1. <domain>\<username>

    2. <username>@<domain>

    Please, make sure that credentials provided by you are valid.

    If the problem persists, gather logs, following the instructions described here:

    https://www.nomachine.com/AR07K00677

    and send them to forum[at]nomachine[dot]com referencing your topic.

    in reply to: Can’t start nxserver after setting ldap #5172
    AvatarCato
    Contributor

    Hello locutus,

     

    We’re glad that you manage to solve the problem. Thank you for sharing the solution.

    We will add proper article on ldap configuration to our knowledge base.

    in reply to: Windows XP 32 bits installation freezes #5119
    AvatarCato
    Contributor

    Hello avalcarcel,

    When installing, it is always better to wait. Only if it seems to be
    stuck at the same point for at least 10 minutes, you should make
    sure you gather the installation logs before killing any of the
    subprocesses.

    The installation log should be found in “Documents and Settings\
    <username>\Local settings\Temp\”. The name of file will be “Setup Log
    <date>.txt”.

    The other log files are located in “Documents and Settings/All
    Users/NoMachine/var/log”.

    Please send logs to issues[at]nomachine[dot]com.

     

    AvatarCato
    Contributor

    Hello henrik,

    Unfortunately, assigning LDAP users to local groups, using pam_group module is currently not supported.
    We created TR:  https://www.nomachine.com/TR08L04515 and are going to deal with this issue.

    Thanks for reporting.

Viewing 14 posts - 106 through 119 (of 119 total)