dadinck

Forum Replies Created

Viewing 1 post (of 1 total)
  • Author
    Posts
  • in reply to: Permission to connect not working #23702
    Avatardadinck
    Participant

    The version I had originally was 6.7.6 (6.7.6_7?) on Windows 10 and 6.7.6_11 on Fedora 29. I thought it was a nice feature that the server will ask the user “in attendance” anyway. I wonder if this is because of persistent sessions?

    So, in looking through the /usr/NX/etc/server.cfg, I noticed in the comments that PhysicalDesktopAuthorization actually has 3 values, 0, 1, and 2. A check box can only set 0 and 1.

    A value of 2 means even the administrator needs to be approved by the desktop owner.

    The output of grep PhysicalDesktopAuthorization /usr/NX/etc/server.cfg gives

    PhysicalDesktopAuthorization 1

    So, I will have to go with the current behavior which is that the same user does not need permission. It would be nice to have the option so that NoMachine will always ask. (attended remote desktop) I would feel safer that way.

    I was connecting with the same account as the user that was logged in. In fact when I used a different account I did get the permission to connect popup window. But, on v 6.7.6, I was also given the permission popup window for the same user.

    1. Did not add any user as trusted afaik. Only approved the connection.

    2. Server was not on the login window.

    3. Windows user and linux user both have admin privileges.

     

     

Viewing 1 post (of 1 total)