danslak

Forum Replies Created

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • in reply to: Black screen on connection to headless CentOS 7 NoMachine #21506
    Avatardanslak
    Participant

    Thanks very much for the info and the link. I followed the instructions in the article, and got the first method working (“turn LLVMpipe ON”), and the desktop is responsive. To get this to work, I did have to ensure the display manager (gdm) was shut down, otherwise NoMachine would provide only the option to connect to physical desktop, which was again just blank.

    I did try the second method also, but no luck, still just blank screen on connecting to the physical desktop. One step of the process did suggest a possible problem (see IMPORTANT NOTE at the end):

    /etc/NX/nxserver –virtualgl-install
    NX> 900 … Modifying /etc/security/console.perms to disable automatic permissions
    NX> 900     for DRI devices …
    NX> 900 … Creating /etc/modprobe.d/virtualgl.conf to set requested permissions for
    NX> 900     /dev/nvidia* …
    NX> 900 … Attempting to remove nvidia module from memory so device permissions
    NX> 900     will be reloaded …
    NX> 900 … Granting write permission to /dev/nvidia-modeset /dev/nvidia0 /dev/nvidiactl for all users …
    NX> 900 … Granting write permission to /dev/dri/card0 for all users …
    NX> 900 … Modifying /etc/X11/xorg.conf.d/99-virtualgl-dri to enable DRI permissions
    NX> 900     for all users …
    NX> 900 … /etc/X11/xorg.conf has been saved as /etc/X11/xorg.conf.orig.vgl …
    NX> 900 … Modifying /etc/X11/xorg.conf to enable DRI permissions
    NX> 900     for all users …
    NX> 900 … /etc/gdm/Init/Default has been saved as /etc/gdm/Init/Default.orig.vgl …
    NX> 900 … Adding xhost +LOCAL: to /etc/gdm/Init/Default script …
    NX> 900 … Enabling XTEST extension in /etc/gdm/custom.conf …
    NX> 900 … Setting default run level to 5 (enabling graphical login prompt) …
    NX> 900 … Commenting out DisallowTCP line (if it exists) in /etc/gdm/custom.conf …
    NX> 900 Done. You must restart the display manager for the changes to take effect.
    NX> 900 IMPORTANT NOTE: Your system uses modprobe.d to set device permissions. You
    NX> 900 must execute rmmod nvidia with the display manager stopped in order for the
    NX> 900 new device permission settings to become effective.

    I attempted to execute the “rmmod nvidia”, but this fails:

    # rmmod nvidia
    rmmod: ERROR: Module nvidia is in use by: nvidia_modeset

    This is after shutting down gdm. I get the same error if do rmmod -f. So perhaps this is preventing this method from working properly…

    First method might be ok for now, as long as applications such as MATLAB can still access the GPU (for computation, not rendering)…I’ll have the user check.

    Otherwise, sounds like getting a dongle is maybe the easiest solution?

    in reply to: Errors with 6.0.78 on Ubuntu 16.04 #17549
    Avatardanslak
    Participant

    Ok, thank you! This set me on the right path, looking at X processes – it appears to be working fully correctly now for the first time since I switched to Ubuntu a few years ago!

    Xvfb was not the culprit, although it did not need to be running. It was just a remnant from something I’d run a few weeks ago. (it would cause a X display option :25 to appear in nxplayer when you try to connect, along with root and user options, but the :25 one never got you anywhere).

    I attempted to track down the process you mention (any pids associated with the nxexec line), but by the time I was looking for that, the problem disappeared. And I would need one of those crashes (after having saved a process listing) to see what pid was being referred to. So not quite sure what was going on there.

    But in any case, there were two problems: light-locker (screen lock utility, which had been installed by default, either with Ubuntu or MATE desktop), and an IBM BigFix agent that is required to run on this machine. The BigFix agent has a process XBESClientUI, which apparently confuses nxserver. This is solved if you simply stop besclient, restart nxserver, then restart besclient (or I suppose if I fix the order they start after boot, this would be solved permanently); nxserver needs to start before besclient. Without that fix, you cannot login (maybe this was the source of the crashes?).

    As for light-locker, once I removed that, the double-login problem disappeared. With that problem, when the machine screen locks, light-locker appears uses some different X display to provide the unlock screen (which looks like the initial login screen), and apparently this is a problem for nomachine because you first need to connect to that x display to unlock, but your desktop is on a different x display. At least, thats my interpretation: in that situation, after you connect the client/nxplayer, you then need to select the root X display (there’s a root option, and a user option), which brings you to the unlock screen, where you put in your password, but then the screen goes blank. You then need to close nxplayer, restart it, and then you’re logged in. But now, with light-locker uninstalled, I get a different unlock screen (mate-screensaver maybe?), and upon entering password, I’m immediately back to my desktop, no need to close nxplayer / restart.  HUGE improvement!

    So key points:

    1. uninstall light-locker

    2. make sure nxserver starts AFTER besclient (IBM BigFix client). (or perhaps anything else that leaves a process running with an X in the name?)

    Hopefully that is it and I’m good for now…

    Avatardanslak
    Participant

    Yes – thank you! If I turn off the besclient service, and then restart nxserver, I can access with no problems whatsoever. I can then turn besclient service back on, and I can continue to connect, for some time (hours..not quite sure how many, but not overnight…), but at some point, besclient interferes again, and I then need to turn it off and restart nxserver to be able to connect.

    Based on the logs I sent, do you have any suggestions on workarounds to allow besclient to not interfere with nxserver? To be clear, they can both be running, as long as nxserver was started first, and connections work, for a number of hours. But then this breaks down and I get the error stating no display is available.

    Avatardanslak
    Participant

    Ok, I’ve just now submitted the logs to the email address above.

    Avatardanslak
    Participant

    Quick update: after composing the above post, the NoMachine login page then listed an available X server: “Physical display, root, Ubuntu X server on :1 0 “, instead of “no available sessions on this server” . I selected this server, which then got me back to the MATE login screen, and then (after waiting a few minutes, disconnecting, and then connecting again) back to the “no available sessions on this server” message.  Typically in the past, getting the root X server was good news, as this would let me in. (vs the username X server, which would not).

    Avatardanslak
    Participant

    Thanks for the suggestions. A day or two after making the above post, it of course began working perfectly, without requiring the double-connection, and with none of the warnings/errors about available display. It had not ever worked seamlessly like that in MANY months. Unfortunately, it did not last, and am back in the originally described scenario above.  (despite many reboots and nxserver restarts).

    Below are some of the error messages from nxerror.log. First I’ll post some lines that repeat every ~30 seconds, even when I’m not making any attempts to connect (nor have since last system reboot):

    2220 18237 20:25:19 372.490 HostWmRunningHelper: WARNING! Failed to open display ‘:0’.
    Invalid MIT-MAGIC-COOKIE-1 key2220 18256 20:25:19 385.917 HostWmRunningHelper: WARNING! Failed to open display ‘:0’.
    Invalid MIT-MAGIC-COOKIE-1 key2220 18257 20:25:19 386.373 HostWmRunningHelper: WARNING! Failed to open display ‘:0’.
    … (8 repeats of above line) …
    Invalid MIT-MAGIC-COOKIE-1 key2220 18266 20:25:19 389.330 HostWmRunningHelper: WARNING! Failed to open display ‘:0’.
    25710 25710 20:25:23 481.689 Io/Io: WARNING! Can’t find pid monitor for 18375.
    No protocol specified

    When I attempted to login tonight (during which I get to, and past, the MATE login screen), there’s also a message about display :1 (which I assume is the login screen? although it does “open” as I see it and enter my username/pw), but then back to the display :0 warnings, and other errors at the end of the connection attempt:

    Invalid MIT-MAGIC-COOKIE-1 key2220 17855 20:24:49 087.901 HostWmRunningHelper: WARNING! Failed to open display ‘:0’.
    Invalid MIT-MAGIC-COOKIE-1 key2220 17856 20:24:49 088.269 HostWmRunningHelper: WARNING! Failed to open display ‘:0’.
    Invalid MIT-MAGIC-COOKIE-1 key2220 17857 20:24:49 088.630 HostWmRunningHelper: WARNING! Failed to open display ‘:0’.
    2220 18218 20:25:19 357.383 HostWmRunningHelper: WARNING! Failed to open display ‘:1’.
    /usr/bin/xauth:  file /var/run/lightdm/root/:1 does not exist
    No protocol specified
    2220 18237 20:25:19 372.490 HostWmRunningHelper: WARNING! Failed to open display ‘:0’.
    Invalid MIT-MAGIC-COOKIE-1 key2220 18256 20:25:19 385.917 HostWmRunningHelper: WARNING! Failed to open display ‘:0’.

    Invalid MIT-MAGIC-COOKIE-1 key2220 18265 20:25:19 389.086 HostWmRunningHelper: WARNING! Failed to open display ‘:0’.
    Invalid MIT-MAGIC-COOKIE-1 key2220 18266 20:25:19 389.330 HostWmRunningHelper: WARNING! Failed to open display ‘:0’.
    25710 25710 20:25:23 481.689 Io/Io: WARNING! Can’t find pid monitor for 18375.
    No protocol specified
    2220 18310 20:25:23 548.219 HostWmRunningHelper: WARNING! Failed to open display ‘:0’.
    Invalid MIT-MAGIC-COOKIE-1 key2220 18319 20:25:23 563.214 HostWmRunningHelper: WARNING! Failed to open display ‘:0’.
    Invalid MIT-MAGIC-COOKIE-1 key2220 18320 20:25:23 563.920 HostWmRunningHelper: WARNING! Failed to open display ‘:0’.
    Invalid MIT-MAGIC-COOKIE-1 key2220 18321 20:25:23 564.486 HostWmRunningHelper: WARNING! Failed to open display ‘:0’.

    kdestroy: No credentials cache found while destroying cache
    Info: Handler started with pid 18846 on Tue Oct 24 20:27:00 2017.
    Info: Handling connection from <MYIP> port 52463 on Tue Oct 24 20:27:00 2017.
    nxexecRemoveKerberosTicket: WARNING! Can’t remove ticket.
    nxexecRemoveKerberosTicket: Error is No such file or directory.
    Info: Connection from <MYIP> port 52463 closed on Tue Oct 24 20:27:39 2017.
    Info: Handler with pid 18846 terminated on Tue Oct 24 20:27:39 2017.
    Error: Invalid user .
    Info: Handler started with pid 19116 on Tue Oct 24 20:27:44 2017.
    Info: Handling connection from <MYIP> port 52490 on Tue Oct 24 20:27:44 2017.
    nxexecRemoveKerberosTicket: WARNING! Can’t remove ticket.
    nxexecRemoveKerberosTicket: Error is No such file or directory.

    Does any of that look particularly suspect or have a known solution?

    Avatardanslak
    Participant

    Ah….thanks very much, after uninstalling, then manually removing the install directories /usr/NX, and reinstalling, its working again!

     

Viewing 7 posts - 1 through 7 (of 7 total)