defactoman

Forum Replies Created

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • Avatardefactoman
    Participant

    Yea the situation I find myself in is not ideal.   The problem is i’m using Gnome Desktop with CentOS 7.  I have a timer to automatically log out the user when the it’s been idle for an hour.  The problem is some of the time when it does this, a session never becomes available again.

    My only workaround has been to use “systemctl set-default multi-user.target” to turn off the gnome at boot (no local desktop).  Once I do this, NoMachine recognizes that gnome isn’t working, and does its thing.  This actually works great since I have users logging on and off all day.

    I can’t tell if this is a gnome issue or a NoMachine not liking the way gnome logs me out.   I’ll peruse with support if I decide to move forward with this and purchase the evaluation.   I have a knowledge deficit in the area of how NoMachine works with Gnome on CentOS.   “gdm” is running and gnome desktops load, but apparently…no sessions available.  I figured this would be enough to be configured correctly, but alas it is not.

     

    No session data is being developed, because no desktops are available.

    No logs are being generated in the /usr/NX/var/log that have any clues as to why no sessions are being generated.

     

    So in the end, im back to simply letting NoMachine start its sessions, and locking down server.cfg.

     

     

    Avatardefactoman
    Participant

    My current solution to this is to mark the server.cfg on the desktop system as immutable with “CreateDisplay 0” set.  NoMachine thankfully handles this without user interrupting errors.  However this comes at an obvious cost that I can’t make changes on the fly using the GUI and who knows what other side effects down the road.

     

    Hopefully there is some way to avoid this,  but if someone else is seeing this, it’s an option.

     

     

Viewing 2 posts - 1 through 2 (of 2 total)