ewired

Forum Replies Created

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • in reply to: Can’t change server settings #27788
    Avatarewired
    Participant

    I uninstalled NoMachine by following this:

    https://askubuntu.com/questions/583547/how-to-uninstall-nomachine

    Then, I reinstalled NoMachine according to the guide for my distribution. So far, this issue is solved for me and I’m able to connect to my physical display. I was hoping I wouldn’t have to reinstall, but thankfully the process to uninstall and reinstall NoMachine is very quick and I should have tried it sooner. Thanks!

    in reply to: Can’t change server settings #27787
    Avatarewired
    Participant

    I applied the fix found in this thread:

    https://forums.nomachine.com/topic/authentication-failed-with-error-7

    chmod u+s /usr/NX/bin/nxexec

    This allows me to manage server settings without being prompted for a user, and to connect to the server again. However, it does not detect any displays and prompts to create a new one which is not my physical display. The NoMachine tray icon still does not show up even after a reboot, although nxclient –admin does report that the server is running.

    in reply to: Can’t change server settings #27786
    Avatarewired
    Participant

    I am getting (ALL) ALL for sudo -l on the remote machine.

    Tailing $HOME/.nx/*/session, no new errors are produced when connecting to the remote.

    Tailing /usr/NX/var/log/nxerror.log, some errors are produced when connecting to the remote:

    Info: Handler started with pid 132450 on Tue May 26 19:41:58 2020.
    Info: Handling connection from 10.42.0.1 port 48780 on Tue May 26 19:41:58 2020.
    132497 132497 19:44:48 001 nxexecPAMCheckCredentials: ERROR!Authentication failed with error 7.
    Info: Connection from 10.42.0.1 port 48780 closed on Tue May 26 19:44:48 2020.
    Info: Handler with pid 132450 terminated on Tue May 26 19:44:48 2020.

    10.42.0.1 is local, 10.42.0.151 is remote.

    I also noticed some logs before I attempted connecting when reading the tail of the log file, but these are not reproduced on reconnect:

    130078 130078 18:50:00 947 nxexecExecute: ERROR! Cannot execute '/usr/NX/scripts/restricted/nxenvironmentget.sh': Permission denied.
    130083 130083 18:50:00 955 nxexecExecute: WARNING! Can't set suplementary groups.
    130083 130083 18:50:00 955 nxexecExecute: WARNING! Error is 1.
    130083 130083 18:50:00 955 nxexecExecute: ERROR! Cannot execute '/usr/NX/scripts/restricted/nxenvironmentget.sh': Permission denied.
    130088 130088 18:50:00 963 nxexecExecute: WARNING! Can't set suplementary groups.
    130088 130088 18:50:00 963 nxexecExecute: WARNING! Error is 1.
    130088 130088 18:50:00 963 nxexecExecute: ERROR! Cannot execute '/usr/NX/scripts/restricted/nxcookieget.sh': Permission denied.
    130093 130093 18:50:00 971 nxexecExecute: WARNING! Can't set suplementary groups.
    130093 130093 18:50:00 971 nxexecExecute: WARNING! Error is 1.
    130093 130093 18:50:00 971 nxexecExecute: ERROR! Cannot execute '/usr/NX/scripts/restricted/nxenvironmentget.sh': Permission denied.

    I tried to set permissions of /usr/NX/scripts/restricted to 771 but this didn’t fix the issue, connections still fail with the PAMCheckCredentials error.

    in reply to: Can’t change server settings #27521
    Avatarewired
    Participant

    This is happening for me after the latest update yesterday. I’m no longer able to use NoMachine at all on any of my two systems. I wish I could downgrade to the previous version. When running nxclient –admin as root, I see a server running, but it does not allow any user to connect (authentication error). When running nxclient –admin from the menu icon as usual, it does not allow me to change settings, as it now prompts to “Please insert a user with administrative rights” and does not allow any user, even though my user has sudo.

    While NoMachine is out of service, I’m using vino-server which is built into GNOME, and accessing my screen over VNC. I had to start it in the command line because my distro is special, but on Fedora you should be able to go to GNOME settings, then Sharing, enable sharing, then enable screen sharing. This will start a VNC server that you can use from Remmina or KRDC.

    in reply to: A new PulseAudio instance is created #25910
    Avatarewired
    Participant

    Sound is available on all physically connected/installed audio devices until I restart nxserver after logging in. Watching the output of pstree, it appears that a second instance of PulseAudio is being created shortly after the NoMachine player/client connects to the server. I’m working around the problem for now by disabling all audio capability in the NoMachine configuration and I’m using PulseAudio’s built-in ability to forward sound devices over the network with zeroconf discovery/paprefs. After configuring the NoMachine server to not use audio (AudioInterface disabled in node.cfg) there are no extra instances of PulseAudio being created upon connecting to it. I’m using the free edition with no headless servers or virtual displays, I have only ever connected after logging in to the desktop environment fully.

Viewing 5 posts - 1 through 5 (of 5 total)