fisherman

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 226 total)
  • Author
    Posts
  • in reply to: Can’t connect thru internet #41685
    fisherman
    Moderator

    Hello,

    There was a typo in the command. Please use
    To enable logs
    sudo /etc/NX/nxserver --debug --enable all

    To collect logs
    sudo /etc/NX/nxserver --debug --collect

    To disable logs after debug
    sudo /etc/NX/nxserver --debug --disable all

    in reply to: Cannot install NoMachine #40037
    fisherman
    Moderator

    Hello,

    Please can you try to use following link
    curl -fSL "https://www.nomachine.com/free/arm/64/deb" -o nomachine_arm64.deb

    in reply to: Are my settings for connecting over the internet ok? #39320
    fisherman
    Moderator

    Hello,

    Just a note, NoMachine free has ssh port disabled.

    Using a proxy in NoMachine is similar to like using a proxy in Internet browser. If you are using it in your mobile browser, then there is no need to enable proxy functionality in the player connection.

    Issue with error 100 and 111 looks definitely related with the port forwarding not correctly set.

    As i understood you have in your setup ADSL (router), I will name it after router1, then you have second router and I will name it router2, and then NoMachine server. So your expected connection should work in the following flow:
    Mobile ( NoMachine player ) 4G ---> router1 --> router2 --> nxserver

    In this situation you will configure port-forwarding twice to be able to be able to access nxserver
    [router1 - publicIP:54000] --forwarded to --> [router2 publicIP:54000] --forwarded to --> [ nxserver IP:4000 ]

    In my example I mentioned for the router2, the publicIP, is the IP that directly communicates with router1, and as well I used port 54000. You can use other port that is best works for you.

    in reply to: Manjaro -> Ubuntu connection problem #39275
    fisherman
    Moderator

    Can you please execute some commands to collect core stack and send it to us

    coredumpctl list

    You will receive an output like this:

    TIME                          PID  UID  GID SIG     COREFILE EXE                      SIZE
    Thu 2022-07-15 19:48:13 CEST 120316 1000 1000 SIGSEGV present  /usr/NX/bin/nxplayer.bin 2.1M

    then depending on the pid number of the nxplayer crash, please execute:
    coredumpctl gdb 120316 --debugger-arguments="-batch -ex 'thread apply all bt'" > /tmp/crashReport.txt

    then please send us /tmp/crashReport.txt crash report file.

    in reply to: Error 102 over IPv6 when connecting to Windows 7 #39042
    fisherman
    Moderator

    Hello,

    Can you verify if you did correctly enable IPv6 on the Windows XP?

    fisherman
    Moderator

    I am glad that you solved the problem.

    fisherman
    Moderator

    Hi lucasf,

    Sorry for the delay. Can you explain further what you mean with ‘I had a little progress’? As far as we know, with that extension, everything should work even after logging out from the desktop.

    That said, even without the extension, NoMachine should work by using an alternative method to capture the screen. We found a bug in this method that affects your case and it will be fixed in the next NoMachine version.

    fisherman
    Moderator

    if you are using Wayland, can you try to disable it?

    fisherman
    Moderator

    Hi,

    Can you tell me if you have problem with lock screen when using physical or virtual desktop?

    in reply to: Run script after connection and after disconnection #38590
    fisherman
    Moderator

    Please just add your scripts in the node.cfg file, and it will be executed with current logged user.

    in reply to: Run script after connection and after disconnection #38470
    fisherman
    Moderator

    Please check following link for the additional information about possibility and how to run scripts:
    https://knowledgebase.nomachine.com/DT11R00174#11.5

    in reply to: Have shutdown NoMachine and can’t login #38236
    fisherman
    Moderator

    Hello,

    Probably when you did select/ click NoMachine shutdown, you selected “Do not run NoMachine service at the next startup”, and now NoMachine is set to not start automatically after reboot.

    after connecting to the machine use command to startup nomachine and to enable automatic startup.

    sudo /etc/NX/nxserver --startmode automatic
    sudo /etc/NX/nxserver --startup

    More information about start mode you can find here AR04L00800 – Disabling the automatic start-up of NoMachine at boot time

    in reply to: Forcing the server to 1024×768 #38147
    fisherman
    Moderator

    If you are connecting to a host where NoMachine is set to create display, please use currently possible workaround to restrict resize of the display, by setting following key in the server.cfg
    VirtualDesktopMode 1

    in reply to: How to disable Gnome xsession #37786
    fisherman
    Moderator

    I have just tested and following this, we will limit NoMachine to use ONLY xfce4 on the requested node

    On the node “node002.mynet.local”, please update keys in the node.cfg with:

     AvailableSessionTypes unix-xsession-default
    DefaultDesktopCommand /usr/bin/startxfce4

    then on the Enterprise terminal server execute
    nxserver --nodeupdate node002.mynet.local:4000

    in the nodeupdate command you will see output with
    NX> 187 Session types available on node: unix-xsession-default

    unix-xsession-default listed there means that on that specific node, only DefaultDesktopCommand /usr/bin/startxfce4 session will be started.

    If this still does not work, send us your output of the command --nodelist, output of the command --nodeupdate after editing node.cfg file, and node.cfg file from the requested node.

    Please note this that if you have automatic node selection, sessions will be started possibly on the node where gnome is enabled.

    In case you want to disable automatic node selection, please check following document: DT11R00178 – NoMachine Enterprise Terminal Server – Installation and Configuration Guide.

    in reply to: How to disable Gnome xsession #37774
    fisherman
    Moderator

    Please apply requested change in the node.cfg file on the required Terminal Server Node that you want to allow only Xfce4 session.

Viewing 15 posts - 1 through 15 (of 226 total)