fra81

Forum Replies Created

Viewing 13 posts - 646 through 658 (of 658 total)
  • Author
    Posts
  • in reply to: Latest versions, kworker process high CPU #1219
    fra81
    Moderator

    Update:

    we tried on multiple Fedora 19 and Ubuntu 13.10 machines and we reproduced the problem on one of them. The description you gave matches 100%. The source of the problem is in the USB kernel module. Unloading it fixes the CPU problem.

    Edit /usr/NX/etc/node.cfg and set EnableUSBSharing key to “none”. Restart the server with /usr/NX/bin/nxserver –restart. Please confirm that the workaround works.

    in reply to: Latest versions, kworker process high CPU #1218
    fra81
    Moderator

    I’ve noted last versions of Nomachine (maybe the 4.36x series) put a kworker process to high CPU utilization, making almost unusable the remote physical desktop

    For the moment for this release, there have been no changes that may affect CPU usage for quite a while, so I don’t think it’s directly related to changes to the NoMachine software. It seems more connected to a change to the Linux system. This kworker processes are started by the kernel for various reasons, for example to handle I/O or interrupts, except that there is no new I/O or interrupt compared to the software released 1 or 2 months ago.

    Please send the output of the top command taken while somebody is connected to the physical desktop and while the NoMachine system is idle. Take the same output using top -H (this will show the threads one by one). Include the exact version of the Linux kernel you are using (so we can possibly try to reproduce it), the exact version of the NoMachine software and, if possible, the logs on the server (check here how to get them: https://www.nomachine.com/AR07K00677). If there is any thread entering a loop eating CPU it should be easy to find out which one it is from top and the logs.

    in reply to: ALT-GR + tilde, SPACEBAR does not work as it should #1186
    fra81
    Moderator

    See? It was easy. I get the same with the Belgian keyboard. I opened a TR:

    https://www.nomachine.com/TR12K04110

    You can track it and see when it’s resolved.

    in reply to: ALT-GR + tilde, SPACEBAR does not work as it should #1171
    fra81
    Moderator

    Hello

    Just tried on Ubuntu 12.04 in Unity from Windows 7 and worked perfectly fine. Can you tell me more about your environment?

    Please specify the keyboard layout in use on client and on server and also:

    – Whether the problem arises connecting to a physical or a virtual display.
    – Remote and local Windows/Mac/Linux version (Windows XP/7/8, OS X 10.x, Ubuntu xyz, Mint x.y, etc.).
    – If on Linux, desktop version (GNOME. KDE, whatever) on client and on server.

    in reply to: Configuring keyboard #1076
    fra81
    Moderator

    Keyboard in version 3 (in NoMachine products and any other product derived from the same NoMachine version 3 software) worked in a completely different way, compared to version 4. In version 3 the keymaps of the client were uploaded to the agent X server, so that the X applications saw the same X keycodes as stored on the client. In version 4 the keycodes are sent by the client untranslated and the translation happens inside the target X server, according to the keymap selected by the user. This change is obviously for the better and allows the user to simply change the keyboard layout by selecting the keyboard in the control panel of the desktop environment. If you were running a previous version of NoMachine (or an alternative product based on the same NoMachine software), what we suggest is ensuring that you don’t try to load any special keyboard command on the client and that you don’t change the keyboard on the server upon running the NX session, for example to try to correct a keyboard problem encountered running an older NoMachine version.

    Regarding your specific issue, you don’t specify which NoMachine version you run on the server, but we suggest you upgrade to the 4.0.366 since it included one fix that was specifically aimed at solving AltGr keyboard problems.

    fra81
    Moderator

    There doesn’t seem to be anything abnormal in the stats.

    Can you attach also client-side logs? You can find them in the .nx directory in the user’s home.

    fra81
    Moderator

    Have you tried disabling UDP from the Advanced connection settings?

    Also please paste the statistics after a freeze occurred.
    You can take them clicking on the Connection icon of the toolbar.

    in reply to: Closing unexpectedly at least once an hour #882
    fra81
    Moderator

    Please contact us at forum[at]nomachine[dot]com.

    We will send you a patch to test.

    in reply to: how to access windows in Virtual Box with No Machine #724
    fra81
    Moderator

    It’s very likely that you can’t get an additional public IP for free, since you are on a hosted facility. But you may try to create a tunnel to 162.243.14.121 and from 162.243.14.121 to 10.0.2.15 port 4000.

    ssh -R 4500:localhost:4000 user@162.243.14.121

    It won’t work as fast as a direct connection but better than nothing. Be also sure you disable UDP in the connection setup.

    Otherwise I strongly suggest you ask to the help-desk of the provider offering the hosting service.

    in reply to: Seeing double… #672
    fra81
    Moderator

    Hi.
    It looks like a known issue with sharing a 16 bit physical display.

    The bug is tracked in the following Trouble Report:

    https://www.nomachine.com/TR11K04037

    The fix will not be ready for the upcoming release, but you can expect it to be fixed in the next one, which is likely to take place in the next week.

    in reply to: Display setting adjustment? #663
    fra81
    Moderator

    Check if you have a core dump in the home directory of the user owning the session.

    Please also attach the logs files:

    # tar zcf logs1.tar.gz /usr/NX/var/log
    # tar zcf logs2.tar.gz /home/<user>/.nx

    Be sure you include all the information listed here:

    – NoMachine product and version on local and remote machine (free version, Workstation, etc).
    – Whether the problem arises connecting to a physical or a virtual display.
    – Remote and local Windows/Mac/Linux version (Windows XP/7/8, OS X 10.x, Ubuntu xyz, Mint x.y, etc.).
    – If on Linux, desktop version (GNOME. KDE, whatever) on client and on server.

    in reply to: language setting #592
    fra81
    Moderator

    Where did you set that? You must set it on the server, in the target user’s home, not on the client.

    Don’t forget also to export the variable:

    export LANG=”it_IT.UTF-8″

    in reply to: language setting #544
    fra81
    Moderator

    Hi.
    It could be some environment variable that is missing in the start command of your desktop manager.

    Please copy&paste the output of the “env” command, as run in the physical desktop and on the virtual desktop session.

    That is:

    Open a terminal on the physical display and run:
    # env

    Start the new remote desktop session on the NoMachine server.
    Open a terminal and run:
    # env

    Please provide the complete output.

Viewing 13 posts - 646 through 658 (of 658 total)