Gega

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 26 total)
  • Author
    Posts
  • in reply to: Crouton XFCE on Chromebook #25170
    AvatarGega
    Participant

    Hello yinshslin,

    Logs might help to identify your issue, so please enable debug, than restart nxserver:
    nxserver --restart
    run also:
    nxserver --upnpstatus
    and collect logs.
    This article shows how to collect logs: https://www.nomachine.com/DT10O00163

    in reply to: Error is 11 ‘Resource temporarily unavailable’ #24419
    AvatarGega
    Participant

    Problem is caused by lack of resources, do you have enough RAM to run all that sessions? If yes please check also:
    cat /proc/sys/kernel/threads-max
    to see limit on the total number of processes on the system (threads)
    To list also threads you need to add L switch to your ps command. e.g:
    ps -efL | wc -l

    Usually this problem comes out because of limits, specifically “number of processes” limit or “virtual memory” limit. You’ve shown us limits for common user, but as we’ve said before we’re more interested in limits of user “nx”, since it looks like that might be causing this issues. Let’s check limits set for nxserver daemon, since this process is run as user “nx”, to do that firstly run:
    ps -ef | grep "nxserver.bin --daemon"
    Then copy pid of daemon and run:
    cat /proc/<pid>/limits

    If you see that nproc or virtual memory limit are set, than you should set new limits in limits.conf.
    nx soft nproc unlimited
    nx hard nproc unlimited
    nx hard as unlimited
    nx soft as unlimited

    in reply to: Error is 11 ‘Resource temporarily unavailable’ #24398
    AvatarGega
    Participant

    Hello,

    It looks like max user processes limit is reached for user nx, all nxserver processes are run with user “nx”. Your command shows limits for user root, so it doesn’t say much about limits for “nx” or any regular user.

    For the nx user it’s advisable to set ‘unlimited’:
    nx soft nproc unlimited
    nx hard nproc unlimited

    For more information please refer to: https://www.nomachine.com/AR04O00927

    in reply to: Cannot connect, screen sharing is disabled #24237
    AvatarGega
    Participant

    Hello,

    This means that for some reason you’re not allowed to access physical display of current user. This can happen any of this
    three reasons:

    1)LoginScreenAccess is set to 0 in server.cfg and system is in login window state.
    2)You’ve changed settings by clicking on nxclient monitor menu and disabling “Accepting connections”, in this case nxclient monitor
    icon will be grayed out.
    3)PhysicalDesktopSharing from server.cfg is set to either 0 or 2 and connecting user has no permission to access physical display.

    in reply to: Nxerror.log becomes massive #23668
    AvatarGega
    Participant

    Hello,

    Firstly please try this:

    1)Shut down nxserver:
    /etc/NX/nxserver --shutdown

    2)Clean nxerror.log:
    > /Library/Application\ Support/NoMachine/var/log/nxerror.log

    3)Start up nxserver:
    /etc/NX/nxserver --startup

    If nxerror.log still continues to grow, please collect logs and send it to us to investigate and provide proper fix. This article shows how to collect logs: https://www.nomachine.com/DT10O00163
    As a workaround you could redirect all logs written in nxerror.log to null, to do that you need to:

    1)Shut down nxserver:
    /etc/NX/nxserver --shutdown

    2)Remove nxerror.log:
    rm -rf /Library/Application\ Support/NoMachine/var/log/nxerror.log

    3)Redirect nxerror.log to /dev/null:
    cp -a /dev/null /Library/Application\ Support/NoMachine/var/log/nxerror.log

    4)Start up nxserver:
    /etc/NX/nxserver --startup

    in reply to: Disk space taken up with old logfiles #23608
    AvatarGega
    Participant

    Files in /etc/NX/server/localhost/ are used internally and aren’t meant to be modified by user. It’s mainly used to indicate nx installation directory.

    in reply to: Disk space taken up with old logfiles #23598
    AvatarGega
    Participant

    Files in /etc/NX/server/localhost/ are different, these are part of regular nomachine installation so there’s nothing to worry about.

    in reply to: Disk space taken up with old logfiles #23584
    AvatarGega
    Participant

    Hello heywood,

    Several things needs to be done in order to resolve these issues.

    1) To safely clean up ‘/Library/Application Support/NoMachine/var/log/node/’ and user’s .nx directories please run:

     

    nxserver --shutdown

     

    rm -rf log/node

     

    rm -rf /.nx/T-* /.nx/F-* /.nx/R-* /.nx/M-*

     

    nxserver --startup

     

    Please note that by doing this you won’t be clean up whole .nx directory, since some of the files there might be important.

    2) Configuration files are located in: /Applications/NoMachine.app/Contents/Frameworks/etc. Please set SessionLogClean 1 in node.cfg if it’s not 1 already.

    3)These values look weird, so after clean up is done please monitor /Library/Application Support/NoMachine/var/log/node/, if the number of folders is increasing abnormally than it looks like a problem and we’d need logs to find out what goes wrong, here’s an article how to gather logs for in case it’s needed: https://www.nomachine.com/DT10O00163

    in reply to: How does remote command get assembled? #23342
    AvatarGega
    Participant

    Hello capn.freako,

    The command is correctly constructed but it’s not displayed with it’s original form in the logs.

    The only part of this command you can and might want to modify could be ‘/etc/X11/xinit/Xsession default’, but it’s not necessary since the problem isn’t related to the command construction.

    Could you confirm if the Desktop environment is working properly?

    .xsession-errors file in user’s home directory or system logs (such as syslog) might show some more information about why the session application terminates.

    in reply to: 500 ERROR: Cannot connect to the requested session #23258
    AvatarGega
    Participant

    Hello tsher,

    It looks like there’s problem with gnome, there are numerous errors in remote node logs:
    2019-07-10 16:34:12 287.271 18278 NXNODE WARNING! Process ‘/bin/bash -c exec -a – /bin/ksh -c ‘/etc/gdm/Xsession ‘\”gnome-session –session=gnome’\” with pid ‘18316/18316’ finished with exit code 1 after 1,848 seconds.

    .xsession-errors file in user’s home directory or system logs(such as syslog) might show some more information.
    Is that machine headless? Could you confirm that Desktop environment is working properly?

    in reply to: Connection Error #23192
    AvatarGega
    Participant

    Did you follow this link https://www.nomachine.com/AR11L00827 about port mapping? Could you tell us if plain ssh connection from same client to same server works?

     

    Edit: please also refer to https://forums.nomachine.com/topic/problems-connecting-to-one-remote-computer#post-23387

    in reply to: Server.cfg – script does not execute? #23170
    AvatarGega
    Participant

    Hello, looks like there’s some problem in your script:

    2019-07-31 19:54:27 347.045 1139 NXSERVER WARNING! Process ‘/Library/Scripts/cleanup.sh main 192.168.0.77’ with pid ‘1216/1216’ finished with exit code 2 after 0,006 seconds.

    nxerror.log might show some more info. Script will probably fail even if you run it by hand. if you’re unable to fix it, you can post your script here and we could take a look at it.

    in reply to: Connection Error #23169
    AvatarGega
    Participant

    Hello ReEm,

    Are you trying to access NoMachine server over the internet? In that case please take a look at this link: https://www.nomachine.com/getting-started-with-nomachine#internet and follow instructions, you can ask here if you have any further questions.

    in reply to: Limit access to single application #23147
    AvatarGega
    Participant

    Hello ddufour,
    It is possible to restrict users to use certain applications on Linux using profiles, however free version doesn’t support profiles feature, which is required. Take a look into https://www.nomachine.com/DT07M00091 Paragraph 4.1.

    unix-script path to the script Run a virtual session by using the X client script on server as specified by path

    You could disable all other sessions and set unix-script for certain user, that would restrict user to running only specified command.

    in reply to: Server.cfg – script does not execute? #23111
    AvatarGega
    Participant

    Hi catalina,
    First thing to check is if script is executable and user “nx” has permissions to run it. Than check if you correctly set your script into server.cfg e.g:

    UserScriptAfterSessionStart = "/usr/NX/scripts/custom/myScript.sh"

    Do you log in straight onto the machine where you edit server.cfg? You can find more information about custom scripts on this link : https://www.nomachine.com/DT02O00125#11.3.

    If everything looks ok than we’d need to take a look at logs. To do it please uncomment and set the ‘SessionLogLevel 7’ configuration key in the ‘/usr/NX/etc/server.cfg’ than reproduce problem i.e in your case e.g set
    UserScriptAfterLogin = "/usr/NX/scripts/custom/myScript.sh" then connect with NoMachine client and log in.

    Here you can find detailed info on how to gather logs: https://www.nomachine.com/DT10O00163.

Viewing 15 posts - 1 through 15 (of 26 total)