GhsDrakwn

Forum Replies Created

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • AvatarGhsDrakwn
    Participant

    Yes, that worked! Thanks a heap for helping me figure this out.

     

     

    AvatarGhsDrakwn
    Participant

    ls -lt $(whereis gnome-session)
    ls: cannot access gnome-session:: No such file or directory
    -rwxr-xr-x 1 root root 235904 Mar 26  2015 /usr/bin/gnome-session
    -rwxr-xr-x 1 root root 235904 Mar 26  2015 /usr/bin/X11/gnome-session
    -rw-r–r– 1 root root   1515 Mar 26  2015 /usr/share/man/man1/gnome-session.1.gz

    /usr/lib/gnome-session:
    total 48
    -rwxr-xr-x 1 root root 10504 Mar 26  2015 gnome-session-check-accelerated
    -rwxr-xr-x 1 root root 14768 Mar 26  2015 gnome-session-check-accelerated-helper
    -rwxr-xr-x 1 root root 19032 Mar 26  2015 gnome-session-failed

    /usr/share/gnome-session:
    total 28
    drwxr-xr-x 2 root root  4096 Oct 10 09:50 sessions
    -rw-r–r– 1 root root  2504 Mar 26  2015 gsm-inhibit-dialog.ui
    -rw-r–r– 1 root root   692 Mar 26  2015 hardware-compatibility
    -rw-r–r– 1 root root 13073 Mar 26  2015 session-properties.ui
    ls -lt /etc/X11/Xsession
    -rwxr-xr-x 1 root root 3730 Jun 24 2008 /etc/X11/Xsession

    ls -lt /etc/gdm/Xsession
    -rwxr-xr-x 1 root root 6680 Apr 3 2015 /etc/gdm/Xsession

    ls -lt /etc/X11/xinit/Xsession
    ls: cannot access /etc/X11/xinit/Xsession: No such file or directory

    The server doesn’t seem to have /etc/X11/xinit/Xsession, so I tried that key in node.cfg but it didn’t work.

    I tried all of the options you listed at the end, too. They all resulted in a failure to create a new display, and when I restarted the server I got the “NX> 162 WARNING”s, too. I only tried gnome-session and /user/bin/gnome-session. The other two don’t exist.

    AvatarGhsDrakwn
    Participant

    That didn’t work either. I’m sending the logs, but I’ll add the comments here, too.
    This version was installed over NoMachine 3.5, which I was also having trouble getting to work (though I did use NX extensively a few years ago on this server). Ubuntu was originally installed without a DE (if I remember right, it was a long time ago), and I installed gnome while one of the other server’s users installed fluxbox, I think. I use apt-get for installation.

    Thanks for all your help!

    AvatarGhsDrakwn
    Participant

    ls -l /usr/share/xsessions/

    total 20

    -rw-r–r– 1 root root 222 Feb 24  2014 fluxbox.desktop

    -rw-r–r– 1 root root 231 Mar 12  2014 gnome-classic.desktop

    -rw-r–r– 1 root root 216 Mar 26  2015 gnome.desktop

    -rw-r–r– 1 root root 272 Sep 30  2014 gnome-fallback-compiz.desktop

    -rw-r–r– 1 root root 310 Sep 30  2014 gnome-fallback.desktop

     

    I recopied the text you included, too, and no, that didn’t change anything either.

     

    AvatarGhsDrakwn
    Participant

    Okay, so I added the line you suggested into node.cfg and restarted the server, and the client seemed to make more progress. However, as I was going through some graphical options for setup, the connection failed with “Error 134: Protocol error.”

    I changed the settings in node.cfg back to default (DefaultDesktopCommand “/etc/X11/xinit/Xsession default”) and tried again, and got a different error, which is the same as before “Cannot create a new display, please contact your system administrator”. Now it seems like however I try to reproduce error 134, I can’t get back to it. I thought I was getting closer, but I’m back where I was.

    On the server side, when I restart the server after making changes to node.cfg, I am getting these messages:

    sudo /usr/NX/bin/nxserver –restart

    NX> 162 Disabled service: nxserver.

    NX> 162 Disabled service: nxnode.

    NX> 162 Disabled service: nxd.

    NX> 161 Enabled service: nxserver.

    NX> 162 WARNING: Cannot find X servers running on this machine.

    NX> 162 WARNING: A new virtual display will be created on demand.

    NX> 161 Enabled service: nxd.

    The server is headless, perhaps I should add.

    AvatarGhsDrakwn
    Participant

    I’m connecting from Windows 7, to Ubuntu 14.04.5 LTS.

     

Viewing 6 posts - 1 through 6 (of 6 total)