Giorgi-G.

Forum Replies Created

Viewing 15 posts - 106 through 120 (of 147 total)
  • Author
    Posts
  • Giorgi-G.
    Contributor

    Hi,

    Please check whether the nxusb.ko kernel object is compiled on your machine. If not, you will need to compile it. Instructions for checking and ultimately compiling are available here: https://www.nomachine.com/AR12J00658

    There’s nothing else in the attachments that can help us unfortunately. Could you also please send us logs from server and client sides? https://www.nomachine.com/AR10K00697

    in reply to: Does NoMachine support local USB device? #21871
    Giorgi-G.
    Contributor

    For now we can say that you have passed point #1. And the reason why USB device forwarding doesn’t work is that nxusb.ko driver is compiled but not loaded. So you will not be able to forward devices from it or connect devices to that machine.

     

    It’s necessary to check and find one of two possible reasons why it’s not loaded. To that you need to have a root access. And also to fix it you will need to have root access.

    Here are instructions to find out why driver is not loaded:

    Run in terminal following commands:

    sudo insmod /usr/NX/bin/drivers/nxusb.ko

    after:

    tail /var/log/syslog 

    and send us output from terminal.

    in reply to: Does NoMachine support local USB device? #21857
    Giorgi-G.
    Contributor

    The command lsmod | grep nxusb returns nothing.

    Are you sure that before running that command you opened Devices -> Connect USB devices and waited before USB devices list will be loaded?

    About logs – we didn’t receive anything to forum@.

    in reply to: Does NoMachine support local USB device? #21843
    Giorgi-G.
    Contributor

    Hi,

    In that case, I can explain the steps to follow for point #1. Here are instructions for how you can do that without admin rights:

    Connect to remote machine, open terminal on it and type command:

    cat /usr/NX/var/log/nxinstall.log | grep -i usb && ls -l /usr/NX/bin/drivers/

    After go to NM Menu -> Devices -> Connect a USB device and wait 10 seconds till devices appear and type this command in the terminal :

    lsmod | grep nxusb

    And send us file with all output from the terminal.

    Again, the above commands don’t need root access. And they will completely cover point #1.

    It also may be helpful if you send us the logs from remote Linux machine. Because of you don’t have root rights, you will not be able to send us a complete package. But partial logs will be possible.

    To collect them run following command in terminal:

    cd ~/ && tar -czf linux_log.tar.gz /usr/NX/var/log

    That command will report warnings, however don’t worry about them. A linux_log.tar.gz package will be created in your home directory. Send this file to us using forum[at]nomachine[dot]com making sure you reference your topic.

    in reply to: Does NoMachine support local USB device? #21793
    Giorgi-G.
    Contributor

    Do you have root access to your remote Ubuntu?

    Without it you will not be able to check any of that 3 points and the only way is to talk with the administrator of that machine administrator. If you have it – you can just the follow links I sent in my previous post.

    in reply to: Does NoMachine support local USB device? #21780
    Giorgi-G.
    Contributor

    Hi,

    There are 3 possible reasons why it doesn’t work.

    1. USB forwarding kernel object is not compiled. Take a look here https://www.nomachine.com/AR12J00658

    2. Your Linux is running in Secure Boot mode, take a look here https://www.nomachine.com/AR05O00929

    3. On the remote Unix machine, the administrator has disabled USB forwarding/connecting to it and that’s why you can’t forward anything to Unix machine.

    in reply to: USB Sharing greyed out #21777
    Giorgi-G.
    Contributor

    Hi,

    Here is a way that should fit it.

    1. Check whether this file exists on your disk — C:\WINDOWS\system32\drivers\asmthub3.sys

    If yes – USB forwarding will remain disabled.

    2. Check whether this file exists on your disk– C:\Program Files (x86)\NoMachine\etc\node.cfg

    If yes – please attach that file to your forum reply.

    Also check whether you have rights to open and read that file. If you don’t, it will also not work.

    3. Send us output file PC1.txt generated after running this command in command prompt.

    driverquery /V > PC1.txt

    3. Uninstall NoMachine -> Restart machine -> Install NoMachine -> Restart machine again.

    It should work well. If not, please send us new logs.

    in reply to: USB Sharing greyed out #21762
    Giorgi-G.
    Contributor

    First of all you need to restart nxserver after uninstallation of ASMedia USB Drivers. It can be done manually or you can restart whole machine.

    It also matters how you deleted ASMedia USB Drivers. It should be deleted using the original uninstall tool by ASMedia from Programs and Features.

    And can you send us logs from your Windows machine and I will check whether there might be any conflicting drivers that are stopping the nxusb module from working?

    in reply to: Does NoMachine support local USB device? #21733
    Giorgi-G.
    Contributor

    Hi,

    Can you please send us logs from Windows machine (see https://www.nomachine.com/AR10K00697″) and screenshot of Devices -> Connect USB Device panel?

    And also try to forward another USB device, i.e. Flash Drive from your Windows to Ubuntu. Just do that after restart of both machines.

    in reply to: Smart card reader / USB device redirection #21644
    Giorgi-G.
    Contributor

    Hi,

    The thing that you can’t forward even USB flash drive indicates that the issue is not in the smart card reader, it’s probably in the USB forwarding module.

    That’s why we weren’t able to reproduce it because of we were testing Omnikey 3021 USB Smart Card Reader.

    For now we suggest to update NM to the latest version and try to make the following test.

    Connect in NM to remote host. Go to USB forwarding tab, list devices.

    Do you see here local and remote devices listed?

    After close devices tab and type following command in remote Linux terminal:

    lsmod | grep nxusb

    If result is empty – try to type next one command:

    sudo insmod /usr/NX/bin/drivers/nxusb.ko 

    And after repeat first command and send us terminal output.

     

    Also check out this article: https://www.nomachine.com/AR05O00929

    in reply to: Does NoMachine support local USB device? #21424
    Giorgi-G.
    Contributor

    Hi,

    NoMachine supports USB devices forwarding and may allow to forward your USB game controller from your Windows machine to the remote Ubuntu. To do that you need to click on top right corner of screen, after NoMachine session menu will appear click to

    Devices -> Connect USB Device -> Find your game controller in list of Local Devices -> Click on it -> Click Connect.

    After device will be forwarded to remote machine you will see green dot near your device.

    Please have in mind that if you want game controller to work on remote Ubuntu you need to have installed drivers for it on Ubuntu.

    Additionally, if you will not see any devices in Devices -> Connect USB Device panel, it may sign that you have not builded nxusb.ko module n Ubuntu. To build it please follow this article AR12J00658

    in reply to: Installation corrupted, can’t uninstall #21299
    Giorgi-G.
    Contributor

    Hi,

    First of all here are instructions on how to recover corrupted installation:

    For that you need to move:

    C:\Program Files (x86)\NoMachine\etc\server.lic.sample to C:\Program Files (x86)\NoMachine\etc\server.lic

    and also move:

    C:\Program Files (x86)\NoMachine\etc\node.lic.sample to C:\Program Files (x86)\NoMachine\etc\node.lic

    After that you need to run installation file of the NoMachine Free installer with disabled USB forwarding module and update NoMachine installation.

    We will pass a link to the free NoMachine version with disabled USB forwarding module.

    After updating you will be able to use all functionalities of the NoMachine Free version expect USB devices forwarding.

    Also it would be very helpful for us if you could send your Memory Dump File for us to check. Usually it’s located here: %SystemRoot%memory.dmp.

    in reply to: Installing USB Devices gives error code 183 #21254
    Giorgi-G.
    Contributor

    Hi,

    NoMachine USB forwarding module uses specific methods and drivers that may not be compatible on some OSes with third party drivers with the same functionality. We recommend to disable it in the other program for a correct functioning of USB in NoMachine.

    in reply to: Smart card reader / USB device redirection #20929
    Giorgi-G.
    Contributor

    Hi,

    We are still unable to reproduce this despite several attempts.


    @frank
    , can you please tell us what versions of OS you use and your smart card reader version?

    And also, have you tried to forward some another USB device, not SM reader ?

    Regards.

    in reply to: Cannot connect USB device #20688
    Giorgi-G.
    Contributor

    Hi,

    first try uninstalling NoMachine from your Mac and restart the machine. After that, install the latest version from our website. Then check in System Preferences… -> Security & Privacy that there is nothing that needs to be accepted manually for ‘Apps downloaded from App store and identified developers’.

    You should see something like I have attached, so then try forwarding USB device once again.

Viewing 15 posts - 106 through 120 (of 147 total)