Haven

Forum Replies Created

Viewing 15 posts - 31 through 45 (of 96 total)
  • Author
    Posts
  • AvatarHaven
    Contributor

    Hello vnaipaul,
    Thank you for taking the time to report this.
    We reproduced the issue in our labs. Here is the relevant Trouble Report:
    https://www.nomachine.com/TR12M06262
    Please use the “Notify me” to know when a fix is available.

    in reply to: NoMachine 5.0.47 not responding (OSX El Capitan) #9152
    AvatarHaven
    Contributor

    hello macphi,
    NoMachine server logs to investigate further.
    Please follow the instructions here:
    https://www.nomachine.com/AR07K00677
    Send them to forum[at]nomachine[dot]com making sure to reference your topic.

    in reply to: NoMachine suspends instead of running in background #9132
    AvatarHaven
    Contributor

    Hello charleshenry,
    Are using the newest NoMachine 5.0.47 (free)?
    In this case NoMachine should provide access to current working X server.
    Or ask to create X11 display when no X servers are running on this host.

    Could you provide output of command:
    ps -Af | grep X
    to confirm what is the current situation?

    nxplayer by default is keeping all setting in .nx directory in home directory.
    You could remove it to make sure that all setting are restored to default.
    Note that path to nxplayer setting directory can be changed in ‘setting’ in nxplayer menu.

    in reply to: Remote sessions being disconnected #9113
    AvatarHaven
    Contributor

    Hello James.Sch,
    We are not aware of the such problem. Just based on your description
    it could be some issue with settings saved in ‘connection file’.

    Could you send us the logs as per the instructions here?
    https://www.nomachine.com/AR07K00677
    Send them to forum[at]nomachine[dot]com making sure to reference the
    topic in your email.

    We are especially interest in nxplayer logs when this issues occurs.

    in reply to: NoMachine suspends instead of running in background #8975
    AvatarHaven
    Contributor

    Hello charleshenry,
    NoMachine is not suspending the session when user disconnects.
    Could clarify you experience? Which Linux distribution are you using?
    Which version of NoMachine are you using?
    Are you accessing the physical desktop or creating the virtual session?

    in reply to: Unix-KDE is not available on this server #8495
    AvatarHaven
    Contributor

    Hello newmanium,
    The reason of error: unix-kde is not available on this server was because this session type was missing in AvailableSessionTypes key in node.cfg.
    During the reinstallation of NoMachine we auto-detect KDE and add this session type to this key.

    in reply to: Can’t start Opensuse 13.1 #8478
    AvatarHaven
    Contributor

    Hello Alex,
    None of those errors looks critical.

    We will more need debug NoMachine server logs to investigate further.
    Please follow the instructions here:
    https://www.nomachine.com/AR07K00677
    Send them to forum[at]nomachine[dot]com

    After enable debug logs on problematic machine please execute:
    /etc/NX/nxserver --restart
    and after that try to reproduce the issue.

    Additionally please provide output of command:
    ps -Af | grep X

    Please make sure that NX is in ClientConnectionMethods key in server.cfig file.

    in reply to: NX node: stop working after several hours #8460
    AvatarHaven
    Contributor

    Hello unlim,
    Thanks for bearing with me during the investigation.
    We have identified the issue and have opened a Trouble Report:
    http://www.nomachine.com/TR10M06073
    You can use the ‘alert me’ check box to know when we have a fix.
    You could also apply the described workaround.
    Please remember to restart nxserver after changing server.cfg file.

    in reply to: NX node: stop working after several hours #8410
    AvatarHaven
    Contributor

    Hello unlim,
    Thank you for new set of logs. Unfortunately I still cannot identify the issue.
    We know that running nxserver –daemon process:
    nx 13809 1 7 22:38 pts/0 00:00:00 /usr/NX/bin/nxserver.bin root 13770 --daemon
    has limit of 1024 open files. It should be more then enough to work properly.

    The issue on your system occurs after several hours after ‘restart’.
    Could please you keep debug level in the server and provide new set of logs
    when the nxserver --daemon process will be lost due to error: ‘Too many open files’ ?

    AvatarHaven
    Contributor

    Hello pvn,
    This step: ## Replace default SSH keys on E2C instance is not necessary.
    NoMachine (free) does not support SSH protocol.

    After setting up a tunnel to the E2C instance, you should try to connect
    using the following connection settings:

    Protocol: NX
    Host: localhost
    Port: 4003
    Authentication method: Password
    Username: ec2-user
    Password: ***

    If you want to access ‘E2C instance’ with key based authentication
    please follow the article: https://www.nomachine.com/AR02L00785

    The crucial is to add public key to: /home/ec2-user/.nx/config/authorized.crt
    Then should try to connect using the following connection settings:

    Protocol: NX
    Host: localhost
    Port: 4003
    Authentication method: Private-key
    Private Key: nomachine.pem (with correct path)
    Username: ec2-user
    Passphrase: <empty>

    in reply to: Possible to reserve a DISPLAY number for a user? #8352
    AvatarHaven
    Contributor

    Hello ostromark,
    I cannot recommend any assured way to reserve display for the user.
    Could you maybe use nxserver --list command output to identify user display?
    We have also command nxserver --message where you can send message to the session, maybe it could be helpful.

    in reply to: NX node: stop working after several hours #8334
    AvatarHaven
    Contributor

    Hello unlim,
    Let’s investigate further.
    Please follow those instructions and if possible provide full commands output.

    Please keep debug level log in server.cfg file and perform server restart:
    /etc/NX/nxserver --restart

    then execute:
    ps -Af | grep nx

    Find nxserver --daemon process PID, and check its limits:
    cat /proc/<nxserver --daemon PID>/limits
    It’s necessary to verify especially the fields ‘Max open files’

    Please check also user limits after that ‘nxserver –restart’ command was performed:

    ulimit -aS
    ulimit -aH

    If limits are set correctly, please send output of those command with new set of logs.

    in reply to: NX node: stop working after several hours #8316
    AvatarHaven
    Contributor

    hello unlim,
    Thank you for sending the logs.
    In nxserver.log file we can find: Error is: 24, 'Too many open files'.

    Did you try follow the article:
    How to avoid "Too many open files" messages while opening a NX session
    from my previous post?

    in reply to: NX node: stop working after several hours #8299
    AvatarHaven
    Contributor

    Hello unlim,
    One of the possible issue that fits described symptoms is crash of
    ‘nxserver –daemon’ process. This process is vital to provide access
    to the physical display. Unfortunately we need full nxserver logs to
    find what is exactly going on.
    Please follow the instructions here:
    https://www.nomachine.com/AR07K00677
    Reproduce the issue, please gather logs and send them to forum[at]nomachine[dot]com

    As a note, a common case is that the ‘nxserver –daemon’ process
    crashes due to “Too many open files” error. If you see in nxserver.log
    file error: Error is: 24, 'Too many open files'.
    Please follow the instructions from article to fix this:
    How to avoid ‘Too many open files’ messages while opening a NX session

    • This reply was modified 5 years, 5 months ago by AvatarHaven.
    • This reply was modified 5 years, 5 months ago by AvatarHaven.
    in reply to: Ooops! The connection to the server was lost #8240
    AvatarHaven
    Contributor

    Hello Sim81,
    In attached NX Network server (nxd) logs we can find:

    Error: Error 98 'Address already in use'.

    The default setting of NoMachine is to run connections is via the NX protocol on port 4000.
    Did you try to change default NX port?
    You can do it by editing /usr/NX/etc/server.cfg file:

    #
    # Specify the TCP port where the NX service is listening.
    #
    #NXPort 4000

    uncomment and change this default value from 4000 to 4001.

    After that please execute /etc/NX/nxserver --restart to apply changes.

    Please remember to update port value also on nxplayer side.

    • This reply was modified 5 years, 5 months ago by AvatarHaven.
Viewing 15 posts - 31 through 45 (of 96 total)