Haven

Forum Replies Created

Viewing 15 posts - 76 through 90 (of 96 total)
  • Author
    Posts
  • in reply to: Login as a guest user #5588
    AvatarHaven
    Contributor

    Hello PPG2014,
    to enable guest login you need: NoMachine Enterprise Server, NoMachine Cloud Server or NoMachine Terminal Server.

    Product: NoMachine Enterprise Desktop does not have this feature enabled.

    After installing appropriate product you must enable guests by executing command:
    /etc/NX/nxserver –ruleadd –class feature –type enable-guest –value yes

    in reply to: Recording feature can’t be disabled on Windows #5587
    AvatarHaven
    Contributor

    Hello snejok,
    We cannot reproduce the issue. We will need nxserver and nxnode logs
    to investigate further. Please follow the instructions here:
    https://www.nomachine.com/AR07K00677
    Send them to issues[at]nomachine[dot]com

    in reply to: EnableNetworkSharing doesn’t work #5464
    AvatarHaven
    Contributor

    Hello snejok,
    We will need nxserver and nxnode logs to investigate further. Please follow the instructions here:
    https://www.nomachine.com/AR07K00677
    Send them to issues[at]nomachine[dot]com

    in reply to: How can I force session limit to 1 in free NX version 4 #5075
    AvatarHaven
    Contributor

    Hello ang,
    NoMachine Free has licence that allows only for one connection
    to the server. If You suspect orphan connections please check
    output of commands:

    /etc/NX/nxserver –version
    /etc/NX/nxserver –list
    /etc/NX/nxserver –history

    To investigate possible issue with error logging in or a black
    screen please follow the instructions here:

    https://www.nomachine.com/AR07K00677

    Please send logs and output of commands to issues[at]nomachine[dot]com.

    AvatarHaven
    Contributor

    Hello mt,
    We will need nxserver and nxnode logs to investigate further. Please follow the instructions here:
    https://www.nomachine.com/AR07K00677
    Send them to issues[at]nomachine[dot]com

    in reply to: Login failure using NX authentication with key file #4657
    AvatarHaven
    Contributor

    Once we’ve implemented the possibility to set the authentication method available, this workaround won’t be necessary and is only temporary.
    We created Feature Request: https://www.nomachine.com/FR09L02825 to make it possible.

    in reply to: How to know what is the server of current node #4648
    AvatarHaven
    Contributor

    Hello dhy,
    We do not have possibility of checking to what multi-node server node machine was added.
    We are currently evaluating whether an Feature Request can be added.

    in reply to: Login failure using NX authentication with key file #4612
    AvatarHaven
    Contributor

    Hello lorandsm,

    debug message: ‘isSupportedPublicKey FAIL’ means that server failed to find public key in ‘<user’s home>/.nx/config/authorized.crt’ file.

    Please make sure that public key was correctly added to that file. You can do it by: execute ‘cat authorized.crt’ in ‘<user’s home>/.nx/config’ and check if public key is there.
    Also check if NoMachine server can access that file. File should be readable for ‘<user’s home>’ owner.

    If issue persist please send ‘ls -la’ output from ‘<user’s home>/.nx/config/’ and nxserver.log file (with nxserver logs enabled) on forum[at]nomachine[dot]com.

    in reply to: No available sessions on this server #4422
    AvatarHaven
    Contributor

    Hello marciak,
    We did not find any issues in attached logs that may indicate issues with providing access to physical session on that host. Debug log level was not enabled, but nonetheless we can see entries that indicate connection to that physical session.

    With that said, in .nx attached directory we can find nxplayer R- directories, where indeed is not physical session available. Maybe logs where send from client side (where nxplayer was running) not from server side host?

    in reply to: Redirect rules to nodes do not work #4368
    AvatarHaven
    Contributor

    Hello esarmien,

    the other solution that is probably more comfortable could be to disable each node for everybody:

    /etc/NX/nxserver –ruleadd –class=node –type=<host>:<port> –value=no

    and then enable node only for specific group:

    /etc/NX/nxserver –ruleadd –class=node –type=<host>:<port> –value=yes –group=<group name>

    We do not have –value=only available.

    in reply to: No session on headless server #4347
    AvatarHaven
    Contributor

    Hello dtc42,

    I logs you submitted we found that session because nxserver choose wrong X server to attach to. In user processes we can found two running X servers:

    vnc4           Xvnc4 :1 -desktop localhost:1 (googlestudent) -auth /home/googlestudent/.Xauthority -geometry 1280×1024 -depth 16 -rfbwait 30000 -rfbauth /home/googlestudent/.vnc/passwd -rfbport 5901 -pn -fp /usr/X11R6/lib/X11/fonts/Type1/,/usr/X11R6/lib/X11/fonts/Speedo/,/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/75dpi/,/usr/X11R6/lib/X11/fonts/100dpi/,/usr/share/fonts/X11/misc/,/usr/share/fonts/X11/Type1/,/usr/share/fonts/X11/75dpi/,/usr/share/fonts/X11/100dpi/ -co /etc/X11/rgb

    and

    Xvfb            Xvfb :0 -auth /home/googlestudent/Xvfb-0.auth -screen 0 1280x1024x2

    Please try to disable other X server before connecting to session or uncomment in node.cfg file key:

    #
    # Specify on which physical display the server must connect.
    #
    #DisplayDefault :0

    Then nxserver will always choose X server with display defined in this key.

    • This reply was modified 6 years, 7 months ago by AvatarHaven.
    in reply to: Redirect rules to nodes do not work #4315
    AvatarHaven
    Contributor

    Hello esarmien,

    Group redirect will not work in this case, because it it designed to redirect player connections directly to other host and ‘terminal nodes’ cannot be accessed directly.

    The solution can be to disable other nodes for specific group:

    nxserver –ruleadd –class=node –type=<host>:<port> –value=no –group=<group name>

    in reply to: Issue with Crunchbang #4309
    AvatarHaven
    Contributor

    Hello solek,
    We will need nxserver and nxnode logs to investigate further. Please follow the instructions here:
    https://www.nomachine.com/AR07K00677
    Send them to issues[at]nomachine[dot]com

    in reply to: No session on headless server #4280
    AvatarHaven
    Contributor

    Hello dtc42,

    We will need nxserver and nxnode logs to investigate further. Please follow the instructions here:

    https://www.nomachine.com/AR07K00677

    Send them to issues[at]nomachine[dot]com

    AvatarHaven
    Contributor

    hello,

    Terminal Server Node can only be accessed via an Enterprise Server or Cloud Server. If you want to access nodes directly, as well as via a central login point, you could install the Workstation or Terminal Server.

    See here for more details:

     

    https://www.nomachine.com/DT04L00067&documentName=multinode

    • This reply was modified 6 years, 8 months ago by AvatarHaven.
Viewing 15 posts - 76 through 90 (of 96 total)