HippoMan

Forum Replies Created

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • in reply to: How to get NoMachine to ignore Caps Lock? #38563
    HippoMan
    Participant

    Correction: when I use /usr/bin/xmodmap -e ‘keycode 66=Shift_L’ on the Raspberry PI, my Caps Lock mapping indeed functions properly when I’m connecting to that host via NoMachine.  I had incorrectly tested this in the past.

    However, I still have the problem with the Caps Lock key mapping being properly recognized on the Mac, as I reported above.

     

    in reply to: How to get NoMachine to ignore Caps Lock? #38520
    HippoMan
    Participant

    Thank you for your reply.

    By “directly connected”, I mean “when using the keyboard on those machines, and without NoMachine being in use”.

    The Raspberry PI machine has the same version of NoMachine as my Linux box: 6.17.1-4

    The Mac is running version 7.9.2

    I disable Caps Lock on both the Linux box and the Raspberry PI as follows:  /usr/bin/xmodmap -e ‘keycode 66=Shift_L’ . This just maps it to the normal Left-Shift key. That works fine on both of those machines when I am using the keyboard. But the mapping gets ignored when I’m connected via NoMachine, and it forces the full Caps-Lock functionality on the Raspberry PI.

    On the Mac, I use the Karbiner-Elements.app utility to map CapsLock to Left-Shift. Again, this works fine when I’m using the Mac’s keyboard, but it gets ignored when I’m connected via NoMachine, and it forces the full Caps-Lock functionality on the Mac.

    I don’t have this problem when using [removed] to connect to the Mac and to the Raspberry PI from my Linux box. My remapping of CapsLock works fine when connecting in that way to each machine. This Caps-Lock problem seems to be related to NoMachine itself.

    Also, I have just now upgraded my Linux box and my Raspberry PI both to use NoMachine 7.9.2-1 .  This Caps-Lock problem remains the same.

     

Viewing 2 posts - 1 through 2 (of 2 total)