iceback

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 40 total)
  • Author
    Posts
  • in reply to: Three different users at log in #13146
    Avatariceback
    Participant

    Yes, NX successfully connects to server now that X is properly installed.  Perhaps there’s an issue remaining w.r.t. the claim that NX will ‘create a Virtual display on demand’ and doesn’t.  I suspect the bad X installation is the root of that problem too.

    in reply to: Three different users at log in #13071
    Avatariceback
    Participant

    The issue has been resolved by fixing the xdm initialization.  I believe that is a remnant issue in what NX is doing in absence of a GUI – claiming it will start an virtual session, then failing to do so – but that’s for another day.

    The heart of the issue is a fault in ‘prefdm’ script:  it does an rpm query for packages which supply a graphical interface, then iterates over the results.   The configuration of the server in question had at some point in the recent past (last OS update?) lost it’s X packages and the query return “no packages found for graphical interface” but the prefdm script never recognized the error and tried to process each of those words as a possible display manager!  And did so repeatedly.

    Re-installing the 500+ packages involved in X did the trick.

    case-sorta-closed

    in reply to: Three different users at log in #13055
    Avatariceback
    Participant

    This machine has a KVM attached so it should not be (and in the past wasn’t) headless. Currently x is not starting and am looking in to that as well.

    /usr/NX/bin/nxserver –restart
    NX> 162 Disabled service: nxserver.
    NX> 162 Disabled service: nxnode.
    NX> 162 Disabled service: nxd.
    NX> 161 Enabled service: nxserver.
    NX> 162 WARNING: Cannot find X servers running on this machine.
    NX> 162 WARNING: A new virtual display will be created on demand.
    NX> 161 Enabled service: nxd.

    in reply to: Three different users at log in #12996
    Avatariceback
    Participant

    Sent log by email to forum[at]nomachine[dot]com’ (suitable translated I hope).

    Please confirm.

    in reply to: Three different users at log in #12975
    Avatariceback
    Participant

    Attaching logs generated with debug level 7. It seems to be in a tight loop.
    (I could not find a client side option to ‘not delete files’)

    in reply to: Three different users at log in #12974
    Avatariceback
    Participant

    Server side .xsession-errors
    integrity:~$ cat ./.xsession-errors
    Warning: Missing charsets in String to FontSet conversion
    XIO: fatal IO error 11 (Resource temporarily unavailable) on X server “:1001”
    after 225 requests (91 known processed) with 0 events remaining.
    xterm: fatal IO error 11 (Resource temporarily unavailable) or KillClient on X server “:1001”
    firefox: Fatal IO error 11 (Resource temporarily unavailable) on X server :1001.
    Client side:
    Script for ibus started at run_im.
    Script for auto started at run_im.
    Script for default started at run_im.
    init: at-spi2-registryd main process ended, respawning
    init: at-spi2-registryd main process ended, respawning
    init: at-spi2-registryd main process ended, respawning
    init: at-spi2-registryd main process ended, respawning
    init: at-spi2-registryd main process ended, respawning
    init: at-spi2-registryd main process ended, respawning
    init: at-spi2-registryd main process ended, respawning
    init: at-spi2-registryd main process ended, respawning
    init: at-spi2-registryd main process ended, respawning
    init: at-spi2-registryd main process ended, respawning
    init: at-spi2-registryd respawning too fast, stopped

    FULL LOG from –restart (NOT DEBUG) attached.

    in reply to: Three different users at log in #12973
    Avatariceback
    Participant

    sudo /usr/NX/bin/nxserver –userlist
    NX> 149 NX users list

    Username                         Redirected to                  Trusted for       Screen sharing Access
    ——————————– —————————— —————– ————– ——–
    rob                                                                               enabled        enabled
    u0886896                                                                          enabled        enabled
    u0138544                                                                          enabled        enabled
    u0690571                                                                          enabled        enabled
    raja                                                                              enabled        enabled
    u0430776                                                                          enabled        enabled
    u0786386                                                                          enabled        enabled
    u0919127                                                                          enabled        enabled
    u1018864                                                                          enabled        enabled

    As I said u0886896 was a member of the team but has moved on. BTW, that Id had ‘technical difficulties’ and he was issued a new account name “raja”.

    I can/have reproduce the problem over several nxserver –restart calls and will do so again (barring a miracle). Do you want the .xsession from the client or the server?

    in reply to: Is lightweight (X11) transport available on free version #12972
    Avatariceback
    Participant

    Thanks for that clarification.

    in reply to: No input accepted after update to 5.1.44 #12316
    Avatariceback
    Participant

    I will try another install, but it won’t be this week.  Just back from vacation and am far behind

     

    in reply to: No input accepted after update to 5.1.44 #12149
    Avatariceback
    Participant

    Relevant contents of the server.cfg file suggest post #11940 is not applicable

    #
    # Set the interaction level for the session connected to the physical
    # desktop:
    #
    # 0: View-only. The session is connected to the desktop in
    # view-only mode, i.e. the user can't interact with the
    # physical desktop.
    #
    # 1: Restricted. User connected to the physical desktop can
    # interact with the desktop except for resize operations.
    #
    # 2: Interactive. User connected to the physical desktop has
    # full interaction with the desktop.
    #
    #PhysicalDesktopMode 2
    
    in reply to: 5.0.63 breaks CapsLock/Ctrl swap #9969
    Avatariceback
    Participant

    successfully ran

    • setxkbmap -option “” -option “ctrl:swapcaps” -option “terminate:ctrl_alt_bksp“

    Yes, that used to work but now, from an ubuntu client, it has no effect.  I disconnected from my session, ran that on my desktop, restarted nxserver, reconnected and no change

     

    in reply to: 5.0.63 breaks CapsLock/Ctrl swap #9924
    Avatariceback
    Participant

    Yes, both server and client are running linux.  Centos 6.7 on the server, Ubuntu-14.04 on the client

     

    in reply to: 5.0.63 breaks CapsLock/Ctrl swap #9859
    Avatariceback
    Participant

    The client would have been 5.50~ and the server was 4.6.4

    in reply to: How to measure slow-down #8363
    Avatariceback
    Participant

    Well yes, the graphics come from the nx-server end of course.  From my end it’s all keyboard and mouse.  Still suspect a client side delay/buffering as part of the problem.

    in reply to: How to measure slow-down #8266
    Avatariceback
    Participant

    Is there any input buffering?  As in ‘wait-this-long’ for more keyboard input before sending to server? And if so is it configurable?

Viewing 15 posts - 1 through 15 (of 40 total)