irek

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 48 total)
  • Author
    Posts
  • in reply to: Disable mDNS traffic #29390
    Avatarirek
    Participant

    Hello bsper2,

    I assume ‘10.156.1.13’ is the server host where you had disabled mDNS broadcasting. Those logs, suggest it is mDNS discovery.

    To disable discovery on clients, select Player preferences -> Privacy -> Don’t show other computers on the network.

    The important thing is that you apply them an all machines of your network on which you dont want to have mDNS.

    in reply to: Disable mDNS traffic #29065
    Avatarirek
    Participant

    Hello bsper2,

    Please make sure that you have restarted nxserver after disabling broadcasting by setting configuration key in server.cfg:

    EnableNetworkBroadcast 0

    Restarting nxserver after such change is required.
    Please do the following steps on all hosts where you want to disable broadcast feature.

    In case restarting nxserver didnt help, please refer to an article on how to enable debug:

    How to gather debug logs for support requests

    1 .Enable debug on the server machine and then do:

    sudo /etc/NX/nxserver --restart

    Then please check if you reproduced issue. Then please gather logs either manually or by executing:

    sudo /etc/NX/nxserver --debug --collect

    2. Please send to us server.cfg file.

    3. Can you please tell us how do exactly you check that

    Please send the logs and server.cfg file to forum[at]nomachine[dot]com using the title of this forum’s thread as the mail’s subject.

    About second suggestion to disable broadcasting from GUI by uncheck the box “Advertize this computer…” in the player’s services,
    looks like you have set key ‘EnableServerPreferences’ to 0 in /usr/NX/etc/node.cfg.

    Please make sure that this key is set to ‘1’ and restart nxserver to be able to see “Server Preferences”

    # grep EnableServerPreferences /usr/NX/etc/node.cfg
    EnableServerPreferences 1
    Avatarirek
    Participant

    Hello boospy

    This is a known issue. Please consult the Trouble Report, there is also a workaround available.

    “The NoMachine web server doesn’t start on Ubuntu 20.04 after changing the ports”
    https://www.nomachine.com/TR06R09730

    Additionally there is an Article which may be helpful:

    “How to change default ports for nxhtd”
    https://www.nomachine.com/AR12Q01065

    in reply to: The connection with the server was shut down #22578
    Avatarirek
    Participant

    Hello,

    If the NoMachine network daemon (nxd) is configured on the server to listen on a different port,
    it’s also necessary to update the client.crt file, on Linux /var/NX/nxhtd/.nx/config/client.crt, to have:

    Host:localhost 5001
    -----BEGIN CERTIFICATE-----
    (...)
    -----END CERTIFICATE-----
    Host:127.0.0.1 5001
    -----BEGIN CERTIFICATE-----
    (...)
    -----END CERTIFICATE-----

    You can find whole instruction in here:
    https://www.nomachine.com/AR06N00888

    Avatarirek
    Participant

    Hello (pasting some info from your email reply)

    1 “both the machines are connected to different routers, now also on the Linux end there is a new router.”

    – did you checked that on both UPnP is enabled?
    – what is the new router name/model?

    2 “However, one’s a laptop, so I can move it to the other location —
    when I have them both on the same home network, the
    connection works fine.”

    And what about UPnP on that laptop in the new location?
    As I understood Windows is installed on this Laptop, and in its base location
    UPnP is working.

    When you move this laptop to the place where PC with Linux is located
    does UPnP works or now it doesnt?

    3 Just for a test, could you disable/turn off all other network interfaces on the Linux machine
    and leave only WiFi or cable connection alive to this router. And then please call as administrator in terminal

    /etc/NX/nxserver --restart
    
    /etc/NX/nxserver --upnpstatus

    if still doesnt show, wait a while and run:

    /etc/NX/nxserver --upnpmap

    Please send all the output to forum[at]nomachine[dot]com making sure to reference the topic.

    Avatarirek
    Participant

    Hello,

    we would need some more information

    1 Could you please send to use all configuration files *.cfg from :

    # /usr/NX/etc/

    If you don’t show us the htd.cfg, it’s hard for us to advise appropriately.

    2 Please execute this command in terminal:

    # /etc/NX/nxserver --version

    3 From server.cfg I can tell 2 things

    3.1 HTTP is disabled

    #
    # Specify how clients will have to contact the node, by default by
    # the NX service. To allow for multiple methods, specify them in a
    # comma-separated list. Supported methods are: NX, SSH and HTTP.
    #
    ClientConnectionMethods NX,SSH

    to enable you have to add HTTP:

    ClientConnectionMethods NX,SSH,HTTP

    Restart of nxserver is required.

    3.2 it looks like this is old version maybe v5, if thats true is this possible to update to latest v6?

    4 We would ned alos to see all logs.
    Instructions about debug and collecting logs you can find there: https://www.nomachine.com/AR07K00677

    Please send them to forum[at]nomachine[dot]com making sure to reference the topic.

    Avatarirek
    Participant

    Hello,

    can you please describe what are you trying to do by removing ssl certificates,
    is it because you want to have only HTTP or both HTTP and HTTPs instead of only having HTTPs?

    Can you also send to us htd.cfg and server.cfg configuration files.

    Please send all the info to forum[at]nomachine[dot]com making sure to reference the topic.

    Avatarirek
    Participant

    we would need some more information:

    1 When did you notice that UPnP stopped working ? Maybe after a software / OS update?

    2 Can you describe the network infrastructure

    – router model / version
    – is there more than one router / network interfaces on which Linux machine is connected?
    – is the computer directly connected to router or is there a cascade or repeater between them?
    – are both machines [ physical machines or virtual [vbox/vmware] ? ] connected to the same router, both over wifi/lan or mixed?

    3 Can you please execute those commands:

    – on Linux machine in terminal:

    nmcli device status
    
    route -n
    
    ifconfig -a
    

    – on Windows in cmd:

    ipconfig /all

    Please send all the output to forum[at]nomachine[dot]com making sure to reference the topic.

    in reply to: Wildcard cert on Terminal Server #18644
    Avatarirek
    Participant

    Hello Lars,

    not sure if you’re referring to the certificate for the web server. If so, edit the nxhtd configuration file to point to the new certificate.

    If, on the other hand, you’re referring to the certificate for NX authentication, it still has to be implemented

    in reply to: Wildcard cert on Terminal Server #18612
    Avatarirek
    Participant

    Hello pureobscure,

    currently for a Web session you can use self-signed certificates, as explained in:

    https://www.nomachine.com/DT03O00127#3

    CA certificates are effectively not supported yet.

    in reply to: NX Server WAN port #18364
    Avatarirek
    Participant

    Hello Stan,

    NoMachine retrieves the public IP and maps the port automatically when the router supports UPnP or NAT-PMP port mapping.

    Information how to enable UPnP port mapping on nxserver is available here: https://www.nomachine.com/AR11L00827. Just set

    EnableUPnP NX

    in the

    /usr/NX/etc/server.cfg

    .

    When IP will change you will probably not be able to connect to the server. It’s now been queued up for fixing and you can see it here: https://www.nomachine.com/TR01P08354. You can use the ‘notify me’ tool to find out when a fix has been released.

    However there is a way to handle this, and make it works:
    when IP will change you can use script or by hand call those 2 commands as administrator / root user:

    # /etc/NX/nxserver –upnpunmap
    # /etc/NX/nxserver –upnpmap

    If UPnP is enabled and works on router that server machine is connected you will see as the ouput of second command external IP and Port.

    Port may not changed, but those to commands called exactly in that order, will allows you to connect after IP changed.

    To get only information about port mapping you can call:

    # /etc/NX/nxserver –upnpstatus

    the ouput will be similar to:

    # /etc/NX/nxserver –upnpstatus
    Local IP 192.168.1.2
    Gateway IP 192.168.1.1
    External IP 151.1.192.128
    NX port 4000 mapped to: 151.1.192.128:29382

    in reply to: Problem opening GW port in automatic at Windows boot #17700
    Avatarirek
    Participant

    Hello Rosssiiii,

    I asked to check if UPnP is enabled just to be sure, as you want to use UPnP feature it should be enabled all the time.

    1. Enable the logs by following the instructions on the server side using the article https://www.nomachine.com/DT10O00163#1 (alternatively there is https://www.nomachine.com/DT10O00162 which is a less technical version).

    2. As you can see here: https://www.nomachine.com/DT10O00163#1.4.

    you will find the logs on Windows in

    %PROGRAMDATA%/NoMachine/var/log on Windows Vista, 7, 8, 8.1 and 10.
    Documents and Settings/All Users/NoMachine/var/log on Windows XP.

    For example:

    C:\ProgramData\NoMachine\var\log

    3. Reproduce the problem and show us the result of the following commands::

    On Windows: start cmd.exe as root (Administrator) and

    C:\Program Files (x86)\NoMachine\bin\nxserver.exe –upnpmap
    C:\Program Files (x86)\NoMachine\bin\nxserver.exe –upnpstatus

    On Unix:

    sudo /etc/NX/nxserver --upnpmap
    sudo /etc/NX/nxserver --upnpstatus

    4. Zip them up and send them to forum[at]nomachine[dot]com. Use the ‘@’ and ‘.’ in place of the brackets.

    It’s important to reproduce the problem once you’ve enabled everything and then zip the logs.

    in reply to: Problem opening GW port in automatic at Windows boot #17673
    Avatarirek
    Participant

    Hello Rosssiiii,

    we would need some more information

    1. Router name and model.

    2. Check the key EnableUPnP in server.cfg if it is set to NX, if not set it and restart nxserver.

    Then please run a terminal and execute the commands:
    3. Please enable debug, restart nxserver, reproduce the problem and show us the result of the following commands::

    On Windows: start cmd.exe as root (Administrator) and

    C:\Program Files (x86)\NoMachine\bin\nxserver.exe –upnpmap
    C:\Program Files (x86)\NoMachine\bin\nxserver.exe –upnpstatus
    

    On Unix:

    sudo /etc/NX/nxserver --upnpmap
    sudo /etc/NX/nxserver --upnpstatus
    

    Please do this on 2 servers where problem occurs and where doents connected to the same router. Instructions about debug and collecting logs you can find there: https://www.nomachine.com/AR07K00677

    Please send them to forum[at]nomachine[dot]com making sure to reference the topic.

    in reply to: Web-based connection and Chromebook security policy #17634
    Avatarirek
    Participant

    Hello r91085,

    I realise now that my answer was incomplete. So, by adding into:

    InstallationDirectory/etc/htd.cfg

    and add following lines at the end of file, please make sure that this new line is :

    PassEnv ALLUSERSPROFILE USERPROFILE

    so end of htd.cfg file will looks like :

    <Directory "C:\Program Files (x86)\NoMachine/">
      AllowOverride None
      Options +FollowSymLinks +ExecCGI
      Require all granted
    </Directory>
    
    PassEnv ALLUSERSPROFILE USERPROFILE
    

    and then restart nxhtd server:

    InstallationDirectory/bin/nxserver --restart nxhtd

    in reply to: Web-based connection and Chromebook security policy #17489
    Avatarirek
    Participant

    Hello r91085,

    let’s clarify one thing. Installation comes with a self-signed an SSL Certificate File and SSL Certificate Key file intended to be just a sample. They are, respectively:

    installation directory/etc/keys/host/ht_host_rsa_key.crt
    installation directory/etc/keys/host/ht_host_rsa_key

    Administrators have to replace the sample SSL Certificate File and Key File with their own certificate self-signed or acquired from a CA. you can read more about that with the following article: https://www.nomachine.com/DT03O00127#3

    In any case, we’d like to take a look at the logs in just to make sure there’s nothing wrong in NoMachine
    Please follow the instructions here: https://www.nomachine.com/DT10O00163#1
    and uncomment and set these 2 keys in server.cfg like this:

    SessionLogLevel 7
    WebSessionLogLevel 7

    Send them to forum[at]nomachine[dot]com

Viewing 15 posts - 1 through 15 (of 48 total)