jefft

Forum Replies Created

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • in reply to: USB devices and Raspberry Pi #13213
    Avatarjefft
    Participant

    Incidentally – your link to the FR gives me a 404 type error page.

    in reply to: USB devices and Raspberry Pi #13212
    Avatarjefft
    Participant

    Thanks.  Seems ok as a disk, yes…  In the real world, I’ll need to add a USB headset as well as to be able to plug in USB storage, so I guess that’ll have to wait for the feature request to find its way into a release.
    Thanks for raising that 🙂

     

    in reply to: USB devices and Raspberry Pi #13148
    Avatarjefft
    Participant

    Found this… https://www.nomachine.com/AR12J00658

    The kernel headers on RPi are called raspberrypi-kernel-headers, not the naming suggested.  The make has to be run in a root shell, or it fails trying to overwrite one of the modules as output.  Make clean doesn’t work fully – something about a dangling symlink.  Other than that, the compile seemed to work.

    With the compiled driver in place and a reboot done, NM now offers me the option to connect a local USB device (previously greyed out), but still does not see the attached USB storage key.

    Anyone got any further ideas?  Can I get NM to offer up any debugging as it tries to see the USB device?

    in reply to: No audio – RasPi 3 to Windows remote #13142
    Avatarjefft
    Participant

    Ah.  I thought I’d added a comment to this one… yes, got it working, so this one can be closed thanks!

    For anyone reading this later – it doesn’t like pulseaudio in system mode; pulse has to be running as the same user as NM and to be started before opening the NM window (the taskbar component runs automatically and it seems fine for that to run pre-pulse).

    in reply to: No audio – RasPi 3 to Windows remote #13136
    Avatarjefft
    Participant

    Weird.  Just after I posted this, I thought I’d give it one more try.  Ran pulseaudio in the foreground as the user before going anywhere near NM… and lo and behold, I have sound!  I guess perhaps I’d previously only disconnected NM before running pulse, rather than starting pulse first before opening NM.  I’ve also ascertained that it doesn’t like pulse running in system mode, unfortunately.

    So for a dedicated NoMachine thin client, I guess I have to script X windows startup to run pulse and then NM.  Next task… 😉

Viewing 5 posts - 1 through 5 (of 5 total)