jmi

Forum Replies Created

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • in reply to: Authentication failed from another Windows 7 client #4817
    Avatarjmi
    Participant

    I changed the TCP port in SSH tunnelling and NoMachine client connection configuration from 4555 to 4556 for my new laptop client. The authentication then worked. I guess the server somehow remembers the port 4555 is for the connection for another client machine.

    in reply to: How to setup server on Centos #447
    Avatarjmi
    Participant

    Hi Titan,

    Thanks for the tip of tunneling. I installed openssh on my windows and used it to tunnel the way you described. My NX client can now connect to the NX server.

    Great help! Thanks again.

    Jason

    in reply to: How to setup server on Centos #418
    Avatarjmi
    Participant

    Hi titan,

    I just stopped nxd, deleted nxd.log and then restarted nxd so that you can have a clean log file to take a look at. I also tried to connect to it from my Windows 7 client with no success. Below is all in the nxd.log.

    Info: Server started with pid 17603 on Sat Nov 2 14:51:28 2013.
    Info: Listening for connections on any interface on port 4000.
    Info: Accepting connections from any host with encryption enabled.

    It doesn’t look like it received any connection request. On my NX client window, it displayed:
    Could not connect to the server.
    Error is 138: Connection timed out

    If we cannot resolve this due to network setting for port 4000, can we possibly enable SSH port 22 on the NX server? Again, I’m using the non-enterprise version 4.0.360 for 64-bit.

    Thanks for your help!
    Jason

    in reply to: How to setup server on Centos #415
    Avatarjmi
    Participant

    My firewall on centos where NX server is running is also disabled. Could be other network setting blocking me from access it?
    On another machine in my office, ‘telnet x.x.x.x 22’ connects where x.x.x.x is the IP for the centos. But ‘telnet x.x.x.x 4000’ doesn’t connect.

    Is there a way to enable SSH (port 22) protocol on the server with my non-enterprise version 4.0.360?

    Jason

    in reply to: How to setup server on Centos #387
    Avatarjmi
    Participant

    I am still trying to get the latest non-enterprise version 4.0.360 for 64-bit to work for my centos as server and Windows 7 as client. No success so far.
    What I’ve tried are as below:

    Right out-of-box for both server and client with NX protocol, connection timed out. If I connect client and the server on the same centos machine, it works.
    Somehow, I think that the NX protocol on port 4000 does not work for me if the client is on a Windows 7.

    When switching to SSH protocol by adding SSH to ClientConnectionMethods in server.cfg, I can get the login, but then got “Error is: SSH connections are not supported on this server.”. By reading the doc, it appeared to me that SSH protocol is not supported in the non-enterprise version.

    Any guidance on what to try the next…

    Thanks,
    Jason

Viewing 5 posts - 1 through 5 (of 5 total)