Kalabagh

Forum Replies Created

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • in reply to: Cannot detect any display running #27067
    AvatarKalabagh
    Participant

    Hi Mr. Kroy,

    I have created a new instance with the same configuration. It works perfect and with the same AMI.

    I also have no access to the AMI’s root user, because it’s not created by me, so let’s forget this issue.

    So many thanks for all your help and concerned about having been unable to give a public solution.

    in reply to: Cannot detect any display running #27021
    AvatarKalabagh
    Participant

    Hi there kroy,

    I have tried writing “/usr/bin/startxfce4” but nothing.

    What is written by default is “/etc/X11/xdm/Xsession default”.

     

    Thanks.

    in reply to: Cannot detect any display running #26998
    AvatarKalabagh
    Participant

    Sorry, I thought this message had been sent:

    “Dear Mr. Kroy,

    This is what I get:

    /usr/share/xsessions/icewm.desktop:Exec=icewm-session
    /usr/share/xsessions/mwm.desktop:Exec=mwm
    /usr/share/xsessions/twm.desktop:Exec=twm
    /usr/share/xsessions/xfce.desktop:Exec=startxfce4

    So I think it has already installed xfce environment. What do you think?”

    in reply to: Cannot detect any display running #26918
    AvatarKalabagh
    Participant

    Sorry, I thought this message had been sent:

    “Dear Mr. Kroy,

    This is what I get:

    /usr/share/xsessions/icewm.desktop:Exec=icewm-session
    /usr/share/xsessions/mwm.desktop:Exec=mwm
    /usr/share/xsessions/twm.desktop:Exec=twm
    /usr/share/xsessions/xfce.desktop:Exec=startxfce4

    So I think it has already installed xfce environment. What do you think?”

    in reply to: Cannot detect any display running #26844
    AvatarKalabagh
    Participant

    So, what do you think?

    in reply to: Cannot detect any display running #26692
    AvatarKalabagh
    Participant

    Dear Mr. Kroy,

    This is what I get:

    /usr/share/xsessions/icewm.desktop:Exec=icewm-session
    /usr/share/xsessions/mwm.desktop:Exec=mwm
    /usr/share/xsessions/twm.desktop:Exec=twm
    /usr/share/xsessions/xfce.desktop:Exec=startxfce4

    So I think it has already installed xfce environment. What do you think?

    in reply to: Cannot detect any display running #26661
    AvatarKalabagh
    Participant

    Dear Mth,

    I hope that health is on your side, and I also wish you a happy Easter.

    I would like to have a solution for this. Last day I could work with NoMachine properly I finished with a simulation and since then I’m not able to see the results… I have done the work but I have no acces to it.

    I don’t understand where is the issue, because you only refer to one configuration but I imagine that there are two configurations, one from my local machine and other from AWS server, so please, refer always the side you are talking about. The AWS image is not mine, is public, so an error there would be rare.

    I don’t know what is a “headless phisical session” or a “virtual session”. Since the initials I opened my AWS console, activated my preconfigured server, open up a terminal and connect to it by ssh command. Finally open a NoMachine connection to view the server desktop. Very simple.

    At least, I would appreciate to know how all the related configuration should be, and I’m going to make my best in order to find and change it.

     

    Many thanks.

     

    in reply to: Cannot detect any display running #26563
    AvatarKalabagh
    Participant

    So that’s what I found.

     

    Any suggestion?

    in reply to: Cannot detect any display running #26341
    AvatarKalabagh
    Participant

    Good afternoon,

    That’s what I get when executing the command you said:

    “/usr/share/xsessions/ubuntu.desktop:Exec=env GNOME_SHELL_SESSION_MODE=ubuntu  gnome-session –session=ubuntu

    /usr/share/xsessions/ubuntu-xorg.desktop:Exec=env GNOME_SHELL_SESSION_MODE=ubuntu  gnome-session –session=ubuntu

    /usr/share/xsessions/unity.desktop:Exec=/usr/lib/gnome-session/run-systemd-session unity-session.target”

    in reply to: Cannot detect any display running #26283
    AvatarKalabagh
    Participant

    Please, I need an answer.

    in reply to: Cannot detect any display running #26164
    AvatarKalabagh
    Participant

    Thank you for answering,

    I have to say that I have been working with the same Amazon AMI, with the same instance and configuration and with NoMachine since January and everything has worked properly. This happens to me only since a few days. So maybe is related with some update, but the only one I remember is related with the internet connection device.

    NX server came with it, I didn’t install it later.

    In DefaultDesktopCommand I can see: “dbus-launch –exit-with-session gnome-session –session=ubuntu”

    in reply to: Cannot detect any display running #26112
    AvatarKalabagh
    Participant

    Hi Britgirl,

    OS version in local is Ubuntu 17.10, client is NoMachine 6.9.2.

    Server side is an Amazon AMI, OpenSUSE Leap 42.1 x86-64

    Here are the logs:

    CONNECTION

    “NX> 164 Connection policy:

    Type                       Value
    ———————–    ——
    autocreate                  yes  
    autoconnect                 yes  
    automigrate                 yes  
    desktop                     no   
    dialog                      no   
    NX> 105 Resourcelist
    NX> 104 Lista de recursos :

    Class     Type                       Value
    ——— ————————– ——
    session   nxvfb                       no
    session   unix-console                no
    session   unix-gnome                  no
    session   vms                         no
    session   unix-remote-custom          no
    session   unix-xsession-default       no
    session   vnc                         no
    session   windows                     no
    session   unix-desktop                no
    session   unix-remote                 no
    session   unix-cde                    no
    session   shadow                      no
    session   unix-kde                    no
    session   unix-application            no
    session   unix-default                no
    session   unix-xdm                    no
    session   physical-desktop            no
    session   unix-script                 no
    service   server-printer-sharing      yes
    service   client-network-sharing      yes
    service   audio                       yes
    service   server-network-sharing      yes
    service   client-usb-sharing          yes
    service   server-disk-sharing         yes
    service   local-recording             yes
    service   client-smartcard-sharing    yes
    service   client-disk-sharing         yes
    service   client-printer-sharing      yes
    service   microphone                  yes
    service   server-file-transfer        yes
    service   client-file-transfer        yes
    service   session-recording           yes
    service   server-usb-sharing          yes
    feature   enable-multinode            no
    feature   client-clipboard            yes
    feature   manual-node-selection       yes
    feature   server-clipboard            yes
    feature   node-load-balancing         yes
    feature   bandwidth                   no
    node      localhost:4000              yes
    node      virtual-desktops-limit      no
    node      connections-limit           no
    NX> 105 Listsession –user=”cfd” –status=”disconnected\054connected” –geometry=”1920x1080x24+render” –type=”all” –reconnectable=”yes”
    NX> 149 Confirmation required for creating new frame buffer on server
    Startxserver –option=”yes”
    NX> 500 ERROR: No se puede crear una nueva pantalla. Por favor, contacte su administrador sistema.
    NX> 127 Session list of user ‘cfd’:

    Display Type Session ID Services Depth Screensize Status Session name Username Platform Users Crea Node
    ——- —- ———- ——– —– ———- —— ———— ——– ——– —– —- —-

    NX> 148 Server capacity: not reached for user: cfd
    NX> 105″

    SESSION

    “Info: Starting NoMachine version 6.9.2.
    Info: Loading settings from ‘.nx/config/player.cfg’.
    Info: Loaded translation files for ‘Spanish’.
    8529 8529 20:20:55 085,952 Main: Creating the client session.
    8529 8529 20:20:55 086,044 ClientSession: Initializing session at 0x136f8f0.
    8529 8529 20:20:55 238,862 ClientSession: Initialized session at 0x136f8f0.
    8529 8529 20:20:55 239,175 Main: Entering the GUI event loop.
    Info: Slave server running with pid 8555.
    Info: Listening to slave connections on port 37550.
    8529 8529 20:21:04 178,539 ClientSession: Starting session at 0x136f8f0.
    8529 8529 20:21:04 179,306 ClientSession: Going to start session ‘/home/ordenador/Documentos/NoMachine/Conexión a ec2-35-164-97-22.us-west-2.compute.amazonaws.com.nxs’.
    8529 8529 20:21:04 192,663 Connection: Initializing connection at 0x167dd10.
    8529 8529 20:21:04 192,863 Connection: Initialized connection at 0x167dd10.
    8529 8529 20:21:04 192,888 Connection: Starting connection at 0x167dd10.
    8529 8529 20:21:04 192,903 ClientDaemonConnector: Starting a new connection to host ‘ec2-35-164-97-22.us-west-2.compute.amazonaws.com’ on port ‘4000’.
    8529 8529 20:21:04 193,019 Connection: Started connection at 0x167dd10.
    8529 8529 20:21:04 198,808 ClientSession: Started session at 0x136f8f0.
    Info: Connection to 35.164.97.22 port 4000 started at 20:21:04 418,577.
    8529 8565 20:21:05 279,846 ClientSession: A valid certificate for this server was found.
    8529 8565 20:21:07 286,411 Connection: WARNING! Skipping a duplicate code 1000.
    8529 8529 20:21:07 501,816 ClientSession: Going to query the server for available services.
    8529 8529 20:21:09 533,254 Connection: Connection at 0x167dd10 failed.
    8529 8529 20:21:09 533,287 ClientSession: Runnable at 0x167dd10 caused the session at 0x136f8f0 to fail.
    8529 8529 20:21:09 533,300 ClientSession: Failing reason is ‘La negociación de la sesión falló.

    Error: No se puede crear una nueva pantalla’.
    8529 8529 20:21:09 540,614 ClientSession: Stopping session at 0x136f8f0.”

    SETTINGS

    nx/nx,cookie=A0B93010BD231BA656C8DFBDCC769A35,slave=65051,x11=0,id=localhost-65051-7CF546C1AB870DACB9B32F0B7F9A0576:65051″

    Many thanks.

Viewing 12 posts - 1 through 12 (of 12 total)