kleinfelter

Forum Replies Created

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • in reply to: Unable to login to Ubuntu host with monitor off #33516
    Avatarkleinfelter
    Participant

    In case someone else comes along after me with a similar problem: Confirmed:

    • If NoMachine connects to the physical console X session on a Linux box
    • and your monitor is turned off, unplugged, or the Linux box is the inactive monitor on a KVM or HDMI switch
    • and it shows a black screen and/or ignores your keyboard/mouse
    • and your monitor is connected via HDMI (or if, like me, your computer has DisplayPort and you use a DP to HDMI cable)

    placing one Hdmi Edid Emulator on the monitor end of your cable will make your computer “think” the monitor is turned on and connected.

    i.e. one Hdmi Edid Emulator on the monitor end of your cable will fix the issue where NoMachine doesn’t work well without a connected monitor. It will work with or without a monitor.

    in reply to: Unable to login to Ubuntu host with monitor off #33459
    Avatarkleinfelter
    Participant

    Ha! I think I found a hardware solution.  Looks like I need an HDMI EDID Emulator with pass-through.

    If it works as described, the computer will “see” a connected monitor, whether the monitor is on/off or connected/disconnected.

    in reply to: Unable to login to Ubuntu host with monitor off #33458
    Avatarkleinfelter
    Participant

    Thank you for the suggestion.

    • The fake-monitor dongle won’t work for me. The server is attached to a KVM switch, which simply disconnects the not-selected machine.  Shopping for a pricey KVM switch that emulates a connected monitor interface to the disconnected machine would be a theoretical alternative. Can anyone recommend an affordable 3-4 port HDMI KVM that does this?
    • If I sudo systemctl stop gdm && sudo /etc/NX/nxserver --restart && sudo systemctl stop gdm would it have the effect of running both a NoMachine X server *and* GDM?
    • Is there a way to just tell NoMachine to always launch its X server in addition to the one for the physical monitor?  I don’t need to ‘share’ the physical session — I just need to connect remotely to *an* X session.
    in reply to: Lower-res remote down-scaling for Retina #29642
    Avatarkleinfelter
    Participant

    OK.  I apologize.  The fault is mine.  Apparently, I have been running my Macbook at 1440×900 for the last 5 years without realizing it.  I downloaded Display Menu from the Mac App Store, clicked on 2880×1800, and suddenly everything is tiny and when I connect to distant NoMachine hosts, I get all the resolution I expect.

    Sheesh!  I thought I was scaling everything at Retina but I’ve been pixel doubling all along.  Oops.

    in reply to: Lower-res remote down-scaling for Retina #29641
    Avatarkleinfelter
    Participant

    I tried removing NoMachine (and the .nx directory and the ~/Documents/NoMachine connection files), and re-installing with the latest .dmg from NoMachine.  And rebooting.  Same behavior.  NoMachine behaves as if my Mac 2880 x 1800 has a lower resolution than the remote Windows machine at 1920×1080.  It sure looks like NoMachine is pixel-doubled on the Mac.

    I confirmed that the “Open in Low Resolution” checkbox is clear on the Mac.  My Retina Display options in System Preferences are set to “Default for Display”.

    The Windows machine is typically set to scale to 125%.  I set it to 100% with no change in behavior. That made the text smaller, but the viewport is still the same size.

    I’m running MacOS 10.13.6.  (I have some critical 32-bit apps, so I simply won’t be updating MacOS.)

    nx.zip emailed to the specified address.

    The problem appears to be on the Mac.  When I connect to a Linux host and set “Change the server resolution to match the client when I connect”, the Linux host switches from its normal 1920×1080 to 1440×900.  NoMachine on my Mac thinks I’ve got 1440×900.  And yes, I did confirm that About This Mac says “15.4-inch (2880 x 1800)”.

    Thank you for your help!

    in reply to: Lower-res remote down-scaling for Retina #29626
    Avatarkleinfelter
    Participant

    Thank you for your reply.  “Fit to window” is NOT checked on either remote.

    When I view the display settings in NoMachine for the Windows connection, I don’t see a ‘scaling’ setting.  I have display quality set to medium, and resolution is set to 1920×1080 (which is the resolution used by the Windows machine).

    Hmmm… So I went into “Get Info” on the Mac, and told it to make NoMachine “Open in Low Resolution”, which uses pixel doubling to hide Retina resolution from the app.  That told NoMachine that my Mac had a lower resolution than the Windows machine, and it gave me a scrolling viewport onto the ‘higher resolution’ Windows machine.  That’s what I’d expect.  But then I cleared “Open in Low Resolution” and restarted NoMachine on the Mac, and it *still* behaves as if the Mac had lower resolution than the Windows machine.

Viewing 6 posts - 1 through 6 (of 6 total)