kroy

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 435 total)
  • Author
    Posts
  • in reply to: NoMachine not working Ubuntu 18.04 #24646
    Avatarkroy
    Contributor

    There probably remains of a previous installation. To remove NoMachine completely use commands:

    sudo dpkg --purge nomachine
    sudo rm -rvf /usr/NX

    Then check a machine hardware architecture:

    uname -a

    If it shows: x86_64 – you should install amd64.deb package. If for some reason problem shows again – logs you can find in /usr/NX/var/log.

    in reply to: Power management and sleep #24630
    Avatarkroy
    Contributor

    It should not affect significantly on the NoMachine connection. You can check it out, but as it was said earlier sleep state should be disabled or you need to use some wake up utility.

    in reply to: Power management and sleep #24580
    Avatarkroy
    Contributor

    At this moment there is no way to wake up machine from sleep state by connecting with NoMachine, but there is the plan to implement such feature https://www.nomachine.com/FR09H02385. You can sign up to the ‘notify me’ in order to know when it has been implemented.

    About changing power saving states – you can modify it. There are some benchmarks of Ryzen tests in general on Reddit (search for Ryzen 2nd Gen & Windows Power Plans: Benchmarks) which show that 90% minimum processor state, has a little performance improvement with the default Windows Balanced plan (5%) comparison, but this involves increasing idle temperatures and power consumption.

    in reply to: Fails to conect to Linux nxserver #24556
    Avatarkroy
    Contributor

    From which version are you updatingNoMachine on Ubuntu? We cannot reproduce the problem. What rights have /usr/NX/var/db/limits file? It should have nx:root.

    To check permissions use command: sudo ls -ltr /usr/NX/var/db/limits. To change owner execute: sudo chown nx:root /usr/NX/var/db/limits. After changes restart nxserver (sudo /usr/NX/bin/nxserver --restart).

    in reply to: NoMachine only shows local IP to connect to #24515
    Avatarkroy
    Contributor

    Check that you have uncommented “EnableUPnP NX” key in /usr/NX/etc/server.cfg. Please refer to the article in our KB here: https://www.nomachine.com/AR11L00827.

    Avatarkroy
    Contributor

    Did you reboot system? It’s necessary to complete the installation of the NoMachine. If the problem still appears check the logs or pas them here. Instructions about debug and collecting logs you can find there: https://www.nomachine.com/<wbr />DT10O00163

    in reply to: Authentication problems again #24401
    Avatarkroy
    Contributor

    Is this headless machine? It looks Xserver isn’t running. Changing node.cfg key to DefaultDesktopCommand “/usr/bin/mate-session” should allow you to create session.

    As you had not proper permissions on the subfolders – we stronly recommend to reinstall NoMachine. Maybe you have system on external disk and it’s change permissions when you use disk on other device? Anyway we wasn’t able to reproduce that problem.

    in reply to: Problems installing NoMachine Enterprise Client #24350
    Avatarkroy
    Contributor

    We weren’t able to reproduce this problem. Are you sure it’s the latest Enterprise Client version? Installation package you can find there https://www.nomachine.com/download/download&id=16.

    If problem still appears please navigate to: c > Users > [username] > AppData > Local > Temp and find logs with installation, which should be similar to “Setup Log yyyy-mm-dd #001.txt”. Attach it and paste here output of the PowerShell comands: whoami /groups and cacls C:\ProgramData.

    in reply to: Connecting outside of LAN #24295
    Avatarkroy
    Contributor

    It looks there is some configuration problem. Please recheck local IP. You can enable UPnP to avoid problems with manual port forwarding configuration. Please refer to the instruction: https://www.nomachine.com/AR11L00827. Here you can find an information how to find port to the machine https://www.nomachine.com/getting-started-with-nomachine.

    in reply to: No audio with PulseAudio system instance #24189
    Avatarkroy
    Contributor

    Please verify if following /usr/NX/etc/node.cfg keys are set like there:

    AudioInterface pulseaudio
    CommandStartPulseAudio "/usr/bin/pulseaudio --high-priority=no"

    Check also if pulseudio is in the /usr/bin/pulseaudio on the system

    Restart nxserver (sudo /usr/NX/bin/nxserver --restart) to make changes effect.

    If problem will still appears enable debug (nxserver and nxnode) on server side, reproduce problem and send logs to forum[at]nomachine[dot]com? Instructions about debug and collecting logs you can find there: https://www.nomachine.com/DT10O00162#1.

    Please send also output of the pactl_list command (pactl list > pactl_list.log).

    in reply to: No audio with PulseAudio system instance #24053
    Avatarkroy
    Contributor

    Hi.

    Please edit /etc/pulse/daemon.conf

    change daemonize = no to daemonize = yes
    change system-instance = no to system-instance= yes

    – edit /etc/default/pulseaudio

    change PULSEAUDIO_SYSTEM_START=0  to PULSEAUDIO_SYSTEM_START=1

    – delete .pulse in your home directory and do the same fore other users

    – reboot the system

    If the problem still apears, please extract logs: sudo tar cvfz NoMachine-log.tar.gz /usr/NX/var/log/node and send them to forum[at]nomachine[dot]com. Make sure that you are connected to session during collection of the logs (in case SessionLogClean is disabled).

    in reply to: Support for Catalina? #23998
    Avatarkroy
    Contributor

    There are packages available which fix this issue. Please contact us at forum[at]nomachine[dot]com to get the package. This isn’t full fix for Mac Catalina problems, but it will help add correct Privacy permissions to make NoMachine work on this system. Full fix will follow.

    We strongly recommend uninstalling NoMachine and install the new workaround package. Please follow these short instructions and you should be able to connect without any problems.

    During installation there should show a system dialog named Accessibility Access (Events). The local user, as administrator, can then add the nxnode.bin application to the list of apps that may control the Mac. Otherwise the remote user will be able to access the Mac only in view-mode.

    Second step is adding the NoMachine application to the Screen Recording list. System dialog named Screen Recording should show after connection via NoMachine from other host.

    In the case of update, both questions show up during the first NoMachine connection. However, there could possibly still be issues with ‘Screen Recording’, so a restart of nxserver (sudo /etc/NX/nxserver --restart) mighte be necessary. Connect again to see Screen Recording pop-up.

    in reply to: Support for Catalina? #23915
    Avatarkroy
    Contributor

    Hi.

    There are some changes on the newest Mac version which we are still investigating, but in the meantime we can provide a workaround. Please follow these short instructions and you should be able to connect without any problems.

    During installation there should show a system dialog named Accessibility Access (Events). The local user, if administrator, can then add the bash application to the list of apps that may control the Mac. Otherwise the remote user will be able to access the Mac only in view-mode.

    Second step is adding the bash application to the Screen Recording list. System dialog named Screen Recording should show after connection via NoMachine from other host or just start local recording from NoMachine Client monitor icon on the system tray (recording don’t have to be saved).

    in reply to: Access multiple desktops via Internet #23829
    Avatarkroy
    Contributor

    Probably it was typo with the router model number. Isn’t it 3801hgv? You can follow that guide: https://portforward.com/2wire/3801hgv/

    1. Set static IP for machine with nxserver.

    2. Log in to the router, and then select your computer (with nxserver). Then navigate to panel from your screenshot, set some Application Name (for example: NoMachine TCP and NoMachine UDP) and choose 4000 in the Port field choose 4000. Create two applications separately with this method – for TCP and UDP.

    3. Confirm changes. Go Back and add just created applications to the Hosted Applications box.

    in reply to: Lost window controls after 6.8.1 #23788
    Avatarkroy
    Contributor

    This is not a NoMachine bug, but rather an issue in Slackware and how it handles KDE 5 which is not its default desktop environment. We had a look and found that this works:

    Try to modify startSession.sh script and add window manager startup command.

    Edit as root the last line script to looks like this:

    /usr/bin/dbus-launch --sh-syntax --exit-with-session /usr/bin/startkde --failsafe & /usr/bin/kwin_x11 --replace

Viewing 15 posts - 1 through 15 (of 435 total)