kubaszym1

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • in reply to: Update to NoMachine audio not working on Mojave #38369
    kubaszym1
    Participant

    Hi,

    Here’s what you can try:

    This command should show you the reason of the issue (run it after reboot):

    sudo kextutil -nt /System/Library/Extensions/nxaudio.kext

    The command below may help you to solve it:

    sudo kextcache -prelinked-kernel /System/Library/PrelinkedKernels/prelinkedkernel /System/Library/Extensions/nxaudio.kext

    To make sure whether .kext is added to the prelinked kernel:

    strings /System/Library/PrelinkedKernels/prelinkedkernel | grep nxau

    Please check if something is different after a reboot. If ‘sudo kextcache …’ doesn’t help, please send me the output of ‘sudo kextutil -nt /System/Library/Extensions/nxaudio.kext’

    in reply to: Update to NoMachine audio not working on Mojave #38359
    kubaszym1
    Participant

    Hi,

    Kernel extensions should be loaded automatically by the OS. I’m still not sure whether your issue is caused by the OS or by NoMachine.

    You can make sure that SIP is disabled by running:

    csrutil status

    Moreover, I would like to see some logs. Please set the log level to ‘9 – Debug’ and restart NoMachine server, then reboot your computer and load nxaudio.kext manually.

    I would like to see .nx/nxserver.log, .nx/nxerror.log, and you can also send me this folder: /Library/Application Support/NoMachine/var/log

    Send everything to forum[at]nomachine[dot]com, with the topic as reference in the subject field.

    in reply to: Update to NoMachine audio not working on Mojave #38311
    kubaszym1
    Participant

    Hi,

    It’s hard to say what happened at first glance, so I would need a crash report. In the Console app you should find some crash reports or diagnostic reports. Also, I would like to know if it happens before or after kextload, so it would be nice if you reproduced the issue.

    Please send all the log files as attachments.

    in reply to: Audio only when remote miniPC audio enabled #38249
    kubaszym1
    Participant

    Hi,

    Unfortunately there’s nothing more I can do. I found out it depends on the functionalities that your audio driver supports. There is a small chance that updating drivers might help you, but it’s not for sure.

    in reply to: Audio only when remote miniPC audio enabled #38226
    kubaszym1
    Participant

    Hi,

    You can try to workaround this issue by plugging in an external device, i.e. headphones to your Windows machine. Then connect to the Windows machine via NoMachine and check if everything works as expected. I hope it will help you. I’m still trying to find out why capturing audio doesn’t work with several drivers.

    in reply to: Audio only when remote miniPC audio enabled #38065
    kubaszym1
    Participant

    Hi,

    There is a way you can temporarily fix it. Our test team found that setting NoMachine Microphone Adapter as the default device fixes the issue but it shouldn’t work that way. Microphone adapter is for sending voice from the client to the server. We’re now trying to investigate why this happens on Windows.

    in reply to: NoMachine audio not working on Mojave #37596
    kubaszym1
    Participant

    Hi,

    Try to run it in recovery mode:

    1. Turn off your computer.

    2. Turn on your computer in recovery mode

    3. Run the command /usr/sbin/spctl kext-consent add 493C5JZAGR as before

    4. Restart your computer

    If you don’t know, how to start up you Mac in recovery mode, check here: https://support.apple.com/en-us/HT201255

    in reply to: NoMachine audio not working on Mojave #37511
    kubaszym1
    Participant

    Hello,

    You can try this command:

    /usr/sbin/spctl kext-consent add 493C5JZAGR

    If it still doesn’t work, please send me any notifications you will get.

    in reply to: NoMachine audio not working on Mojave #37386
    kubaszym1
    Participant

    Hello,

    You can check if NoMachine kernel extensions are in the kext policy database:

    sudo sqlite3 “/var/db/SystemPolicyConfiguration/KextPolicy” “SELECT * FROM kext_policy;” | grep nomachine

    Please send us the result of this command.

    Also, do you use any Mobile Device Management like JAMF?

    in reply to: NoMachine audio not working on Mojave #37367
    kubaszym1
    Participant

    Hello,

    You can update the NoMachine application to the newest version (7.8.2). Then, after the installation you should see the notification about blocked extensions. Enter the Security & Privacy as before, click the lock to make changes and allow system software from NoMachine. Please note that the possibility to unblock the loading of NoMachine system extensions is available only for 30 minutesĀ  after the system has issued the ‘System Extension Blocked’ dialog.

    in reply to: NoMachine audio not working on Mojave #37318
    kubaszym1
    Participant

    Hello,

    You can check the kernel or system logs with this command:

    tail -f /var/log/system.log

    tail -f /var/log/kernel.log

    You can also use the ‘less’ command, for example:

    less /var/log/kernel.log

    in reply to: NoMachine audio not working on Mojave #37305
    kubaszym1
    Participant

    Hi,

    First, in System preferences -> Security -> General TabĀ  in section “Allow apps downloaded from” check if the option “App store and identified developers” is marked.

    Then, please run this command:

    sudo kextload -vvv /System/Library/Extensions/nxaudio.kext

    Then you should be able to see the notifications about blocked software in System Preferences->Security->General Tab. Please allow loading system software from NoMachine S.a.r.l.. Then probably you will have to restart your machine or at least NoMachine server. You can find more information here: https://knowledgebase.nomachine.com/AR01P00962

    in reply to: NoMachine audio not working on Mojave #37092
    kubaszym1
    Participant

    Hi,

    Try this. After running the command “sudo kextutil -vvv /System/Library/Extensions/nxaudio.kext” access System Preferences -> Security&Privacy -> General panel and click on the “Allow” button.

    in reply to: NoMachine audio not working on Mojave #37078
    kubaszym1
    Participant

    Hello,
    Please check if you see NoMachine Audio Adapter in your audio settings while the session is running.
    If you don’t, please check if you can load nxaudio.kext by running the following command:
    sudo kextutil -vvv /System/Library/Extensions/nxaudio.kext/
    You can check the result by running:
    kextstat | grep nxau
    The output should look similar to this:
    265 0 0xffffff7f83cd6000 0x5000 0x5000 com.nomachine.driver.nxau (4.1.b2) 78172556-B6A4-3112-BA41-E79D18108476
    Then restart NoMachine server:
    sudo /etc/NX/nxserver –restart

    Kuba

    kubaszym1
    Participant

    Hello,

    I would like to know some details in order to help you:

    * the version of Windows you use

    * please check if Audio Service is running or not

    * You wrote that you can’t change the default output. Do you mean there are no other options available besides NM Audio Adapter or maybe there are but you can’t choose them? Or you can choose other options but they don’t work?

Viewing 15 posts - 1 through 15 (of 15 total)