kvic

Forum Replies Created

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • in reply to: Encoding issue on bright colors on Mac #25070
    Avatarkvic
    Participant

    Hi there,

    Server side has four items listed under “Scaled” resolutions:

    • 2560×1440
    • 1600×900
    • 1080p
    • 720p

    Client side has exactly the same items.

    I tried to set server to different scaled resolutions in macOS. I also realized that NX client can request custom resolution as well as setting to match client. Played with them individually or in combination. Make no difference.

    I believe the issue may be before the encoder (as it happens in h264, VP8 and MJPEG). Perhaps a common setting applicable to all of them in the encoding pipeline.

    I’m no expert in video encoding. Google pointed me to discussions about color space. In particular, some people mentioned YUV 4:4:4 vs YUV 4:2:2. The latter hurts bright colors in non-video materials (such as graphics and text). Don’t know if it’s relevant but worth checking.

    Cheers

    in reply to: Encoding issue on bright colors on Mac #24851
    Avatarkvic
    Participant

    Hi fra81

    Thanks for the prompt help. I tried your suggestion but no difference unfortunately. Based on in-line comments in the file, I also tried ‘EncoderMode quality’ but no difference either.

    Cheers

    in reply to: Possibly a bug on Mac client #24492
    Avatarkvic
    Participant

    Just installed 6.8.2 (typing this message from it). So far the fix works flawlessly. It’s a huge relief for me personally & I hope it benefits other users suffering from the same issue.

    Thank you very much for the quick fix & being so helpful!

Viewing 3 posts - 1 through 3 (of 3 total)