lorandsm

Forum Replies Created

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • in reply to: Cannot connect to server on Ubuntu Mate 20.04 #28137
    Avatarlorandsm
    Participant

    I also have a regular PC (x86_64) with the same kernel version on Ubuntu 20.04 and NoMachine is working fine on it.

    in reply to: Cannot connect to server on Ubuntu Mate 20.04 #28135
    Avatarlorandsm
    Participant

    My linux image is:

    linux-image-5.4.0-1012-raspi

    But the ticket mentions kernel version 5.4.42 and later.

    in reply to: Encryptor context errors #12219
    Avatarlorandsm
    Participant

    Logs sent to forum[at]nomachine[dot]com.

    in reply to: Encryptor context errors #12193
    Avatarlorandsm
    Participant

    Additional messages I see in the log when I connect are:

    NXSERVER ERROR! Failed to determine the client IP

    2016-08-25 21:05:20 879.109 29213 NXSERVER ERROR! Variables NX_CONNECTION,SSH_CONNECTION,SSH_CLIENT,SSH2_CLIENT not provided.

    2016-08-25 21:05:20 879.163 29213 NXSERVER ERROR! Please set SSHDCheckIP=1 if you want to refuse the connection.

    2016-08-25 21:05:20 879.217 29213 NXSERVER ERROR! Failed to get remote port. Environment NX_CONNECTION,SSH_CONNECTION,SSH_CLIENT,SSH2_CLIENT not set

    2016-08-25 21:05:20 879.271 29213 NXSERVER ERROR! Failed to get local IP. Remote IP is 0.

    2016-08-25 21:05:20 882.404 29213 NXSERVER ERROR! Wrong process id, received pid 0.

    2016-08-25 21:05:20 882.472 29213 NXSERVER WARNING! Could not get SSHD PID: Process 0 does not have expected name.

    2016-08-25 21:05:20 884.557 29213 NXSERVER ERROR! Cannot save forward server pid. ‘value’ for key sshdPid cannot be null

    2016-08-25 21:05:24 087.344 29213 NXSERVER WARNING! Cannot retrieve node socket for session A08C413482FCCD048DB746DF258F072F.

    But again, I can connect fine with the client and it’s working, but these appear in the logs.

    in reply to: Encryptor context errors #12172
    Avatarlorandsm
    Participant

    There is no other application running on port 4000, and I can connect to this station with the NX clients without problem, so this error doesn’t stop me from connecting.

    This is a free version of NX and I use it as it was installed by default, so every component is on this ubuntu machine without any changes done to the default installation.

    Eventually may it have some problem with the fact that the latest version of Ubuntu uses systemd to start processes and could NX not like it?

    in reply to: Setting desktop resolution #11706
    Avatarlorandsm
    Participant

    I found the default desktop configuration in node.cfg using the DefaultDesktopCommand. I am able to start XFCE4 but unable to start metacity, when I specify:

    DefaultDesktopCommand “/usr/bin/X11/metacity”

    only a black screen appears, though it’s not a problem to log in to metacity when lightdm is started.

    Using the configuration

    DefaultDesktopCommand “/usr/bin/X11/startxfce4”

    starts fine XFCE4 though. Could I make somehow to start metacity also when using NX’s X server as I can with XFCE4?

    in reply to: Setting desktop resolution #11705
    Avatarlorandsm
    Participant

    One question though, how can I select which desktop environment to start. Now it starts the Ubuntu default desktop, but I want it to start metacity for example. Thanks.

    in reply to: Setting desktop resolution #11704
    Avatarlorandsm
    Participant

    Thanks, the proposed solution is working.

    in reply to: Setting desktop resolution #11696
    Avatarlorandsm
    Participant

    Hi,

    – the OS info is: Ubuntu 14.04.4 LTS (GNU/Linux 3.13.0-88-generic x86_64)

    – it is a Zotac ZBOX ID88-U, the specifications can be found at http://old.zotac.com/mf/products/mini-pcs/zbox-dvd/intel/product/intel-3/detail/zbox-id88/sort/starttime/order/DESC/amount/10/section/specifications.html

    – in the initial post I’ve specified incorrectly the command used, i.e. “xrandr -r”, the output is from “xrandr -q” and that’s the whole output

    – the output of “lshw -C display” is:

    *-display

    description: VGA compatible controller

    product: Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller

    vendor: Intel Corporation

    physical id: 2

    bus info: pci@0000:00:02.0

    version: 09

    width: 64 bits

    clock: 33MHz

    capabilities: msi pm vga_controller bus_master cap_list rom

    configuration: driver=i915 latency=0

    resources: irq:51 memory:f7800000-f7bfffff memory:e0000000-efffffff ioport:f000(size=64)

    Note that no monitor is attached to the PC.

    in reply to: Login failure using NX authentication with key file #4650
    Avatarlorandsm
    Participant

    Actually I found a workaround to block users to use password log in. The trick is to enable user DB and password DB but not adding any user to the NX database.

    in reply to: Login failure using NX authentication with key file #4635
    Avatarlorandsm
    Participant

    Problem solved. The issue was that I simply copied /var/NX/nx/.ssh/default.id_dsa.pub to ‘<user’s home>/.nx/config/authorized.crt’ and the entry contained something like:

    no-port-forwarding,no-agent-forwarding,command=”/etc/NX/nxserver –login” ssh-dss AAAAB3Nza …

    With this entry the authentication didn’t work. After I deleted no-port-forwarding,no-agent-forwarding,command=”/etc/NX/nxserver –login” from the front of the public key, it worked.

    Also, I have a question related to restricting the authentication type of a user. By running the following command:

    nxserver –uaserauth <user name>

    give the authentication type of the user, which in my case returns system. I want to restrict the user to use only authentication via private/public key but I couldn’t find a way to do that. The link

    https://www.nomachine.com/DT12I00014

    doesn’t say how to impose such restrictions.

Viewing 11 posts - 1 through 11 (of 11 total)