mlyn

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 31 total)
  • Author
    Posts
  • in reply to: NX service not accessible #26214
    Avatarmlyn
    Contributor

    Hello,

    it looks like something disable NoMachine on your Windows, could you provide information about installed antivirus, used tools to encrypt HD, not default firewall?

    in reply to: NX service not accessible #26185
    Avatarmlyn
    Contributor

    Hello,
    Provided logs suggest that you skipped restart system, a restart is required to ensure that NoMachine server correctly works

    If restart doesn’t help please send logs with debug.

    Full instructions about collecting logs: https://www.nomachine.com/DT10O00163#1.4.

    in reply to: Can’t create a virtual desktop #23822
    Avatarmlyn
    Contributor

    Hello,

    there is a problem when the username forwarded to remote node contains a special character.

    We will fix it on next release, please follow up the: https://www.nomachine.com/TR09Q09418

    in reply to: Keep getting an error about connection reset by peer #23396
    Avatarmlyn
    Contributor

    Hello,

    I was checking provided logs, there I see that nxnode process crash when you try to connect.

    Please check if a core file was dumped (usually in the user’s home directory). If you find it, use the instructions here to get a backtrace: https://www.nomachine.com/AR09L00810.

    When NoMachine initializes audio, this key is being changed: “AudioInterface” to “disabled” in /usr/NX/etc/node.cfg
    allowing you to connect, but without audio.

    in reply to: Can’t see Linux machine from Windows #23388
    Avatarmlyn
    Contributor

    Hello,

    Based on the information you provided, we cannot say why you are encountering this issue. We will need logs to understand better.  Please send /usr/NX/var/log directory from the Linux machine where you are connecting to.

    Please send logs to: forum[at]nomachine[dot]com.
    Full instructions about collecting logs: https://www.nomachine.com/DT10O00163#1.3.

    Avatarmlyn
    Contributor

    Hello,

    you mention you don’t have a desktop. Are you referring to not having a desktop environment installed? Having one is pre-requisite to using NoMachine.

    If you do have a DE installed, which desktop environment is it? The error mentioned above may indicate that command for start desktop is incorrect. You should edit /usr/NX/etc/node.cfg as root and change DefaultDesktopCommand (uncomment if commented) value to – for example “/usr/bin/mate-session” if you have MATE installed.

    See also: https://forums.nomachine.com/topic/cannot-create-a-new-display-please-contact-your-system-administrator

    If you are using the Workstation, more information how to run specific desktop environment you can find there: https://www.nomachine.com/AR04K00667.

    if it doesn’t help please send logs to: forum[at]nomachine[dot]com.

    Full instructions about collecting logs: https://www.nomachine.com/DT10O00163#1.3.

    in reply to: Cannot connect after reboot #23116
    Avatarmlyn
    Contributor

    Hello,

    What to do depends on the NoMachine product you have installed.

    If you use NoMachine free version or Enterprise Desktop the login window is always visible.
    If you don’t see it, please check in the client application that you have selected “All desktops” instead of “My desktops”.
    If you have selected “All desktops” and still can’t see sessions please send logs to: forum[at]nomachine[dot]com.

    Full instructions about collecting logs: https://www.nomachine.com/DT10O00163#1.3.

    On the other hand, if you are using any of the other products from the NoMachine for Enterprise range, access to physical display is not enabled by default.

    For NoMachine Cloud Server, the user must be administrator or trusted to get access to login window.
    To make user trusted for physical desktop please use command:
    nxserver –useradd <username> –trusted physical
    To make user administrator please use command:
    nxserver –useradd <username> –administrator

    If you have any of the Terminal Server products installed, you can use the same solution as for Cloud Server or change server configuration key
    ‘PhysicalDesktopSharing’ value to 1

    Please check also key ‘LoginScreenAccess’ (default value is 1) if have a default value.

    If these suggestions doesn’t help, please collect and send logs (as per previous link above).

    in reply to: Problem with macOS 10.13.6 #22848
    Avatarmlyn
    Contributor

    Hello,

    It looks like as Mac OS issue, NoMachine need to create .nx directory in user home dir, but system return empty home dir, please check if you have correctly set field “Home directory:” in “Advanced Options”, default value is “/Users/<username>” but in your case it looks like this field is empty.

    in reply to: Problem with macOS 10.13.6 #22834
    Avatarmlyn
    Contributor

    hello,

    the logs you sent are from a clean installation without any connection, please make sure you send logs from “the other Mac” where you are trying to connect.

     

     

    in reply to: Problem with macOS 10.13.6 #22819
    Avatarmlyn
    Contributor

    Hello,

    The reason of this “no such file or directory” error will be in logs, please send /var/log directory from the machine you are connecting to.

    Please send logs to: forum[at]nomachine[dot]com.
    Full instructions about collecting logs: https://www.nomachine.com/DT10O00163#1.3.

    Avatarmlyn
    Contributor

    Hello,

    Based on the information you provided (you omitted the distribution and version which would be useful to know), we cannot say why you are encountering this issue. We will need logs to understand better.

    Please follow the instructions about collecting logs from https://www.nomachine.com/DT07M00098. After editing server.cfg and node.cfg reproduce issue and send them to forum[at]nomachine[dot]com.

    Could you also check if command ‘nxexec –auth’ works correctly, on linux default path is: ‘$ /usr/NX/bin/nxexec –auth’

    IMPORTANT! when you call this command the password will be visible on your command line.

    Correct output will be similar to: “User authorized, is member of: nomachine.”

     

     

    in reply to: Limiting options with ClientMenuConfiguration #21942
    Avatarmlyn
    Contributor

    Hello,
    as I see you use TSN, so you have also ETS as main server for this remote node,

    The key ClientMenuConfiguration should be set on main server, not on remote node.

     

    in reply to: Terminated session reappears after restart #21679
    Avatarmlyn
    Contributor

    Hello,
    It looks as nxserver start permanent physical session as ‘otherusername’.

    It is a feature which automatically creates session on headless system when using the free NoMachine version or Enterprise Desktop – Are you using either of these? – and it can be changed by keys in the server.cfg (default path /usr/NX/etc/).

    When you change something in server.cfg please call command:
    /etc/NX/nxserver --restart

    to see result.

    You can disable it by changing the CreateDisplay key or changing username in the DisplayOwner key.

    #
    # Enable or disable the automatic creation of an X11 display when no
    # X servers are running on this host (e.g. headless machine) to let
    # users connect to the desktop. This setting applies to NoMachine
    # servers not supporting virtual desktops and permits to have one
    # single display.
    #
    # 1: Enabled. NoMachine will create automatically the new display at
    #    server startup. This setting has to be used in conjunction with
    #    ‘DisplayOwner’ and ‘DisplayGeometry’.
    #
    # 0: Disabled. NoMachine will prompt the user for creating the new
    #    display. This is the default.
    #
    #CreateDisplay 0

    #
    # When ‘CreateDisplay’ is enabled, specify the display owner and let
    # NoMachine create the new display without querying the user. If the
    # server supports only one concurrent connection, the connecting user
    # must be the display owner set in this key.
    #
    #DisplayOwner “”

    #
    # When ‘CreateDisplay’ is enabled, specify the resolution of the new
    # desktop in the WxH format. Default is 800×600.
    #
    #DisplayGeometry 800×600

    in reply to: Manual node selection issues #21383
    Avatarmlyn
    Contributor

    Hello,

    String “Default node name” is use when label is empty, to change it use command:

    sudo /etc/NX/nxserver –nodeedit <nodename> –label “<some text>”

    Node Id can be ignored, it’s index on node list

    as I see you make user trusted to physical and virtual on some node, it’s not related with manual node selection, this configuration allow this user/group to access to desktop on node without desktop owner auth.

     

    in reply to: Connection refused 111 #20753
    Avatarmlyn
    Contributor

    Hello,

    we just reproduced this issue. To solve it, open a terminal and make sure you are in directory /usr/NX/var/db. Then call:
    sudo chown nx:nx unknown

     

Viewing 15 posts - 1 through 15 (of 31 total)