mlyn

Forum Replies Created

Viewing 15 posts - 16 through 30 (of 31 total)
  • Author
    Posts
  • in reply to: Connection refused 111 #20745
    Avatarmlyn
    Contributor

    Hello,

    please send logs to: forum[at]nomachine[dot]com.
    Full instructions about collecting logs: https://www.nomachine.com/DT07M00098.

    The most important is please send directory /usr/NX/var/log.

    Call command sudo /etc/NX/nxserver --startup should solve this problem with permission and start NoMachine.

    If for some reason you still have the same error call:

    in directory /usr/NX/var/db call:

    sudo ls -la running/ failed/ closed/

    and provide output this command to us, and then in the same dir call:

    sudo chown nx:nx running/.lock.special failed/.lock.special closed/.lock.special

    in reply to: Unable to login as non root user #17913
    Avatarmlyn
    Contributor

    Hello pitajnx,

    the described behaviour looks as if PhysicalDesktopMode 0/1 or VirtualDesktopMode 0/1
    are set in the server configuration file. This enables view only mode.

    You can verify by executing in cmdline:
    grep DesktopMode /usr/NX/etc/server.cfg

    By default it is set to 2 which is interactive. Try setting it back to 2 rather than 0 or 1.

    The key PhysicalDesktopMode setting  is used when we find an x server running.
    The key VirtualDesktopMode is used when we start nxframe buffer when we don’t find an x server running.

    If the output shows 2, please enable debug and share logs as described  here: https://www.nomachine.com/AR07K00677

    The logs can be attached here or sent directly to forum[at]nomachine[dot]com.

    in reply to: NoMachine desktop – web access – no display available #16612
    Avatarmlyn
    Contributor

    hello,

    you use Enterprise Desktop this license allow to access to already existing physical desktop, NoMachine checks any session is running and allows remote access.

    In that case it looks like you don’t have any running X session, using system command ‘ps’ you can check if it is running.

    To make available connect to this machine you can manually start any X session.
    If ps command return some running X session please send this output and related with it logs with enabled debug (like in last send logs).

    When you use NoMachine in version 5.3.12 you also use docker with the same configuration (dockerfile)?

    In the last provided logs I don’t see an issue with registering node, from your first post:
    “In the 6.0 nxserver logs it appears that the localhost:4000 node cannot register.”

    in reply to: NoMachine desktop – web access – no display available #16591
    Avatarmlyn
    Contributor

    Hello,

    Thank you for sending the dockerfile.

    Based on provided information I think that in your docker machine there is no xsession running.
    This could be the reason that you are not able to connect there.

    To confirm this issue I need logs, so please uncomment key SessionLogLevel and change value to 7 in both configuration file: server.cfg and node.cfg

    after that please restart NoMachine using command nxserver –restart

    after that please send logs to: forum[at]nomachine[dot]com.
    Full instructions about collecting logs: https://www.nomachine.com/DT07M00098.

    in reply to: NoMachine desktop – web access – no display available #16514
    Avatarmlyn
    Contributor

    Hello,

    Based on the information you provided, we cannot say why you are encountering this issue. We will need logs to understand better.

    Please follow the instructions about collecting logs from https://www.nomachine.com/DT07M00098. After editing server.cfg and node.cfg please restart nxserver and send them to forum[at]nomachine[dot]com.

    Could you send also your Dockerfile, it will be also useful in investigation your issue.

    in reply to: NoMachine Windows internal user database #16495
    Avatarmlyn
    Contributor

    hello,

    server.cfg file should be located in c:\Program Files (x86)\Nomachine\etc\
    I attach file with enabled user and passwords database.

    Please revert settings for nxserver.exe file then start commandline with administrator privileges

    in commandline call first:
    cd c:\Program Files (x86)\Nomachine\bin\

    and then command nxserver.exe –useradd <username>

    in reply to: Password authentification with users having same UID #15398
    Avatarmlyn
    Contributor

    Hello,
    thank you for your information, we will solve this issue in next release.
    there is a trouble report with description of your issue:
    https://www.nomachine.com/TR08O07993

    Avatarmlyn
    Contributor

    Hello,

    to run console or xterm please set path to application in key DefaultDesktopCommand in node.cfg.

    you can also create <username>.node.cfg in the same directory with different value assigned to specified user.

    Please also change ConnectPolicy key in server.cfg to have: “automigrate=0”.

    in reply to: NoMachine stuck in loading #15068
    Avatarmlyn
    Contributor

    Hello,

    based on the provided information we cannot find reason of your issue, to find it we need logs.

    Please follow the instructions about collecting logs from https://www.nomachine.com/DT07M00098. After editing server.cfg and node.cfg please restart nxserver on the server side, reproduce, gather logs and send them to forum[at]nomachine[dot]com.

    in reply to: Set a user to user a certain node #14752
    Avatarmlyn
    Contributor

    Hello,

    you can use profiles:
    Guide to set profiles for remote node

    In the case when you would like to allow specified users to access to one node, you can use the commands below.

    To disable access for all to both nodes:

    nxserver –ruleadd –class node –type <node1:port> –value no

    nxserver –ruleadd –class node –type <node2:port> –value no

    To allow specified user to access:

    nxserver –ruleadd –class node –type <node2:port> –value yes –user <username>

    or if you prefer, a possibilty is to disable access to specified node for specified user with  command:
    nxserver –ruleadd –class node –type <node2:port> –value no –user <username>

    in reply to: EnableScreenLock not working on OSX #13205
    Avatarmlyn
    Contributor

    Hello,

    the solution about you write is directly for a different issue, when you make copy of system image and use it to connect to the other one you previously copied from.

    To find reason of your issue it would first be useful to see the output command nxserver --version and server logs with debug enabled.

    Please follow instructions about collecting logs from https://www.nomachine.com/DT07M00098. After editing server.cfg and node.cfg please restart nxserver on the server side, reproduce, gather logs and send them to forum[at]nomachine[dot]com.

    in reply to: EnableScreenLock not working fully on Linux #13175
    Avatarmlyn
    Contributor

    We prepared new script which should fix your issue, you can use it on host where previous didn’t work.

    #!/bin/bash
    
    path=/usr/NX
    
    sudo $path/bin/nxserver --shutdown > /dev/null
    sudo rm $path/etc/uuid
    sudo $path/bin/nxserver --startup > /dev/null
    sudo $path/bin/nxserver --shutdown > /dev/null
    new=<code>cat $path/etc/uuid</code>
    
    sudo sed -i -E "s/\w{8}-\w{4}-\w{4}-\w{4}-\w{12}/$new/g" $path/etc/nodes.db
    sudo sed -i -E "s/unreachable/running/g" $path/etc/nodes.db
    
    sudo $path/bin/nxserver --startup
    
    echo "UUID changed to $new.";

    We tested it on a few different Linux distros  without any problems. That said we can’t guarantee 100% that it will work correctly on your OS with NoMachine free 5.1.54.

    in reply to: EnableScreenLock not working fully on Linux #13081
    Avatarmlyn
    Contributor

    it seems it didn’t attach, so I’ve pasted it:
    #!/bin/bash

    path=/usr/NX/

    old=cat $path/etc/uuid

    sudo /etc/NX/nxserver –shutdown > /dev/null
    sudo rm $path/etc/uuid
    sudo /etc/NX/nxserver –startup > /dev/null
    sudo /etc/NX/nxserver –shutdown > /dev/null
    new=cat $path/etc/uuid

    sudo sed -i s/$old/$new/g $path/etc/nodes.db

    sudo /etc/NX/nxserver –startup > /dev/null

    echo “UUID changed form $old to $new.”;

    in reply to: EnableScreenLock not working fully on Linux #13066
    Avatarmlyn
    Contributor

    We are investigating how to solve this problem, in the meanwhile please use attached script to change UUID on cloned system, if NoMachine is installed in default patch on Linux script is ready to use, on other systems or not default installation patch please change only variable “path” at the beginning of script.

    in reply to: EnableScreenLock not working fully on Linux #12940
    Avatarmlyn
    Contributor

    If you have the same NoMachine installation (for example copy system image with installed NoMacine) on client and server side please reinstall one of them.

    If you have a different installation on either, to investigate further we would need logs from server and client side. Please follow instructions about collecting logs from https://www.nomachine.com/DT04M00076. After editing server.cfg and node.cfg please restart nxserver on the server side, reproduce, gather logs and send them to forum[at]nomachine[dot]com.

Viewing 15 posts - 16 through 30 (of 31 total)