mrosing

Forum Replies Created

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • in reply to: Authorization problem #26326
    Avatarmrosing
    Participant

    Our IT guys dug into the pam.d directory and found several configuration problems.  The nx file was definitely one of them:

    “It looks like /etc/pam.d/nx was missing some settings to allow nxexec to bypass MFA”  It took a few tries and a reboot, but they got it working.  I’m not exactly sure what they did, but it now works and all is well!  Thanks!

    in reply to: Authorization problem #26159
    Avatarmrosing
    Participant

    I found a couple of things: https://www.nomachine.com/AR08M00857  and https://www.nomachine.com/DT10O00162.  I’ll see what I can come up with based on this.

    in reply to: Black screen problem #26133
    Avatarmrosing
    Participant

    I put everything back to the original (and latest NoMachine 6.9.2), plugged in a terminal to the box with the black screen, and now it works fine.  This is definitely a user error problem, thank you for the help!

    in reply to: Black screen problem #26096
    Avatarmrosing
    Participant

    So the files didn’t make it, but it looks like that doesn’t matter.  I ran nxexec –auth directly and got the following:

    /usr/NX/bin/nxexec –auth
    Username:mrosing
    Please wait…
    Please wait…
    Please wait…
    ERROR: Internal exception.
    4689 4689 08:12:35 228 nxexecPAMCheckCredentials: ERROR!Authentication failed with error 7.
    Login failed.

    There is nothing in the log from this interaction.  How can I turn on debugging to figure out why this is happening?

    Thanks!

    Mike

    in reply to: Black screen problem #26057
    Avatarmrosing
    Participant

    We changed to a different computer which is actually headless.  This time I got a set of log files, and the message:

    The session negotiation failed.

    Error: Cannot create a new display, please contact your system administrator

    The log files are attached.

    Hopefully there is a clue on how to make this work.

    in reply to: Black screen problem #26048
    Avatarmrosing
    Participant

    I uninstalled and re-installed on both sides and still got black screen.  Then I turned off gdm, and still got a black screen.  There are no errors in the logs on the server side, but the client side shows:

    19176 20295 08:20:14 390.375 ServerNetworkInfoHandler: WARNING! Obtaining network data failed.

    Rebooting to run level 3 via remote vpn is problematic.  Is there a way to capture more verbose info to help debug this?

    Thanks.

Viewing 6 posts - 1 through 6 (of 6 total)