nars

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 32 total)
  • Author
    Posts
  • in reply to: Problems with antivirus #16165
    Avatarnars
    Contributor

    Hello katwes,

    do your problems with freezes disappear when you disable Trend Micro antivirus?  Why do you think that it’s related?

    We are not able to reproduce your issue with similar environment and Trend Micro enabled, could you please reproduce the issue again and send your server and client side logs to forum[at]nomachine[dot]com? (instruction how to collect logs: https://www.nomachine.com/DT07M00098)

    in reply to: NoMachine service doesn’t work with Windows 10? #16145
    Avatarnars
    Contributor

    Hello Mick7france,

    Your issue may be related to https://www.nomachine.com/TR03O07676 , already solved in NoMachine version 6 which will be released soon.

    You could try to disable your antivirus and try to reinstall NoMachine again.

    If it doesn’t help or you don’t have any antivirus enabled please send your NoMachine logs to forum[at]nomachine[dot]com. (instruction how: https://www.nomachine.com/DT07M00098)

    Avatarnars
    Contributor

    Hello dbz2k,

    We reproduced lagging problems with Spotify application and we are sure that it’s not a NoMachine issue. We think also that warnings you mentioned are also unrelated.

    We noticed that the desktop Spotify on a few machines occasionally causes little lags during connection but the same problems occurs without using NoMachine.

    We advise you to try the web version of Spotify as it works without problems.

    We suggest you to contact with Spotify https://community.spotify.com/, because some Spotify users has similar problems with desktop application, while Web Player is fine.

    in reply to: NoMachine connection over the internet #15140
    Avatarnars
    Contributor

    Without knowledge about your network environment it’s very hard to say.

    You could:

    – Talk with your ISP, ask if you have individual external IP

    – Check if pings are blocked in your router settings

    – Scan if you have ports used by NoMachine blocked (ex. using this http://www.ipfingerprints.com/portscan.php page)

     

    This kind issues you should solve with your administrator or network provider 🙂

     

    in reply to: NoMachine connection over the internet #15119
    Avatarnars
    Contributor

    Hello ppeixoto,

    There may be a lot of issues causes that you received 138 error (ERR_NETWORK _ACCESS_DENIED) while connecting. All are related to network configuration. To check where a problem is, please go through following steps:

    – Check if your external IP on server host is the same like indicated by NoMachine Client (Server Status window from your screen). You can check it for example on https://www.whatismyip.com/.

    – Check if you can ping external IP of your server host from your client host.

    – Check on router if ports which you use to connect using NoMachine isn’t blocked.

    If your server is behind a NAT router or a firewall it’s possible that you have no UPnP enabled on your server side router. In that case please follow https://www.nomachine.com/AR11L00827 article.

     

    Regards.

    in reply to: Bad Install/Can’t Connect to Physical Desktop #13330
    Avatarnars
    Contributor

    Hello MitchelValentine,

    thank you for reporting your issue to us. Information that “no desktop is available” is displaying on free license if server find running X server during startup but cannot find it when you connect to server using nomachine player. On our Lubuntu 16.04 NoMachine works well so may I ask you some questions which may help in investigation?

     

    – If you run “sudo /usr/NX/bin/nxserver –status” command on server side, nxnode service is enabled?

    – What is an output of command ps aux | grep X on server side?

    – Do you start desktop environment in any non default way? Similar symptoms occures if you shutdown/startup display environment without restarting NoMachine server for example using init command.

    – Do you use any non default Display Manager?

    – Output of command sudo /usr/NX/bin/nxserver –version” from server side also would be helpful.

    It’s very likely that running command “sudo /usr/NX/bin/nxserver –restart” on server machine will fix your issue. Anyway we will be very grateful for sending answers for questions above.

    in reply to: Ubuntu 16.04 exits when NX session starts #12690
    Avatarnars
    Contributor

    After many attempts, we are still not able to reproduce this issue. Make sure you are using the latest version of the server software. We would need to see the server-side logs as well(/var/log/Xorg.0.log.old file and the ~/.xsession-errors from server machines). Send them to forum[at]nomachine[dot]com after problem occurs again.

    If you’re using legacy 3.5.0 , you should submit your enquiry via the customer area.

    Regards.

    in reply to: Fail2ban jail #12661
    Avatarnars
    Contributor

    In the case of incorrect login/password you can find in default mode logs a line like

    2016-10-06 11:54:58 110.837  5478 NXSERVER ERROR! wrong ‘nxexec authentication’ for user ‘nomachine1’ from ‘10.0.1.61’.

    which unambiguously indicates a problem with logging and contains client IP.

    In the case of wrong certificate it is more difficult. There are no log line contains both client IP and information about wrong authentitation. To get it you may activate a server debug log (set “SessionLogLevel 7” in /usr/NX/etc/server.cfg configuration file) and find line informing about client connecting using the same nxserver –login process PID for example by run as root:

     PID=grep -i "ERROR: Cannot accept public key" /usr/NX/var/log/nxserver.log | tail -1 | sed 's/NXSERVER ERROR.*//g' | awk '{ print $NF }'

    cat /usr/NX/var/log/nxserver.log | grep “Local IP determined from NX_CONNECTION” | grep $PID | tail -1 | sed ‘s/.*NX_CONNECTION: //g’ | cut -f 1 -d ” “

    which returns an client IP adress as result.

    Please note that keeping server in debug mode for a long time consumes a lot of disc space.

     

    Regards.

    in reply to: Fail2ban jail #12616
    Avatarnars
    Contributor

    Hello ty,

    log entries for NoMachine 5.1.54 free related to failed authentications are listed below.

    Logs of failed authentication are stored in /usr/NX/var/log/nxserver.log without enabling any additional debug modes. Just keep log level at 6 what is default.

     

    a) Incorrect login log

    2016-10-06 11:54:58 111.214  5478 NXSERVER ERROR! Sending error message ‘NX> 404 ERROR: Wrong password or Login.’

     

    b) Incorrect password log

    2016-10-06 12:05:56 953.011  5495 NXSERVER ERROR! Sending error message ‘NX> 404 ERROR: Wrong password or Login.’

     

    c) Incorrect key log

    2016-10-06 12:23:04 676.653  5840 NXSERVER ERROR! Sending error message ‘NX> 500 ERROR: Cannot accept public key. ‘

     

    Regards.

    Avatarnars
    Contributor

    Hello alphonse,

    to start session automatically you may use the command:

    “<NoMachine directory>/bin/nxplayer –session <nxs file>”

    where NoMachine directory is for example /usr/NX on linux and ‘nxs’ is a connection file generated in <home dir>/NoMachine (or <home dir>/Documents/NoMachine on Windows) every time when you create a new connection using nxplayer.

    Let’s configure nxs file to automatically connect to session – create new connection (nxs file) by clicking “new” in “recent connections” nxplayer view. Connect to server using it, type user credentials and check “save this password in connection file”. If you want to run new session, go to “New desktop”, select “Save this setting in the connection file” and create a session. If you want to connect to physical session then you have to install a version which doesn’t include virtual sessions feature – for example free or enterprise-desktop – then you will automatically connect to physical session when connect to server. It is not possible to connect to physical session directly if thw product contains the feature for creating new sessions on server. You can find more information about modifing nxs files here -> https://www.nomachine.com/DT02M00075

    After every reinstallation of NoMachine, nxplayer will need verification of host authenticity. You may copy certificates using script by adding to <home dir>/.nx/config/client.crt a certificate from server side located in <NX directory>/etc/keys/host/nx_host_rsa_key.crt file. In file, before certificate you should put information about server IP, ex.:

     

    Host:10.0.1.2

    —–BEGIN CERTIFICATE—–

    <certificate>

    —–END CERTIFICATE—–

     

    Nxplayer started from the command line doesn’t return any code. You may check if connection was established correctly by greping in nxplayer logs (session and connection files located in <home directory>/.nx/R-<nxplayer pid>-XXXXXXX)

    I recommend also to look at <home directory>/.nx/config/player.cfg file, you may change a lot of nxplayer settings here.

     

    Regards.

    in reply to: Ubuntu 16.04 exits when NX session starts #11569
    Avatarnars
    Contributor

    Hello,

    thanks for the report. We are not able to reproduce your issue in our labs. Can you let us know:

    – if you run any specific software on your ubuntu when connecting;

    – if you are running a physical or a virtual session.

     

    Additionally, it would be useful if you could send us the /var/log/Xorg.0.log.old file and the ~/.xsession-errors files on the server machines. You can send them to forum[at]nomachine[dot]com.

     

    Regards.

     

    Avatarnars
    Contributor

    Hello Darknite999,

    We are not able to reproduce your issue in our labs so we will need more details.

    Did you restart NoMachine after unticking “Require permission to let remote users connect” and “Require permission to let remote users interact with the desktop” options? (by clicking on “Restart NoMachine for changes to take effect”).

    You can try to disable this option directly in server configuration file by setting a key “PhysicalDesktopAuthorization 0” in <NoMachine directory>/etc/server.cfg.

    Which NoMachine version are you using? We suggest to update to the latest 5.0.63 because restarting NoMachine after these options is no longer needed.

    Please note that attaching to the physical desktop requires permission only if you are logging with an account that is not the desktop owner i.e the user which is currently logged in to the system.

    Which other remote desktop software are you using to click “Accept the incoming connection”? We would like to check that it’s not interfering with NoMachine.

    If none of my hints help you then you will need to send logs and a content of server.cfg file. Please zip content of c:/ProgramData/NoMachine/var/log and c:/Program Files/NoMachine/etc and send them to forum[ at ]nomachine[dot]com.

     

     

    Regards.

    in reply to: Error is 61: Connection refused #7419
    Avatarnars
    Contributor

    Hi jy,

    please run following command on server side via terminal:

    $ sudo /etc/NX/nxserver –status

    Are all services shown as enabled?

    Do you see NoMachine icon in osx tray?

    To fix it please run

    $ sudo /etc/NX/nxserver –restart

    and try to connect again.

    If issues appears again, please send logs to us to forum[at]nomachine[dot]com. Instructions for collecting logs you can find here – https://www.nomachine.com/AR10K00697.

     

    Regards.

    Avatarnars
    Contributor

    Hello paulwjh,

    We are aware of problems with compatibility between our oldest released version 4.0.369 and newest one. Suggested solution is to reinstall your NoMachine on server machine to the newest version.

    Regards

    in reply to: Unable to unlock screen #7381
    Avatarnars
    Contributor

    Hello, haditya

    We known about similar issue on certain Linux versions, it’s linux core issue. What exact Linux distribution/version do you use? Possible solution is try to upgrade your system or disable the screenlock.

    Regards.

Viewing 15 posts - 1 through 15 (of 32 total)