nars

Forum Replies Created

Viewing 15 posts - 16 through 30 (of 32 total)
  • Author
    Posts
  • in reply to: Server failure openSuSE 13.2 with linux kernel 4.x #7306
    Avatarnars
    Contributor

    Hello, daltrey

    Could you check if you have enabled any firewall on this machine? If yes, please try to disable it or add nomachine as exception and try to connect one more time.

    We are not able to reproduce your problems in our laboratory so we have to ask you to send logs from your Windows and OpenSUSE machines.

    Instructions for collecting logs you can find here – https://www.nomachine.com/AR10K00697. You can send them to forum[at]nomachine[dot]com.

     

    Regards.

    in reply to: Changing the nxclient binding port(default 25001)? #7268
    Avatarnars
    Contributor

    Hi, amosbird,

    To change nxclient binding port you should change a value of DisplayBase key in <NoMachine directory>/etc/server.cfg configuration file. New binding port will have number 24000 + <display number>, where display number is a DisplayBase for nxclient of physical session, and higher by one for nxclient run for every next virtual session).

    Please notice that DisplayBase value should be higher than 1000.

    Regards.

    Avatarnars
    Contributor

    Hello Mottofabster,

    Your issues are probably due to disabling or uninstalling a WoW64, an x86 emulator, which allows 32-bit Windows-based applications to run seamlessly on 64-bit Windows. WoW64 is now an optional feature in Windows Server 2008 RC2 that you must install if you want to install NoMachine.

    Article about how to fix it you can find here: http://support.microsoft.com/pl-pl/kb/974727/en-us

    Problem with “error 146 no data message” should be fixed in newest NoMachine version. To fix it on 4.4.6 you could try to run:

    “C:\Program Files (x86)\NoMachine\nxserver” –restart

    Regards.

    in reply to: Connect to VPS #6454
    Avatarnars
    Contributor

    Hello stanislasr,

    What kind of problems do you have with NoMachine on VPS?

    If your VPS is a headless server (doesn’t have a Graphical User Interface) you should check the following instructions: https://www.nomachine.com/AR10K00710

     

    Regards.

    in reply to: NX Service not starting #6382
    Avatarnars
    Contributor

    Hello HenryTheTech,

    Thank you for sending a logs, however they are not sufficient for us to find the problem.

    Could you please set log level to debug and send to us also your server side $HOME/<username>/.nx directory?

     

    Please:

    – edit /usr/NX/etc/server.cfg, uncomment and set “SessionLogLevel 7”

    – edit /usr/NX/etc/node.cfg, uncomment and set “SessionLogLevel 7”

    – reproduce the problem

    – send to us content of /usr/NX/var/log and $HOME/.nx

     

    Regards.

    in reply to: Cannot connect to Linux machine #6258
    Avatarnars
    Contributor

    Hello homebrewdude,

    could you check if you have enabled any firewall on this machine? If yes, please try to disable it or add nomachine as exception and try to connect one more time. If it isn’t, we will need logs. Instruction of collecting logs you can find here – https://www.nomachine.com/AR10K00697. You can send them to forum[at]nomachine[dot]com.

    Regards.

    in reply to: The "New desktop" button is disabled #6062
    Avatarnars
    Contributor

    Please check the updated article here: https://www.nomachine.com/AR10K00710.

    To install Xvfb on Amazon EC2 Red Hat t2.micro you should enable rhui-REGION-rhel-server-optional repository by running:

    $ sudo subscription-manager repos –enable rhui-REGION-rhel-server-optional

    or set it manually in /etc/yum.repos.d/redhat-rhui.repo

    Amazon EC2 Red Hat t2.micro you should enable

    in reply to: The "New desktop" button is disabled #6048
    Avatarnars
    Contributor

    Hello zzzhhh,

    Problem isn’t related to NoMachine software but to RedHat. Instruction of installation Xvfb (“sudo yum install xorg-x11-server-Xvfb”) is correct. You can find the answer for your issue here: http://serverfault.com/questions/344793/install-xvfb-via-yum-yum-repository-for-xvfb or by enabling rhel-7-desktop-optional-beta-rpms repository.

    We will check specifically against the RH t2.micro instance and make sure the article is updated.

    in reply to: Nxserver can’t start on Opensuse 13.2 #5773
    Avatarnars
    Contributor

    Hello dvpaul,

    we are not able to reproduce your problem in our labs. It may be due to your network interface configuration, from the logs you posted it’s hard to tell.

    Could you please increase logs level by setting SessionLogLevel key in your /usr/NX/etc/server.cfg and /usr/NX/etc/node.cfg and send the entire contents of /usr/NX/var/log to us?

    Instructions on how to collect logs: https://www.nomachine.com/AR10K00697

    Send everything to issues[at]nomachine[dot]com and reference the topic title in your subject.

     

    Regards.

    in reply to: Error is 138: Connection timed out #5529
    Avatarnars
    Contributor

    Hello PPG2014,

    You are trying to connect from host with IP “A” to virtual machine where is installed NoMachine server with IP “C” (10.0.2.15).

    Virtual machine is running via VirtualBox software running on host with IP “B”. You should try to connect to IP “B”, it will redirect you to Virtual Machine “C” because of port forwarding.

    Regards.

    in reply to: Error is 138: Connection timed out #5500
    Avatarnars
    Contributor

    We suspect that you are trying to connect using virtual machine IP.

    You should try to connect to IP of the machine on which Virtual Box VM is running. Use the correct port which was forwarded to the VM you are trying to connect to.

     

    Regards.

     

    in reply to: Error is 138: Connection timed out #5476
    Avatarnars
    Contributor

    Hello PPG2014,

    In NoMachine player you should change the protocol and port of connection by right clicking on it and choosing “edit connection”, then specify correct preferences as you see in the attached image.

     

    Regards.

    in reply to: Configuring default guest sessions #5142
    Avatarnars
    Contributor

    Hi, spookydude

    Please note that it’s currently impossible to automatically start Custom session set to “Run the default X client script on server”.

    However it’s possible to automatically start a Default session and you can adjust it to whatever you need.

    Please change DefaultDesktopCommand key in /usr/NX/etc/node.cfg to command you prefer.

    To configure server to run automatically default virtual desktop you should use profiles to disable all other session types except of unix-xsession-default for guest users by executing:

    /usr/NX/bin/nxserver –ruleadd –class session –type physical-desktop –value no –guest

    /usr/NX/bin/nxserver –ruleadd –class session –type unix-console –value no –guest

    /usr/NX/bin/nxserver –ruleadd –class session –type unix-default –value no –guest

    /usr/NX/bin/nxserver –ruleadd –class session –type unix-application –value no –guest

    /usr/NX/bin/nxserver –ruleadd –class session –type vnc –value no –guest

    /usr/NX/bin/nxserver –ruleadd –class session –type windows –value no –guest

    in reply to: System Messages Not Appearing in Red Hat Virtual Session #5041
    Avatarnars
    Contributor

    Hello CityRoamer,

    we are not able to reproduce the issue reported by you and we will need some more information.

    Are you connecting via NX or SSH protocol?

    Which program do you use to show error alerts? Is it abrt or something else?

    Could you tell us the specific application that you are using when these pop ups appear?

    Do you mean that the messages don’t appear in the virtual session because they are shown on the physical display? Or aren’t they shown at all?

    in reply to: No available sessions, RHEL 7 #4421
    Avatarnars
    Contributor

    Currently netstat is required for the proper working of NoMachine. This should be changed in future versions. You can install it by installing net-tools package:

    sudo yum install net-tools

     

    ck-list-sessions is not required, message about that it is not found is a cosmetic issue and also should be fixed in next versions.

Viewing 15 posts - 16 through 30 (of 32 total)