noj

Forum Replies Created

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • in reply to: Change NoMachine virtual desktop user #30118
    Avatarnoj
    Participant

    Actually I confused myself a bit… this is indeed on Enterprise Desktop that I wanted to do this.  We use the Desktop version as we have a one-to-one association between users and their desktops, and we are using NX to provide remote GUI access.

    I checked in the documentation and confirmed with my sales rep that Virtual Desktops are indeed supported and approved by our Enterprise Desktop license, as long as its a one-to-one and we are not trying to use it like a terminal server or with multiple people connected concurrently.  My issue was that I,  as a system administrator,  need to occasionally connect to the NX host as myself to verify that things are running properly and then disconnect before I let a user know that they can connect as themselves.  Doing so caused the DisplayOwner to be set in the server.cfg file, and I had to remove that to let it reset to default before letting a user know that they could connect as themselves.

    in reply to: Change NoMachine virtual desktop user #30105
    Avatarnoj
    Participant

    Thank you for pointing that out… we actually started with desktop and then switched to workstation and I hadn’t realized I had still been using the old desktop RPM in the installation playbook.  I suspect that installing that will fix the issue I am seeing as I don’t remember running into this issue previously.  Now I need to go back and check all of my installations and make sure they are using the right RPM… doh!

    On a side note though, I found what I needed to change.  The DisplayOwner gets set in /usr/NX/etc/server.cfg.  Setting that back to default after a test connection will allow the permanent user to connect to a new virtual desktop that is owned by them.

Viewing 2 posts - 1 through 2 (of 2 total)