ohw2020

Forum Replies Created

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • in reply to: Errors on CentOS 6 server #26361
    Avatarohw2020
    Participant

    After extensive and painful testing on my home setup I can report the following:

    As indicated in my previous post, a lot of error messages are related to loading of audio modules. Indeed, after disabling audio in node.cfg (AudioInterface disabled) the logs look much cleaner. Personally, I don’t have any use for audio via NoMachine at all, I just need the graphical desktop.

    The long delay for gdm to re-appear is still evident; it may be related to these lines which repeatedly appear in nxerror.log

    ... HostWmRunningHelper: WARNING! Failed to open display ':0'.

    ... HostRead: WARNING! Descriptor FD#8 is invalid.

    I still see sporadic messages of the following kind in nxserver.log:

    NXSERVER WARNING! Node localhost:4000 from session {...} reported: Session with pid '{...}' terminated unexpectedly.

    … and directories of type F-C-{…}-{…}-{…} keep accumulating in /usr/NX/var/log/node.

    All of the above may appear as log noise since from a naive user’s perspective things seem to work reasonably. But looking more thoroughly the current version appears to have some flaws at least with this linux version.
    Still checking for disconnects …

    in reply to: Errors on CentOS 6 server #26344
    Avatarohw2020
    Participant

    Dear Mth,

    thanks for the prompt reply.

    The machine in question runs the default gnome 2 via gdm, nvidia quadro graphics, a kvm hypervisor (no running virtual machines) — nothing special really. Monitor is switched off, in case that matters for the behaviour of the X server.

    I should stress that the “waiting for desktop user” message only appears when I try to reconnect after the connection has crashed; in this situation the physical desktop session is open but I am not recognised as the same user any more. After restarting the nx server this problems is solved, and I can connect to the (still running) desktop session directly, i.e. without supplying username/password to gdm again.

    In the meantime I have investigated further and, for comparison, installed the same NoMachine version on a local CentOS 6.10 machine next to the macOS client. On this machine, I can reproduce the majority of warnings and also the “directory not empty” error. In fact the latter appears on every login (on both servers) and — contrary to my initial suspicion — is not indicative of the imminent crash/disconnect. These warnings/errors seem to be related: Loading some audio-related module(s) fails, and directories in /usr/NX/var/log/node are found not to be empty since they retain /devices/audio files. So I believe this is specific to CentOS 6, not to an individual machine.

    The message referring to a 10-sec timeout, however, is not a regular symptom, in fact I now realised that it  appeared only once in the log. What is absolutely reproducible, however, is the long delay between logging out from the graphical session and re-appearance of the gdm login screen. On the physical display the login screen appears immediately, but on the NoMachine client it takes many seconds (15?). This happens when connected from macOS to either of the two CentOS machines, and also between the CentOS computers.

    Overall I tend to think the many audio module-related warnings and the “directory not empty” errors should be readily reproducible on every EL6 machine. I am happy to provide logs as soon as the disconnect happens again.

    Best regards
    ohw2020

     

Viewing 2 posts - 1 through 2 (of 2 total)