paai

Forum Replies Created

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • in reply to: No hardware sound on server #33811
    Avatarpaai
    Participant

    Hi Tsotne,

    it may be too early to declare success, but setting the CreateDisplay key certainly had an effect. Restarting the server made it come up with the hardware audio enabled. Cycled through it a few times and the change seems to be permanent. Still, I wonder what caused it in the first place.

    So if you don’t hear from me, the problem is solved.

    Thank you again.

    Paai

     

     

    in reply to: No hardware sound on server #33795
    Avatarpaai
    Participant

    The problem seems to be that there are two NM sessions. On the server runs display :0. On the client runs display echo $DISPLAY
    :1002

    Is there a way to force the NM client to attach to display :0 in stead of creating a new display?

     

     

     

     

    in reply to: No hardware sound on server #33788
    Avatarpaai
    Participant

    Still not out of the woods.  Even when het monitor is disabled, some reboots make the sound disappear, and some are all right. All reboots report a physical desktop, but I know that there is another NM session flapping around invisibly, because on powerup, when I try to start, e.g. a firefox window,  the Kubuntu desktop says ‘another Firefox session is active’.

     

    in reply to: No hardware sound on server #33751
    Avatarpaai
    Participant

    Dear Tsotne,

    as far as I know, only physical sessions are possible on the free NoMachine, and indeed, the connection properties say ‘Physical session’.

    However, your post set me thinking and I climbed up the attic where the server lives, and the attached monitor still was live for some reason. I disabled the monitor, rebooted the server and now I have sound. The logic is not clear, but I am happy to have my music back.

    Thank you again.

    paai

     

    in reply to: No hardware sound on server #33701
    Avatarpaai
    Participant

    Data are on its way by email. Hope it arrives as there are three logfiles attached: the first 'sudo /etc/NX/nxserver --debug --collect' was executed twicefor some reason . The pavucontrol screens contain the exact same information as the System Settings: two  ‘NoMachine outputs’ and one ‘Simultaneous Output to NoMachine Output’.

    Thanks.

     

    in reply to: No hardware sound on server #33693
    Avatarpaai
    Participant

    OK, I emailed the logs and the pactl output with as subject “No hardware sond on the server”. I also kept toggling the ‘mute audio on server’ checkbox as I have done for the last week.

    Paai

     

     

    in reply to: No audio between two Ubuntu 18.04 machines #33682
    Avatarpaai
    Participant

    @Tsotne, I opened a new thread “no hardware sound on server” and copied your answer to me to that thread.  Is it OK that we use that other thread for my problem? https://forums.nomachine.com/topic/no-hardware-sound-on-server

    Paai

     

    in reply to: No hardware sound on server #33681
    Avatarpaai
    Participant

    (I copied this from ths thread “no audio on two Ubuntu 18.04 machines”  after opening this thread, to keep the subjects clean)

    Hi Paai,
    so you mean that you don’t get audio in amplifier during NoMachine session, yes? or it stops working just after installing NoMachine , without using NoMachine session?

    NoMachine doesn’t “kill/stop” default sinks/source that’s why NoMachine use its own sink/sources.

    Please upload logs (instruction is the same how I advised Dan)

    Just while you will be connected to the host machine using NoMachine, please try to check/uncheck “mute audio on server” option a few times.

    Also provide output of commands of pactl on host machine before you connect using NoMachine and upload screen of pavucontrol output device tab.

     

    in reply to: No audio between two Ubuntu 18.04 machines #33647
    Avatarpaai
    Participant

    Hi all,

    (I would open an new topic, but I can’t find how to do so)

    My problem is rather similar. Two Kubuntu 18.04 machines with the free NoMachine – Version 7.5.2. The server machine has an HDA NVidia sound system. Stand-alone this works. System Settings shows ‘Built in Audio Analog Stereo’ as expected

    But… when I install NoMachine on that server, in System Settings the line ‘Built in Audio Analog Stereo’ is greyed out and three more choices appear: two ‘NoMachine ouput’ lines and one ‘Simultaneous output to NoMachine output’.

    I can stream sound between the computers OK.

    However, I have an amplifier attached to the line-out of the server. So I have the checkbox ‘mute audio on server’ unchecked. This has worked without problems for a few years. But all of a sudden it seems that NoMachine kills the regular ‘Built in Audio Analog Stereo’ because whatever I do no sound comes into the amplifier. If I uninstall NoMachine from the server, the amplifier works again.

    Thank you for reading this.

    paai

     

    in reply to: No sound on server hardware ‘line out’ #30825
    Avatarpaai
    Participant

    @britgirl. After reinstalling the server (the Linux server) things worked again.

    I use Linux since 1993 and from my point of view the userfriendliness has not improved. as ”mean and lean” has been replaced by ” as bloated as the next system”. Ah well, that is evolution. In any case, I use NX since the beginning and let me thank NoMachine again and again and again for making their system available for the home user.

     

    Avatarpaai
    Participant

    Same here. After removing the old /usr/NX directory, I get


    NX> 700 ERROR: Cannot change ownership of: /etc/NX/nxserver to: nx:nx.
    NX> 700 Server install completed with warnings.
    NX> 700 Please review the install log for details.
    NX> 700 Install completed with errors at: Sun Oct 27 11:42:02 2013.
    NX> 700 NoMachine was configured to run the following service:
    NX> 700 NX service on port: 4000

    and when I try to login with the 3.5 client, I get nx server unavailable or disabled.

    BUT

    when I again removed the /usr/NX directory and tried to install version 4 again, I got:

    paai@breslau:~/Downloads$ sudo dpkg -i nomachine_4.0.352_1_i386.deb
    (Reading database … 354868 files and directories currently installed.)
    Preparing to replace nomachine 4.0.352-1 (using nomachine_4.0.352_1_i386.deb) …
    dpkg: error processing nomachine_4.0.352_1_i386.deb (–install):
    subprocess new pre-installation script returned error exit status 127
    Errors were encountered while processing:
    nomachine_4.0.352_1_i386.deb

    What now?

    By the way, I am very glad with the free linux NX and have been using it for almost as long as it exists.
    If I did not have to pay for this excellent piece of software, I hope I made up for it by praising it on
    every opportunity.

    Paai

Viewing 11 posts - 1 through 11 (of 11 total)