rcasero

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • in reply to: Black screen connecting to physical display #24525
    Avatarrcasero
    Participant

    I’ve tried the patched version, and it fixes the black screen problem. Now it connects correctly.

    in reply to: Black screen connecting to physical display #23899
    Avatarrcasero
    Participant

    Hi Mth,

    The dbus service seems to be fine:

    $ systemctl status dbus.service

    ● dbus.service – D-Bus System Message Bus

    Loaded: loaded (/lib/systemd/system/dbus.service; static; vendor preset: enabled)

    Active: active (running) since Wed 2019-10-02 17:30:43 BST; 4 days ago

    Docs: man:dbus-daemon(1)

    Main PID: 932 (dbus-daemon)

    Tasks: 1 (limit: 4915)

    Memory: 6.0M

    CGroup: /system.slice/dbus.service

    └─932 /usr/bin/dbus-daemon –system –address=systemd: –nofork –nopidfile –systemd-activation –syslog-only

     

    Oct 07 10:24:18 lin06 dbus-daemon[932]: [system] Activating via systemd: service name=’net.reactivated.Fprint’ unit=’fprintd.service’ r

    Oct 07 10:24:18 lin06 dbus-daemon[932]: [system] Successfully activated service ‘net.reactivated.Fprint’

    Oct 07 10:33:09 lin06 dbus-daemon[932]: [system] Activating via systemd: service name=’org.freedesktop.PackageKit’ unit=’packagekit.ser

    Oct 07 10:33:09 lin06 dbus-daemon[932]: [system] Successfully activated service ‘org.freedesktop.PackageKit’

    Oct 07 10:40:38 lin06 dbus-daemon[932]: [system] Activating via systemd: service name=’org.freedesktop.PackageKit’ unit=’packagekit.ser

    Oct 07 10:40:38 lin06 dbus-daemon[932]: [system] Successfully activated service ‘org.freedesktop.PackageKit’

    Oct 07 11:16:46 lin06 dbus-daemon[932]: [system] Activating via systemd: service name=’org.freedesktop.hostname1′ unit=’dbus-org.freede

    Oct 07 11:16:46 lin06 dbus-daemon[932]: [system] Successfully activated service ‘org.freedesktop.hostname1′

    Oct 07 11:40:16 lin06 dbus-daemon[932]: [system] Activating via systemd: service name=’net.reactivated.Fprint’ unit=’fprintd.service’ r

    Oct 07 11:40:17 lin06 dbus-daemon[932]: [system] Successfully activated service ‘net.reactivated.Fprint’

     

     

    in reply to: Black screen connecting to physical display #23857
    Avatarrcasero
    Participant

    PS. I’ve emailed new logs.

    in reply to: Black screen connecting to physical display #23854
    Avatarrcasero
    Participant

    Hi,

    I have installed nomachine_6.8.1_1_amd64.deb on client and server. I also had to make myself a trusted user on the server with

    sudo /etc/NX/nxserver –useredit rcasero –trusted physical

    The client establishes the connection, but still only shows a black screen.

    in reply to: Black screen connecting to physical display #23774
    Avatarrcasero
    Participant

    Hi,

    I’m getting the error when I try to upgrade:

    $ sudo dpkg -i nomachine-workstation_6.8.1_1_amd64.deb

    (Reading database … 205897 files and directories currently installed.)

    Preparing to unpack nomachine-workstation_6.8.1_1_amd64.deb …

    Sorry, your upgrade period has expired. To be able to

    install a new version of the software, please visit the

    NoMachine Web site at http://www.nomachine.com/

    to acquire a valid subscription.

     

    Does the NoMachine free version work with physical displays? I want to test that it works before we consider buying a subscription.

    in reply to: Black screen connecting to physical display #23695
    Avatarrcasero
    Participant

    1. Is it freshly installed Ubuntu 19.04, or updated from older version?

    Freshly installed.

    2. Do you have any changes in gnome configuration? It looks like there is no
    Wayland running, but maybe that is the issue here that it is not detected.

    No changes, other than changing the wallpaper and adding a second keyboard layout.

    3. Do You have any virtual X servers running? (like vnc or xvfb)

    No.

    4. If You can, please provide us with output of

    ‘# ps -efjH’

    OK, I’ve sent it by email.

    Maybe it has something to do with the nvidia driver that I mentioned in one of my first posts?

     

    On a related note, it seems that when your reply #23646 started a new page in this thread, it automatically set me to “Unsubscribed”, so again I didn’t get an email notification from your last post.

    in reply to: Black screen connecting to physical display #23655
    Avatarrcasero
    Participant

    Last workaround tried (editing node.cfg and server.cfg and restarting nxserver), but it doesn’t work. I still get the same black screen. I have emailed the new logs.

    in reply to: Black screen connecting to physical display #23648
    Avatarrcasero
    Participant

    Email notifications now working, thanks.

    in reply to: Black screen connecting to physical display #23642
    Avatarrcasero
    Participant

    Hi /Mth,

    Thanks for the proposed workaround, but it didn’t work. I still get a black screen, and moving the mouse, clicking or typing doesn’t do anything.

    In more detail: I edited the files on the server side, as requested. The option PhysicalDisplays didn’t exist in file ‘/usr/NX/etc/server.cfg’, so I added the suggested line to the end of the file. Same thing with DisplayBase in /usr/NX/etc/node.cfg’. I restarted nxserver as requested. Then I tried to connect with the client.

    I have emailed the logs again.

    On a related note, I’m still not receiving email notification from your replies.

    Kind regards,

    Ramon.

    in reply to: Black screen connecting to physical display #23626
    Avatarrcasero
    Participant

    Hi Britgirl,

    I’ve emailed the logs again, as requested.

    Just to confirm, I didn’t get an email notification for your last post either, September 12, 2019 at 15:28

     

    in reply to: Black screen connecting to physical display #23605
    Avatarrcasero
    Participant

    OK, I’ll extract a new set of logs when I get home.

    Not receiving email notifications for your replies yet (I only get emails for the ones I write myself). I’m positive that the tick box for “Notify me on follow-up replies via email” was ticked. Like in this reply I’m writing right now. The box is in front of my eyes, and it’s ticked.

    in reply to: Black screen connecting to physical display #23595
    Avatarrcasero
    Participant

    PS. On a related issue, Britgirl, although I checked “Notify me of follow-up replies via email”, I haven’t received an email notification for your reply (I checked my spam folder too).

    in reply to: Black screen connecting to physical display #23594
    Avatarrcasero
    Participant

    Hi, isn’t that the NoMachine-log.tar.gz file that I already sent to you?

    That should correspond to “1. How to Collect Server Side Logs” -> “1.1. Server on Linux”

    in reply to: Black screen connecting to physical display #23460
    Avatarrcasero
    Participant

    Another detail that may be relevant, I’m using the Nvidia driver nvidia-driver-418 on both desktop and laptop.

    in reply to: Black screen connecting to physical display #23458
    Avatarrcasero
    Participant

    Logs have been sent by email to as described in https://www.nomachine.com/DT10O00163

Viewing 15 posts - 1 through 15 (of 15 total)