reza

Forum Replies Created

Viewing 15 posts - 16 through 30 (of 142 total)
  • Author
    Posts
  • in reply to: Does the wifi network affect NoMachine? #15075
    reza
    Moderator

    Please assure that ports used by NoMachine are not blocked by firewall.

    By default these ports are:

    4000 in case of NX protocol

    22 in case of SSH protocol and NoMachine server installed on Linux or Mac

    4022 in case of SSH protocol and NoMachine server installed on Windows

    in reply to: Login issues to NoMachine 5.2.21 #15067
    reza
    Moderator

    Looks like you have installed 32 bit NoMachine package on 64 bit system.

    Please remove 32 bit version and install correct, 64 bit package or install 32 bit compatibility library.

     

    in reply to: Login issues to NoMachine 5.2.21 #15041
    reza
    Moderator

    We found that key you are trying to do contains obsolete options, no longer used in NX 4 and 5.

    Please don’t add ‚no-port-forwarding,no-agent-forwarding,command=”/usr/NX/bin/nxnode”’ to key you are trying to use for SSH System authorisation.

    Additionally SSHD fails to decode your key.

    Please generate new one, add it to your .ssh/authorized_keys2 and use in player as explained in following article:

    https://www.nomachine.com/AR12I00615

    in reply to: Login issues to NoMachine 5.2.21 #15036
    reza
    Moderator

    In System login case it looks like the key you are trying to use is not added into .ssh/authorized_keys2 file in your home directory on server.

    NoMachine login case is more complicated and we need nxserver.log and nxerror.log files from your server to analyse the problem.

    in reply to: Login issues to NoMachine 5.2.21 #15010
    reza
    Moderator

    Logs you collected are not enough detailed to provide any hint. Please increase SSHD LogLevel from INFO to DEBUG3 and restart daemon. If you are worry about your privacy please remove all sensible info from collected logs.

    Additionally please explain step by step how you try to login and when it works and when not. All of it will help us to understand problem.

    in reply to: Login issues to NoMachine 5.2.21 #15001
    reza
    Moderator

    Please enable debug in your SSH daemon on server and show us logs from failed attempt.

    reza
    Moderator

    We have verified it and setting rtlocalhost to local interface as we perviously suggested doesn’t have any effect.

    You can set it to IP of your real interface.

    Binding to interface specified in option works only if server cannot establish UDP connection to client first .

    in reply to: Remote over Internet #14921
    reza
    Moderator

    Instructions how to connect to NoMachine when the server is behind a NAT router or a firewall you can find there: https://www.nomachine.com/AR11L00827.

    reza
    Moderator

    Please set ProxyExtraOptions „rtlocalhost=127.0.0.1” in node.cfg.

    reza
    Moderator

    Right now it’s not possible to restrict listening in nxnode.bin to particular interface. However it’s possible to disable TCP and use UNIX sockets which are local by definition. It can be done by setting DisplayServerExtraOptions “-nolisten tcp” in node.cfg. We will consider providing a config file key for better control and selecting particular interfaces.

    in reply to: Specify which display to connect to #13879
    reza
    Moderator

    Please take a look at ‚PhysicalDisplays’ key in node.cfg file.

    reza
    Moderator

    Please follow article about setting up key based authentication.

    https://www.nomachine.com/AR02L00785

     

    in reply to: Mass duplicate system images – RSA key issue #11588
    reza
    Moderator

    You Linux machines have to be prepared in advance to have a correct key with correct IP of Windows server.

    Depending on protocol you use you have to store server key in following files:

    ~/.ssh/authorized_keys for SSH protocol

    ~/.nx/config/client.crt for NX protocol

    More about keys used in NoMachine can be found here:

    https://www.nomachine.com/AR04K00665

    https://www.nomachine.com/DT04L00069

    https://www.nomachine.com/AR10K00729

    in reply to: Attach to custom session on localhost? #11338
    reza
    Moderator

    Yes, you should use Player installed on your server to connect to custom session on localhost. Player is a part of Server installation so you should have it already installed.

    in reply to: Allow only from specified network #11257
    reza
    Moderator

    It’s currently not possible to automatically enable/disable broadcast or permit/deny incoming connections when you move to different location.

    This can be archived with help of system scripts where you can detect changes in network interfaces and reconfigure NoMachine configuration files.

    To filter incoming connections you can use a system firewall or prepare a custom script that NoMachine will executed before login – ‘UserScriptBeforeLogin’. Please take a look at article about custom scripts:

    https://www.nomachine.com/FR01M02857

Viewing 15 posts - 16 through 30 (of 142 total)