shelter

Forum Replies Created

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • in reply to: Nxserver -> SDDM -> KDE slow #33830
    shelter
    Participant

    I don’t think Gentoo uses /usr/bin/startplasmacompositor – there’s no such file anywhere.

    in reply to: Nxserver -> SDDM -> KDE slow #33822
    shelter
    Participant

    Btw, I also figured out a workaround for KDE and the slowness that occurs.

    If you have the lid closed on the laptop, then it fails to find any screens which makes the session very slow and the laptop screen is black even if you open the lid.

    To fix it, make a script containing this and put it in KDE Autostart as a login script:
    #!/bin/sh
    (sleep 5s && xrandr –output eDP1 –auto) &

    The above script activates the display after 5 seconds and the problem  is solved!

    PS.
    If you need to find out your display (in this case it’s, eDP1), just run xrandr in an X console.

     

    in reply to: Nxserver -> SDDM -> KDE slow #33820
    shelter
    Participant

    @britgirl Any idea what this command does with the display manager script? Because I get an error:

    # /etc/NX/nxserver --egl-capture yes
    NX> 900 EnableEGLCapture key set to: 1.
    NX> 900 Cannot find any display manager script.

     

    in reply to: Nxserver -> SDDM -> KDE slow #33325
    shelter
    Participant

    Regarding the audio issue I figured out a much better solution.

    1. Set “autospawn = no” in /etc/pulse/client.conf.
    2. Put /usr/bin/pulseaudio in KDE’s autostart.

    This is because Gentoo doesn’t start PulseAudio at all if autospawn is set to no (at least not for me).
    Now I have the NX audio controls under the volume control.

    The video issue still puzzles me tho’.

    in reply to: Nxserver -> SDDM -> KDE slow #33321
    shelter
    Participant

    @graywolf Yeah, I’ll try and have a look.


    @Britgirl
    Could be an OpenRC/elogind/dbus issue I don’t know, I have Arch Linux too that runs systemd and there everything works fine.  I did have problems with “Monitor cannot be started for session type loginwindow” but that went away, don’t know if it was because I switched to EGL in the nxserver config because at first it didn’t help.
    Do you run systemd in Gentoo?

    Thanks for a good product nonetheless, I was using NoMachine some years ago and despite my issues now I feel that it evolved very much.

    in reply to: Nxserver -> SDDM -> KDE slow #33295
    shelter
    Participant

    “Solution” to the audio problem (I’m running OpenRC, so no systemd:

    1. Set “autospawn = no” in /etc/pulse/client.conf.
    2. Manually starting pulseaudio with “pulseaudo –start” in the NX Xorg session (because it doesn’t autostart for me with the above setting).
    3. Restart the nxserver instance through the NX service GUI.

    The keyword was to set autospawn to no but still a very dirty workaround.
    I spent hours to find these workarounds. 🙁 But hope it helps someone in the future.

    But the biggest question is still, Is there any fix/workaround for the black screen/slowness other than having the laptop lid open at startup/reboot?

    in reply to: Very slow with Xubuntu 20.04 #33279
    shelter
    Participant

    The missing libs are because NoMachine runs in it own “chroot” or something. Nothing to worry about.

    The libs are under /usr/NX/lib/

    in reply to: Nxserver -> SDDM -> KDE slow #33275
    shelter
    Participant

    If I connect headless without sddm running, NX audio forwarding works.

    But if I connect through a running Xorg/sddm instance I get no forwarding.

    Only error I see is:

    pulseaudio[6058]: [pulseaudio] main.c: Unable to contact D-Bus: org.freedesktop.DBus.Error.NotSupported: Unable to autolaunch a dbus-daemon without a $DISPLAY for X11

    in reply to: Nxserver -> SDDM -> KDE slow #33260
    shelter
    Participant

    I think I  figured the slowness/black screen issue out, it happens if the laptop lid is closed when connecting to the running xorg/sddm instance. If the lid is open and the screen is active, it works as intended.
    Is there any fix/workaround for this other than having the lid open at startup/reboot?

    Now I only need sound working…

    in reply to: Nxserver -> SDDM -> KDE slow #33250
    shelter
    Participant

    I couldn’t find much in the logs but I checked chrome://gpu when running google chrome and it reports intel as video driver, everything seems normal there.
    I also noticed that NX creates a directory under /var/lib/sddm/.nx that contains logs etc… so I’m a bit confused, NX seems to create logs all over the place.

    It’s a laptop I’m trying to connect to.
    I guess I can live with physically logging in first and starting nxserver manually but it would be nice if it worked without doing so.

    Totally different issue but I can’t for the life of me get pulseaudio forwarding to work. I don’t have any NX audio sliders under the volume control. (I had it working once, but then after a reboot, they went missing for good)
    There are no NX sinks to be found. I even made pulseaudio system-wide but it didn’t change anything. 🙁
    NX is configured for pulseaudio…

Viewing 10 posts - 1 through 10 (of 10 total)