shiba

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • Avatarshiba
    Participant

    Hi landcecluster,
    you can mute the sound during connection by disabling audio in the Audio tab. You can also disable audio streaming completely by turning off streaming in ‘Audio settings’.

    If you don’t want the server-side sound to be muted,leave the option unchecked “Mute audio on the server”.

    You can also completely disable server-side sound notifications in Settings-> Security preferences-> Use sound notifications when there is an event.
    Please let us know if you still have a problem with muting the sound.

    in reply to: Gnome Classic shell #23973
    Avatarshiba
    Participant

    I’m not sure I understand your problem correctly. Couldn`t you log in to the gnome classic in the login window?

    Are you using a free or license version which offers the creation of virtual desktops, e.g. Terminal Server?

    If you don’t want to run the default desktop environment on the virtual session (in your case – GNOME 3), administrators can change the command for start a new desktop.
    For GNOME classic, they have to set in node.cfg:

    DefaultDesktopCommand “env GNOME_SHELL_SESSION_MODE=classic gnome-session –session gnome-classic”

    All information can be found in this article https://www.nomachine.com/AR04K00667

    If you don’t have administrator privileges you can run GNOME classic desktop using custom session instead of virtual desktop.
    In the custom session selection window, enter following command:

    env GNOME_SHELL_SESSION_MODE=classic gnome-session –session gnome-classic

     

    Attachments:
    in reply to: Mint Linux install #23972
    Avatarshiba
    Participant

    We couldn`t reproduce such a problem on Linux Mint. Please, could you provide following information:

    -what version of Linux Mint do you have?
    -which desktop environment are you using, Cinnamon?
    -which package manager are you using, GDebi?

    Could you also install again NoMachine (if you don’t have installed) and check list all the NoMachine processes? Please open terminal and execute ps -ef | grep nx command and paste here an output.

    Avatarshiba
    Participant

    To run all nxserver commands, you need to run the Command Prompt as an administrator. Type “cmd” in search box to find the Command Prompt, then right click on it and select “Run as administrator”. When you launch the Command Prompt with admin privileges, you’ll  see a “User Account Control” window asking for permission to continue, choose “Yes”. Once you’ve got the “Administrator: Command Prompt” window open, you can run any nxserver command, whether it requires administrative privileges or not.

    Please let us know if your problem still exists.

    in reply to: Cinnamon crashes after going out of fullscreen mode #22870
    Avatarshiba
    Participant

    Hello Darkg82,

    We tried to reproduce your problem on Linux Mint 19.1. with Cinnamon 4.0.10, but weren’t able to. Have you noticed that these crashes occur when using a specific application, e.g. while playing a video? Is your Linux Mint 19.1 a headless system?

    Could you enable debug, reproduce problem, collect logs and send them to forum[at]nomachine[dot]com? Instructions about debug and collecting logs you can find there:
    https://www.nomachine.com/DT10O00163
    Are there any .xsession-errors in the your home directory? If such a file was created, please send it together with the logs.

    in reply to: NX key authentication – cannot make it work #21616
    Avatarshiba
    Participant

    Hello maximn,

    Did you generate a new pair of keys? I ask because we have a Trouble Report for which the temporary workaround is to generate new keys

    ssh-keygen -p -m PEM -f

    Here is the TR: https://www.nomachine.com/TR02Q09140

    Btw, we noticed that you are trying to connect as user account named “nx”. We don’t recommend it, because the nx account is needed to setup the initial stage of the client-server connection. Please use local account profiles.

     

    in reply to: NoMachine on Android 9.0 #20967
    Avatarshiba
    Participant

    Hi Lorenzo722,

    We are unable to reproduce this issue in our test labs.

    Could you uninstall the NoMachine application and reinstall it? If that does not help, please let us know.

    in reply to: NXClientAuthentication fails #20489
    Avatarshiba
    Participant

    We are glad that your problem has been solved! 🙂

    in reply to: NXClientAuthentication fails #20469
    Avatarshiba
    Participant

    Thank you for the files you sent us. It seems that your private key and certificate are missing on client side. Could you place nx_client_rsa_key and nx_client_rsa_key.crt to C:\Users\Fred\.nx\config and try to connect again?

    in reply to: NXClientAuthentication fails #20456
    Avatarshiba
    Participant

    Thank you for files that you sent to us, we are investigating them. We would also like to take a look at the client side files. Could you reproduce failed connection again, pack the whole .nx folder from your Windows and send it to us?

    Folder .nx is placed, for example, in C:/Users/username/.nx

    Please send us also ‘server.crt’ file which is located on the server side in /var/NX/nx/.nx/config

    in reply to: NXClientAuthentication fails #20411
    Avatarshiba
    Participant

    We weren’t able to reproduce problem, but we would like to investigate the issue further. What version of NoMachine do you have on the client and server side? We strongly recommend using the latest packages.

    Could you send us the logs from server and client side? The certificate ‘server.crt’ from your Mac may also be helpful. Please send them to forum[at]nomachine[dot]com.

    Instructions about collecting logs you can find here: https://www.nomachine.com/DT10O0016

    in reply to: NXClientAuthentication fails #20403
    Avatarshiba
    Participant

    Hello,
    The error messages you see in the Player appear when the client’s certificate is not accepted on the server. Could you try to look for similar entries on server side logs? There may be such errors in nxerror.log:

    65245 6659 16:40:04 116.519 Encryptor/Encryptable: ERROR! Certificate not found in ‘/Library/Application Support/NoMachine/var/nx/.nx/config/server.crt’..
    65245 6659 16:40:04 116.589 Encryptor/Encryptable: ERROR! Failed to authorize the client certificate.

    If you have such entries, please make sure if everything is correctly set on the client and server side. If adding your client’s certificate, you have considered its IP address, maybe it’s worth checking if it is up-to-date.

    in reply to: NXClientAuthentication fails #20366
    Avatarshiba
    Participant

    Hi,

    Did you go through the instructions on how to configure NoMachine to use SSL client authentication? https://www.nomachine.com/AR10M00866

    I went through them myself on a mix of platforms just to make sure everything is working properly.

    The key EnableNXClientAuthentication enabling support SSL client authentication and it is disabled by default. Setting the value of this key to 1 causes that only clients with the added certificate on the server are able to connect (which is explained there: https://www.nomachine.com/FR09M02964).

    in reply to: Poorly rendered windows #20207
    Avatarshiba
    Participant

    Hi!

    We are unable to reproduce this issue in our test labs. Could you tell us in which application you observed such problems? It would be great if you could also send a screenshot showing the issue.

    in reply to: Disable login for 3 users #20049
    Avatarshiba
    Participant

    Hi IlNeofita,

    You can disable access to specific user, using rules, e.g.

    sudo /usr/NX/bin/nxserver –ruleadd –class node –type localhost:4000 –value no –user <username>

    Server management using rules is available on enterprise versions. If you have a free version, you can limit access for selected users using NoMachine database. To enable it, edit server configuration file /usr/NX/etc/server.cfg. Uncomment and change values of two keys:

    EnableUserDB 1
    EnablePassDB 1

    Then you can add users who will be able to connect using command:

    sudo /usr/NX/bin/nxserver –useradd <username>

    Please refer “Users Management” for details:
    https://www.nomachine.com/DT02O00125#9.6

Viewing 15 posts - 1 through 15 (of 18 total)