Shoti

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 28 total)
  • Author
    Posts
  • in reply to: Webplayer ooops! error #29273
    AvatarShoti
    Contributor

    Hi termmachine,

    For version 7 (coming soon) we made some improvements, the web player should behave better when there is poor network connectivity.

    in reply to: Small Business Server performance in browser connection #25329
    AvatarShoti
    Contributor

    Hi Rick,

    To narrow things down, can you please connect to the physical display with the browser and share results with us? And also, how much connection is established when you expecting the freezes and slowness? maybe there’s several from one browser? or it’s just one?

    in reply to: Auth value in NXS file #23032
    AvatarShoti
    Contributor

    Hi mattdall,

    First of all, let me note one thing: for security reasons, sensitive data is never transmitted from the server-side to the client-side. This means that even if the password is set in the connection file stored on the Web Player host, it will never be used for automatic log-in. To use a pre-configured password is therefore necessary to provide the connection file to the user and save it on his/her computer. It’s the default behavior of NXS for a web session.

    “Where do you enable this option which configuration file”

    That simply means that nxplayer will not save credentials in an NXS file without clicking the “Save this password in the connection file” link in the authentication panel.

    So we can say that this configuration file is NXS file itself. But this is not relevant here, as we are talking about web sessions.

    For web sessions, as written above, sensitive data is never transmitted from the server-side to the client-side. It cannot be modified for security reasons, while properly configured NXS file stored on a client-side will trigger automatic log-in procedure for web sessions – it’s a default behavior as well.

    Note: Please, also check the “EnableClientCredentialsStoring” from the server configuration file, it seems this key will be useful for you.

    AvatarShoti
    Contributor

    Hi Stich,

    Please, see the article : “How to solve ‘The security certificate presented by this website was not issued by a trusted certificate authority'”

    https://www.nomachine.com/AR05P00980

    in reply to: Floating windows in webplayer #22860
    AvatarShoti
    Contributor

    Hi, it guy92075,

    It’s not a bug, just web player doesn’t support the “Virtual desktop” NXS key at all. So as I see your proposition is to open “Custom session” types in a “detached window” like player’s ‘floating window’. It’s a new possible FR and we need to evaluate this. Thanks for sharing ideas.

    in reply to: WebRTC on Version 6.6.8 #22485
    AvatarShoti
    Contributor

    Hi itguy92075,

    Thanks for testing the new version and sharing results here, we appreciate this. So, from what I see, in 6.7.6 all looks OK to you and you get the same results as was in 6.5.6?

    in reply to: Problems with IE11 #22349
    AvatarShoti
    Contributor

    termmachine,

    We were not able to reproduce point 2 and 3 in our labs, we would need the logs from the client-side. Please find the instructions here how to gather web session logs: https://www.nomachine.com/DT10O00163#2.6 You can send them to forum[at]nomachine[dot]com.

    in reply to: WebRTC on Version 6.6.8 #22324
    AvatarShoti
    Contributor

    itguy92075, Within the release of 6.6.8, we fixed an issue related to this : “Cannot connect via web from an external network when WebRTC is enabled” (https://www.nomachine.com/TR05P08581). You are seeing a difference because of the fix.

    The thing here is that in earlier versions of webplayer (e.g 6.5.6) the STUN/TURN servers were ignored by the browser even if they were correctly presented in the configuration file. In the config file you had the “Host 127.0.0.1” (which is wrong) but in reality the browser was ignoring it anyway. Then, in the new version you used the same config (“Host 127.0.0.1”) and encountered what you thought was a bug.

    It happened because it’s not ignored anymore and the config was wrong. It looks like in your particular situation you don’t need any additional STUN/TURN to establish WebRTC connection, removing/commenting any kind of STUN/TURN section in server.cfg file should fix your issues with 6.6.8. Please, try this and share your results.

    in reply to: WebRTC on Version 6.6.8 #22281
    AvatarShoti
    Contributor

    itguy92075, we are pleased that the issue has been solved.

    in reply to: Problems with IE11 #22186
    AvatarShoti
    Contributor

    Hi termmachine,

    First of all, let me explain one thing, the panel where you can choose a keyboard layout is visible only in the case of old browsers, without ‘KeyboardEvent.code’ support. The ‘KeyboardEvent.code’ property represents a physical key on the keyboard (as opposed to the character generated by pressing the key). So when a browser doesn’t support this API for a fully-functional keyboard, we’re asking customers to select the same layout already set on their operating system. When it’s possible, we always strongly suggesting customers use a modern browser for the best experience in the web player.

    Point 1 : This problem is known to us and we’re working to fix it, please see more here : https://www.nomachine.com/TR02Q09132

    You have the option to be notified when this issue is fixed, you just have to click on “Notify me when the TR is closed.” and insert your email address.

    Point 2: The web player isn’t deciding the keyboard layout, we just saving user’s choice in browsers cookie and for second connection web player uses the saved value, so for a very first connection (when the cookie is clean) by default chosen layout is the ‘US’ always. Maybe you mean something else?

    Point 3: How are you switching tabs? Using a ‘Ctrl + Tab’ combination? This can be out of scope and not possible to fix, as it’s implemented at the browser level, but we’ll check what can we do here, as a workaround you can go to fullscreen using the F11 key and problem should be eliminated after that.

    Point 4: We disable the “detach window”  when the browser runs in a fullscreen mode, can you please check that this is not the problem? We weren’t able to reproduce any issue with ‘EnableWebPreconfiguration’ key

    in reply to: WebRTC on Version 6.6.8 #22108
    AvatarShoti
    Contributor

    itguy92075, we found some problems in the Firefox version you have in use (66.0) we are working on it, in meantime can you try Chrome browser and check if the behavior is the same?

    Regarding CFG files you sent to us, the only uncommented server was: “Host      127.0.0.1”, this will not work for connections behind the NAT, please use the real STUN/TURN’s (the ones you commented in CFG file should be OK), also note, that you can use several servers, web player will try all servers until it finds the working one.

    in reply to: WebRTC on Version 6.6.8 #22009
    AvatarShoti
    Contributor

    itguy92075,

    Can you check that there are no special chars in a STUN/TURN section? If there aren’t, we would need the logs from the client. Please find the instructions here how to gather web session logs: https://www.nomachine.com/DT10O00163#2.6 You can send them to forum[at]nomachine[dot]com.

    in reply to: WebRTC on Version 6.6.8 #21998
    AvatarShoti
    Contributor

    Hi itguy92075,

    First of all, can you confirm/re-check that you properly configured STUN/TURN servers in server configuration (server.cfg) file? These two articles may be useful :

    How to configure NoMachine servers to use WebRTC – https://www.nomachine.com/AR07N00892

    How to setup your own STUN/TURN server for NAT traversal: https://www.nomachine.com/AR07N00894

     

    in reply to: Limiting options with ClientMenuConfiguration #21901
    AvatarShoti
    Contributor

    Hi itguy92075,

    we can’t reproduce any problem with the “ClientMenuConfiguration” key in our labs. To investigate this issue further, we would need the logs from the client, as you mentioned “clipboard” and “keyboard” we are assuming that you are using the web session.

    Please find the instructions here how to gather web session logs: https://www.nomachine.com/DT10O00163#2.6 You can send them to forum[at]nomachine[dot]com.

    in reply to: Cannot successfully open session #19931
    AvatarShoti
    Contributor

    Hi StMartin81,

    We can’t reproduce problem in our labs. To investigate this issue further, we would need the logs from server side. Please find the instructions here: https://www.nomachine.com/DT10O00163. You can send them to forum[at]nomachine[dot]com

Viewing 15 posts - 1 through 15 (of 28 total)