termmachine

Forum Replies Created

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • Avatartermmachine
    Participant

    Hello,
    thank you for your input, seems that /etc/systemd/system.conf is the solution. (Sorry I totally missed that part in your guide)

    I edited the following parameter in system.conf:
    DefaultTasksMax=infinity
    DefaultLimitSTACK=infinity
    DefaultLimitNOFILE=1048576
    DefaultLimitNPROC=infinity
    DefaultLimitMEMLOCK=infinity
    DefaultLimitSIGPENDING=infinity
    DefaultLimitMSGQUEUE=infinity

    Before editing limits for NX user was:
    DefaultTasksMax=512
    DefaultLimitSTACK=8388608
    DefaultLimitNOFILE=4096
    DefaultLimitNPROC=71327
    DefaultLimitMEMLOCK=65536
    DefaultLimitSIGPENDING=71327
    DefaultLimitMSGQUEUE=819200

    Now:
    ATORNX002:~ # ps -ef | grep nxserver
    nx        1721     1  3 12:15 ?        00:00:01 /usr/NX/bin/nxserver.bin –daemon
    root      2384  2331  0 12:15 pts/0    00:00:00 grep –color=auto nxserver
    ATORNX002:~ # cat /proc/1721/limits
    Limit                     Soft Limit           Hard Limit           Units
    Max cpu time              unlimited            unlimited            seconds
    Max file size             unlimited            unlimited            bytes
    Max data size             unlimited            unlimited            bytes
    Max stack size            unlimited            unlimited            bytes
    Max core file size        unlimited            unlimited            bytes
    Max resident set          unlimited            unlimited            bytes
    Max processes             unlimited            unlimited            processes
    Max open files            1048576              1048576              files
    Max locked memory         unlimited            unlimited            bytes
    Max address space         unlimited            unlimited            bytes
    Max file locks            unlimited            unlimited            locks
    Max pending signals       unlimited            unlimited            signals
    Max msgqueue size         unlimited            unlimited            bytes
    Max nice priority         0                    0
    Max realtime priority     0                    0
    Max realtime timeout      unlimited            unlimited            us

    All the infinity limits should be no problem, because no of my employees can do anything on my machine, except of using the webplayer with preconfigured session-files.

    Or do you see any reason not to do that?

    Looks good, now I have to wait and see, if all my resource problems are solved.
    Maybe you can leave that topic open for some time 🙂

    Thanks,
    Termmachine

    Avatartermmachine
    Participant

    Thank you for your input.
    Generally I don’t believe, that the machine is overloaded, because on ESXi interface CPU usage is never above 4% utilization and the virtual machine has 18GB RAM assigned and the maximum usage was 10GB (when all 30-40 user are logged in and use the custom RDP and VNC sessions).

    May I ask you if you can answer these 3 questions for me.

    1) I think I have to look, why /etc/security/limits.conf don’t work properly for the NX user, but works great with all other users.
    Have you ever seen this before? Do you know, if I have to configure the limits for NX user on another place?

    2) Can there be some limits in htd.cfg (because all my employees use the webplayer)?
    For example in this parameters:
    #
    # All these directives control the management of NXHTD’s
    # subprocesses for handling individual HTTP requests.
    #
    StartServers         1
    ThreadLimit        255
    ThreadsPerChild    240
    ServerLimit         16
    MaxRequestWorkers 1920
    MinSpareThreads     25
    MaxSpareThreads     75

    3) How can I reset the server.cfg and node.cfg to defaults?
    Because of the bug in “EnableCredentialsStoring” I want to start again from zero, and reconfig my needs.

    Thank you!

    Avatartermmachine
    Participant

    Hi, I got an answer from one of our webplayer users. During this ressource-error-state users saw the message “Node was not retrieved” (see screenshot).
    Moreover they saw another message like: “Service gesperrt” (German), I think in English it should be like “Service locked” (unfortunately no screenshot available).

    Avatartermmachine
    Participant

    Hello,
    the only difference in the past was, that my system was used only by 2-3 users and I allowed now more users to use the systems (up to 20-30 simultaneously). Last week in config files I disabled some unnecessary (for our cases) features like balloon messages, monitor win, pulseaudio and so on to save resources.

    I have already checked your linked article, this was the reason I edited the /etc/security/limits.conf.
    But I don’t understand, why my set limits don’t work for nx user.
    For every other user my set limits works….

    The credentialstoring “none” worked in the past, but I cannot say if it was the ressource problem crash, or some other parameter in my config file, that it doesn’t work anymore.
    I also saw that the authentication page in webplayer is “English” now (with checkbox for saving credentials) and after that it is “German” again, as set in config files.

    Attachments:
    Avatartermmachine
    Participant

    I did another Test, seems I have a problem with getting ma /etc/security/limits.conf working…
    ATORNX002:~ # ps -ef | grep “nxserver.bin –daemon”
    nx        1751     1  1 14:54 ?        00:00:01 /usr/NX/bin/nxserver.bin –daemon
    root      2403  2339  0 14:55 pts/0    00:00:00 grep –color=auto nxserver.bin –daemon
    ATORNX002:~ # cat /proc/1751/limits
    Limit                     Soft Limit           Hard Limit           Units
    Max cpu time              unlimited            unlimited            seconds
    Max file size             unlimited            unlimited            bytes
    Max data size             unlimited            unlimited            bytes
    Max stack size            8388608              unlimited            bytes
    Max core file size        unlimited            unlimited            bytes
    Max resident set          unlimited            unlimited            bytes
    Max processes             71327                71327                processes
    Max open files            4096                 4096                 files
    Max locked memory         65536                65536                bytes
    Max address space         unlimited            unlimited            bytes
    Max file locks            unlimited            unlimited            locks
    Max pending signals       71327                71327                signals
    Max msgqueue size         819200               819200               bytes
    Max nice priority         0                    0
    Max realtime priority     0                    0
    Max realtime timeout      unlimited            unlimited            us

    In my conf file I have set the following:
    nx              soft    nproc           unlimited
    nx              hard    nproc           unlimited
    nx              soft    as              unlimited
    nx              hard    as              unlimited
    nx              soft    nofile          1048576
    nx              hard    nofile          1048576
    nx              soft    sigpending      unlimited
    nx              hard    sigpending      unlimited
    nx              soft    stack           unlimited
    nx              hard    stack           unlimited
    nx              soft    msgqueue        unlimited
    nx              hard    msgqueue        unlimited

    I also did a reboot, but settings dont work.

    in reply to: Webplayer ooops! error #28204
    Avatartermmachine
    Participant

    Thanks for checking!

    Is there any chance to make the startup (initialization) of the webplayer less latency sensitive, so that the webplayer can handle bad network conditions? The windows client is also able to start properly with this bad conditions.

    Maybe in a future update?

    Thanks!

    in reply to: Problems with IE11 #22191
    Avatartermmachine
    Participant

    Hi, thanks for your answer!

    Point 1: Thanks, I registered my mail for notify.

    Point 2: Ah ok thanks for clarification. I tried the following:
    In IE11 I cleared all browser data (cookies cache everything), restarted the browser, and you are right. On first solaris 10 xdm session initiation, the keyboard was US on the solaris login screen. I switched it to german, works well after that. Then I reopenend the IE11, initiated the same xdm solaris 10 session again, and on login screen the keyboard showed German in NoMachine webplayer, but nevertheless it has the US mapping. I have to switch from German to another language and switch back to German. Only after this I have the German keyboard mapping.

    Point 3: Ctrl+Tab works fine. I mean if you have more Tabs in Internet Explorer opened and you switch between the IE-Tabs with Windows Taskbar previews (Mouseover IE icon in taskbar and switch between opened IE tabs). This setting in windows is called “show previews for individual tabs in the taskbar” in tabbed browsing settings (only then you see the opened IE tabs in taskbar). Here the fullscreen closes and cannot be opened again, unless you press Esc in IE. But I also think this is not fixable (due to browser level).

    Point 4: Yes, when in fullscreen the “detach window” is disabled. Its ok. But when not in fullscreen and press the “detach window” button, the new window opens but shows the error message, that NoMachine is configured to only accept connections via .nxs-file.
    This is the same error message as if I set “EnableWebPreconfiguration” to 1 and go to http://IPofServer:4080/nxwebplayer

    Thanks,
    Yours termi

    in reply to: Cannot create virtual xdm session to Solaris 10 #22169
    Avatartermmachine
    Participant

    Hello, thanks for your answer.

    I solved the font problem with automounting (via NFS) the specific fonts directly on my Terminal Server.

     

    in reply to: Cannot create virtual xdm session to Solaris 10 #21267
    Avatartermmachine
    Participant

    Hello,

    thanks for that workaround. With this change XDM on Solaris is possible and I can login.

    Is the workaround the final solution, or will this be fixed in an future update of Terminal-Server?

    Moreover I found another bug, one of my programs on Solaris needs a Font-Server and if I set our Font-Server in node.cfg (#AgentFontServer) this isn’t working.

    When opening the program on Solaris, the NoMachine Client crashes with I/O Error (5)

    Thanks!

    in reply to: Cannot create virtual xdm session to Solaris 10 #21166
    Avatartermmachine
    Participant

    Hi,

    I am able to get a list of available X desktops and can choose one. But when I want to connect to one, I get a black screen and after a defined time I get kicked out from webplayer. This happens with all of the available desktop managers from the list.

    This is the nxclient logfile from one try:

    28078 28078 08:40:01 777.753 Main: Enter main function.
    28078 28078 08:40:01 777.885 Main: Initialize file ownership.
    28078 28078 08:40:01 778.104 Main: Completed file ownership initialization.
    28078 28078 08:40:01 778.138 Main: Update parameters.
    28078 28078 08:40:01 778.151 Main: Completed parameters update.
    28078 28078 08:40:01 778.190 Main: Creating the application in GUI mode.
    28078 28078 08:40:01 778.203 Main: Set client environment.
    28078 28078 08:40:01 778.229 Utility: Going to set process environment.
    28078 28078 08:40:01 778.239 Utility: Environment personal NX directory is [/home/DOMAIN/pozard/.nx].
    28078 28078 08:40:01 778.246 Utility: Environment system NX directory is [/usr/NX].
    28078 28078 08:40:01 778.251 Utility: Not using parameters.
    28078 28078 08:40:01 778.258 Utility: Checking the file [/home/DOMAIN/pozard/.nx/config/player.cfg].
    28078 28078 08:40:01 778.290 Utility: Using [/home/DOMAIN/pozard/.nx/config/player.cfg] as config file.
    28078 28078 08:40:01 778.297 Utility: Using System NX directory.
    28078 28078 08:40:01 778.308 Utility: Reading Personal NX directory.
    28078 28078 08:40:01 778.314 Utility: Using Personal NX directory.
    28078 28078 08:40:01 778.339 Utility: Loading the global settings.
    28078 28078 08:40:01 779.287 Main: Starting slave server.
    28078 28078 08:40:01 779.306 MonitorService: Start slave server.
    28078 28078 08:40:01 779.419 MonitorService: Create the slave server.
    28078 28078 08:40:01 779.431 MonitorService: Creating the slave server instance 11315584.
    28078 28078 08:40:01 779.689 MonitorService: Starting the slave server instance 11315584.
    Info: Slave server running with pid 28085.
    28078 28078 08:40:01 779.709 Main: Initialize qt application.
    Info: Listening to slave connections on port 25002.
    08:40:01 780 QApplication: Initialize qapplication.
    08:40:01 780 QApplication: Create QX11 data.
    08:40:01 780 QApplication: Initialize QX11 font config.
    08:40:01 786 QApplication: Completed QX11 font config initialization.
    08:40:01 786 QApplication: Initialize XRender.
    08:40:01 786 QApplication: Completed XRender initialization.
    08:40:01 786 QApplication: Initialize application class.
    08:40:01 786 QApplication: Completed application class initialization.
    08:40:01 786 QApplication: Install default error handlers.
    08:40:01 786 QApplication: Completed default error handlers installation.
    08:40:01 786 QApplication: Check command line parameters.
    08:40:01 786 QApplication: Completed command line parameters check.
    08:40:01 786 QApplication: Connect to X server.

    Is there a chance to get this fixed in a new nx version update? The remote connection via webplayer was the main reason to buy this product, but if this does not work, the product has been purchased without benefit for our company.

    Thanks!

    in reply to: Cannot create virtual xdm session to Solaris 10 #21151
    Avatartermmachine
    Participant

    Hi,

    thanks for your reply, I sent the new logs via E-Mail after enabling of debugging.

    Thanks!

    in reply to: Cannot create virtual xdm session to Solaris 10 #21105
    Avatartermmachine
    Participant

    Hi,

    thanks for your reply and I sent the additional log files to forum(@)nomachine.com again.

    To your questions:

    1. It seems that there is Kerberos configured on this system, could you check if there are any errors for the user ‘pozard’?

    I use Kerberos in combination with samba and winbind, because my users should be able to use the credentials from our companies active directory (windows domain). The authentification works, but I will check the logs.

    In the logs we have an error regarding that ticket, but the user directory access seems to be working so it may or may not be related.

    User directory access works, I have tested that.

    2. When you say the XDM to Ubuntu server works, did you also use user ‘pozard’? If no, please check what happens.

    Yes, I also used the pozard user. And tried different users as well. same problem.

    3. When you try the failed session, are there any other NoMachine sessions for user ‘pozard’ running?

    I tried it with no sessions besides the solaris xdm session and i tried it with other sessions (to other systems) openend besides. the xdm to solaris always fail with cant connect to NoMachine monitor.

     

    Thanks!

    in reply to: Cannot create virtual xdm session to Solaris 10 #21093
    Avatartermmachine
    Participant

    I sent the attachments to forum(@)nomachine.com

    Cant attach them here.

    Thanks

Viewing 13 posts - 1 through 13 (of 13 total)