thetravellor

Forum Replies Created

Viewing 1 post (of 1 total)
  • Author
    Posts
  • Avatarthetravellor
    Participant

    Hi, I was searching for a solution to this too.

    If the machine is truly headless, you do not actually need the display manager running, as NoMachine will handle it.

    Also the OP mentioned Ubuntu 16, which uses systemd to control services.

    So.

    Stop desktop manager

    sudo systemctl stop lightdm

    Restart nxserver

    sudo systemctl restart nxserver.service

    Is it running?

    :~$ sudo systemctl status nxserver
    ● nxserver.service – NoMachine Server daemon
    Loaded: loaded (/lib/systemd/system/nxserver.service; enabled; vendor preset: enabled)
    Active: active (exited) since Thu 2016-05-19 20:15:04 AEST; 1h 46min ago
    Main PID: 17685 (code=exited, status=0/SUCCESS)
    CGroup: /system.slice/nxserver.service
    ├─17695 /usr/NX/bin/nxserver.bin root 17685 –daemon
    ├─17710 /usr/NX/bin/nxd
    ├─18092 /usr/NX/bin/nxserver.bin -c /etc/NX/nxserver –login -H 5
    └─18116 /usr/NX/bin/nxserver.bin –virtualsession –sessionid A487F762AF159AC0B69660489C44F41B

    May 19 20:15:03 server systemd[1]: Starting NoMachine Server daemon…
    May 19 20:15:03 server nxserver[17685]: NX> 161 Enabled service: nxserver.
    May 19 20:15:04 server nxserver[17685]: NX> 162 Disabled service: nxnode.
    May 19 20:15:04 server nxserver[17685]: NX> 161 Enabled service: nxd.
    May 19 20:15:04 server systemd[1]: Started NoMachine Server daemon.
    May 19 20:15:49 server nxexec[18128]: pam_unix(nx:session): session opened for user user by (uid=125)
    May 19 20:15:57 server nxexec[18775]: pam_unix(nx:session): session opened for user user by (uid=125)

    Or this if you used the CLI

    sudo /usr/NX/bin/nxserver –restart

    NX> 162 Disabled service: nxserver.
    NX> 162 Disabled service: nxnode.
    NX> 162 Disabled service: nxd.
    NX> 161 Enabled service: nxserver.
    NX> 162 WARNING: Cannot find X servers running on this machine.
    NX> 162 WARNING: A new virtual display will be created on demand.
    NX> 161 Enabled service: nxd.

    If the machine is headless, do not need lightdm service to start at all (obviously dont do this on a machine with a real monitor)

    sudo systemctl disable lightdm

    So is lightdm running? Yes it is because NoMachine started it,

    user@server:~$ ps -ef | grep lightdm
    user  15079  5887  0 22:09 pts/19   00:00:00 grep –color=auto lightdm

    You can now resize you NoMachine window

    Image available at http://imgur.com/a/WsPCu (NoMachine Graphics Settings)

Viewing 1 post (of 1 total)