thoamp

Forum Replies Created

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • Avatarthoamp
    Participant

    Yes, with this option the display is perfect. However typing is a bit more laggy, probably due to the larger encoding and bandwidth overhead.

    Avatarthoamp
    Participant

    That’s good to know, thanks for looking into it.

    Furthermore I tried the option with and without quotes as "16m-png" and 16m-png, and the session log always says Info: Using pack method dynamic with session xsession-default. and the visual artifacts are still present.

    It seems ProxyExtraOptions itself can’t be interpreted:


    $ /etc/NX/nxserver --version
    NoMachine Workstation Evaluation - Version 6.4.6
    $ grep ProxyExtraOptions /usr/NX/var/log/nxserver.log
    /var/log/nxserver.log:2019-03-04 12:30:16 312.540 31265 NXNODE ERROR! Wrong syntax in configuration parameter ProxyExtraOptions at: 16m-png

    No stray non-ASCII chars in the config file, either:

    $ cat -A /usr/NX/etc/node.cfg | grep ProxyExtraOptions
    #ProxyExtraOptions limit=256k,link=modem$
    #ProxyExtraOptions 16m-png$
    ProxyExtraOptions "16m-png"$

    Avatarthoamp
    Participant

    Editing /usr/NX/etc/node.cfg with the various options and restarting it each time via systemctl restart nxserver showed no changes. The only other settings I changed in node.cfg are DisplayServerVideoFrameRate 60 and DisplayServerUseVideoFrameRate 1.

    A better and clearer way to reproduce this is setting the terminal to red-on-black. I took a screenshot of gnome-terminal and konsole from within NX, and while the user view shows gnome-terminal in clear fonts, viewing the screenshot within NX showed these artifacts everywhere. The pixels in the screenshot itself are perfectly clear of course, so sending it via NX seems to degrade it.

    I also reset the client display settings to defaults, there some other settings were required to remove some blurry images in qt-creator, but nothing changed.

     

Viewing 3 posts - 1 through 3 (of 3 total)