Tom

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 34 total)
  • Author
    Posts
  • in reply to: Can’t connect with a DDNS hostname #41537
    Tom
    Participant

    Hi,

    I have a FreeboxMini 4K as a router (it’s a French ISP).

    Unfortunately, I do not know this model and I do not know if it is possible to check in its logs why it does not work

    I tested it, and everytime the IP changes, the DDNS is up to date in approx 20 secs, thus making pinging the DDNS giving me the proper public IP adress. (it changes approx once a month).

    So we can assume that domain redirection from DDNS works fine.

    I tried forwarding port 4000 to the IP of the computer, and it seems to be working

    I don’t understand if the way without UPnP works or not? For simplicity, the incoming and outgoing ports should be the same. Incoming port 4000 on the router forwarded to port 4000 and the IP of the computer with NoMachine installed. Then when connecting from outside your local network you should enter in NoMachine Player the DDNS domain name and port 4000 to connect. Is this working?

    

even if I set up the DDNS connection to aim port 24580 ? Implying any DDNS targeted NX connection aims port 4000 ?

    Manually forwarded port is not needed to connect over the port shown by UPnP.

    Please take logs from NoMachine Client and Server and upload here or send direct to forum[at]nomachine[dot]com, instructions below on how to do this
    https://kb.nomachine.com/DT07S00243

    Regards
    Tom

    in reply to: Can’t connect with a DDNS hostname #41499
    Tom
    Participant

    Hi
    What router do you have?
    Can you connect to the computer via RDP using the name from the DDNS address?
    Are you setting up synology.me on your router?
    Connecting via NoMachine are you using the port generated by UPnP (141)?
    For testing, can you permanently forward port 4000 to the IP of the computer you are connecting to?

    Regards
    Tom

    in reply to: Losing connection on dual-nic (Jetson) #40722
    Tom
    Participant

    Hello,
    I understand that you have two devices, Nano and Xavier.
    Both are connected to the local network via WiFi.
    I don’t know if i
    t is important yet, but you have dual-port Jetson cards plugged in them. You have UPnP set up in NoMachine on both of them and you can connect to them from the outside using the ports provided. You have port 4000 forwarding (to one of these devices) set up on your router. You can connect to this device from outside by connecting to port 4000.

    When you want to connect to a VPN at work, do you connect an ethernet cable?
    Is it a different network than WiFi?
    If WiFi and Ethernet are different networks, what are the network addresses.
    Is the VPN client installed on Nano and Xavier?
    Is there a router connected to the ethernet network than to WiFi?

    Regards
    Tom

    in reply to: TCP proxy usage #37017
    Tom
    Participant

    Hello,
    In order to allow us to investigate, can you tell us more about your configuration?

    Regards
    Tom

    in reply to: Fail to connect with AWS EC2 #36743
    Tom
    Participant

    Hello,
    check with the Security Group if there is a rule to open port 4000 and SSH port.

    Perhaps you deleted it by accident.

    Are you connecting to NoMachine through the NX protocol or the SSH protocol?

    Check Nomachine status  with command „/ usr / NX / bin / nxserver –status” 

    You should see

    NX> 111 New connections to NoMachine server are enabled.

    NX> 161 Enabled service: nxserver.

    NX> 161 Enabled service: nxnode.

    NX> 161 Enabled service: nxd.

    I understand this is a VM which has been working for a while and was previously accessed via NoMachine?

    Regards,
    Tom

    in reply to: Unable to connect over Wireguard tunnel #34517
    Tom
    Participant

    Hi, I have set up two machines on AWS. First Amazon Linux 2 with WireGuard installed, second Amazon Linux 2 with Mate desktop and NoMachine installed. From my home computer with Windows, I am able to connect via WireGuard to VM number two using NoMachine, on a local IP. I suspect the problem is that port 4000 in security groups is not open for second VM.
    It must be open at least for the IP VM with WireGuard or for the entire VPC.
    It’s not a good idea to open port 4000 for everyone, but you can do it while testing.
    Then remember to turn off. Greetings, Tom

    in reply to: Authentication error on Ubuntu #29031
    Tom
    Participant

    Hello,
    we confirm the problem.
    We are working on a solution.

    Regards
    Tom

    in reply to: Unable to find computer on VPN #28664
    Tom
    Participant

    Hello,
    on your MacOS, when you connect with a VPN and turn on NoMachine, you won’t see computers with NoMachine installed, as you do on your local network, mDNS doesn’t work over VPN. Computers with NoMachine installed from a network connected via VPN have no way to send information that they are ready to connect. In this case, they will not automatically appear in the NoMachine list as ready for connection.

    In the attachment, the address you are trying to connect to is blurred, is it really a local address from the network you connect to via VPN?

    To connect you will need the local IP address of the computer you want to connect to.
    Try to connect via NoMachine to this IP address with the VPN enabled.

    Regards

    Tom

    Tom
    Participant

    Hello,
    you must configure Bastion host  as an intermediate host between the home computer and the destination host (Linux host).

    I assume that the Linux desktop you want to connect to has disabled external IP connections. Bastion host and Linux desktop are in the same internal LAN.

    In the VPC network in Firewall:
    1) Add a rule allowing connections to port 4000 (you can set a different port) e.g. using „Targets tags”. If your Windows host has a fixed IP you can set the connection permission only for that IP.
    2) Add a rule that accepts connections from the local network to any port or only to port 4000 e.g. using „Targets tags”

    In Compute Engine:

    Assign this rule 1 to the  Bastion host, e.g. using „Targets tags”.
    Assign the rule 2 to a Linux host, e.g. with “Target tags”.

    Log in to the Bastion host and add rules to redirect traffic on port 4000 to Linux host using iptables

    Set traffic redirection from port 4000 to Linux host:

    sysctl net.ipv4.ip_forward=1

    iptables -t nat -A PREROUTING -p tcp –dport 4000 -j DNAT –to-destination x.x.x.x:4000

    iptables -t nat -A PREROUTING -p udp –dport 4000 -j DNAT –to-destination x.x.x.x:4000

    iptables -t nat -A POSTROUTING -j MASQUERADE

    Where x.x.x.x is the local Linux host IP.

    Now connecting to Bastion host on port 4000 using NXPlayer the connection will be transferred to your Linux host.

    Regards
    Tom

    Tom
    Participant

    Hello,

    in the attached logs there are no NX Player logs from Linux.

    In the link you can get help on how to do it:

    https://www.nomachine.com/DT10O00163#2

    Server and NX Player logs should be done at the same time.

    The server logs indicate that you tried to set the server port to 3389. There were problems running nxd.exe during this attempt.

    Have you tried connecting to such a port via NX Player?

    The rest of the entries indicate that this port has been changed.

    Trying to connect from Linux (client) to Windows (server) you always have to connect to the port that has been set on the server side.

    The easiest way is to set the server to the default port 4000 and try to connect to it, after successful connection you can change this port to another one.

    In the link you can see how to check the server status and port:
    https://www.nomachine.com/managing-nomachine-server-preferences

    Regards
    Tom

    in reply to: Endless connection to google cloud #26093
    Tom
    Participant

    Hello

    What version of Windows do you have?

    Do you have home or professional version?

    Can you connect with NoMachine to the computer on the LAN from this Windows?

    Is the Windows computer in a different location than the Mint computer?

    Regards
    Tom

    Tom
    Participant

    Hello,

    if you have desktop environment installed you can download NoMachine package from nomachine.com.

    If your fedora does not have a desktop environment installed, you must install it first before installing NoMachine.

    There are several options for downloading the package without desktop.

    Install wget and download the package from the site using these commands.

    yum install wget
    wget https://download.nomachine.com/download/6.9/Linux/nomachine_6.9.2_1_x86_64.rpm

    Or download the package from the NoMachine website to your computer, then send to DigitalOcean using the scp command.

    scp nomachine_6.9.2_1_x86_64.rpm root@x.x.x.x:~
    x.x.x.x is your Fedora IP

    How to install NoMachine form console you can find in this article
    https://www.nomachine.com/pl/AR01L00775

    Regards
    Tom

    in reply to: Can’t connect from outside of network #25795
    Tom
    Participant

    Hello.
    Do you have double WAN connected to router?

    Is your IP dynamic?

    Please check on host, where NoMachine is installed, what IP shows on website https://whatismyipaddress.com or similar.

    Compare the IP shown by NoMachine with that of the website.

    You can tray tracert or traceroute (system dependent) to check which route your packets are going through.  If NoMachine shows the address 32.160.xxx.x and your service shows the address 68.108.xxx.xxx. Packages pass through them in order of address 32.160.xxx.x first and then 68.108.xxx.xxx?

    Numbers after the colon are open port on your router for NoMachine connection to this host.

    Regards
    Tom

    Tom
    Participant

    Hello Santa000,
    Thank you for your comment.
    You have a connection to the machine but you cannot login?
    Do you use VM “External IP” to connect?
    What error do you get when you connect?

    In the link below you can check how to solve the most common problems with the ssh connection
    https://cloud.google.com/compute/docs/ssh-in-browser#ssherror

    Regards,
    Tom

    Tom
    Participant

    Hello AD5XJ,

    Thank you for your comment.

    The information about your gateway settings is a little bit confusing; we are not sure if you have these mentioned two ports (4000 and 4023) redirected on router by your ISP or if you have admin access to the router and you are able to redirect it by yourself.

    Technically, every computer in your LAN should have a specific port redirected on your router.

    If you want to reach more than one computer from WAN, you must set, on the router, the port forwarding to local IP and port 4000.

    For example:

    first computer – WAN port 8001 forward to IP 192.168.1.10 and port 4000
    second computer  – WAN port 8002 forward to IP 192.168.1.11 and port 4000.

    Regards
    Tom

Viewing 15 posts - 1 through 15 (of 34 total)