Tom

Forum Replies Created

Viewing 13 posts - 16 through 28 (of 28 total)
  • Author
    Posts
  • in reply to: Screen share host behind NAT using reverse SSH tunnel #9489
    AvatarTom
    Participant

    Hello,

    Please try one of these commands:

    ssh -fN -R YourOfficeIP:10022:localhost:4000 ubuntu@a.b.c.d

    or

    ssh -fN -R *:10022:localhost:4000 ubuntu@a.b.c.d

    In the first command replace ‘YourOfficeIP’ with the IP address of your office, if the IP address of your office is static.

    The second command allows you to connect through SSH tunnel from any address on the Internet.

    Regards

    Tom

    in reply to: NoMachine and duckDNS #8763
    AvatarTom
    Participant

    Hello

    I understand you have a laptop at home/office.

    You have a dynamic IP address.

    You configured Duck DNS on it and have domain name eg. exampledomain.duckdns.org.

    Being away from home/office you want to connect by NoMachine to this laptop ?

    NoMachine does not need to be configured.

    First you need on your router to forward port 4000 to port 4000 and the IP address of your laptop. Of course it can be any port eg.5234 forwarding to port 4000 on your laptop.

    Then in the external network to connect to your laptop use the domain name you set up in Duck DNS and port you configured on your router.

     

    in reply to: New NX user admin account post client installation #7663
    AvatarTom
    Participant

    “Hello,

    perhaps you installed NoMachine Server package.
    On our website you can find a package called “NoMachine Enterprise Client”.

    It’s a package that installs only the NoMachine Client.

    During the installation of Enterprise Client a nx user account isn’t created.
    You can find this package in the tab download, “Enterprise Products Evaluation” section.
    Regards

    Tom

    in reply to: Cannot use NoMachine to connect from Windows to Linux #7616
    AvatarTom
    Participant

    Hello.

    In log I see that you tried connect to IP 10.0.3.1, this is local address.

    Is IP address are you try connect over the Internet ?

    If so, please check your Internet IP address on this side http://whatismyipaddress.com ( Do not give this address in the forum ).

    Try to connect to address from the web side to port 4000.

    If no, please give us the model of your router.

    Regards

    Tom

    AvatarTom
    Participant

    Hello,

    on the headless machine eg. on AWS EC2  navigate to the <user’s home>/.nx/ create directory ‘config’.

    In the ‘config’ directory create file ‘authorized.crt’.

    Copy to this file contents of your public key file, this file has the extension .pub.

    After completing these steps you will be able to connect to the NoMachine using the private key.

    in reply to: NoMachine and pfSense #7124
    AvatarTom
    Participant

    Hello,

    If I understand your set up clearly, you have 10 developer workstations in your office on your LAN. You have customers/other developers which need to access one/some of/all these computers on your LAN.

    For each of the developer machines you want to provide access to/share desktop with you will need to configure your pfSense router to bind one port for each machine on the internal network.

    For example you can configure (on the router) port 4001 for Dev 1 machine and forward this port to the local IP address and port 4000 of the Dev 1 machine; port 4002 for ” Dev 2″  and forward it to the local IP and port 4000 of the Dev 2 etc.

    Customers can connect to Dev 1 using your external IP and port 4001. Many customers at the same time can connect to one port. Ports 4001 and 4002 are only an example and can be changed.

    For you pfSense router you can forward ports in menu “Firewall”, sub menu “NAT”, tab “Port Forward”.

    Click on the ‘+’ sign to add port forward.

    Set “Destination” to “any”.

    In “Destination port range” set the port to which you want to bind to first developer machine.

    In “Redirect target IP” set first developers internal IP for example 192.168.0.101.

    In “Redirect target port” set to “other” and write 4000.

    Save changes.

    After this you can connect to ‘Dev 1’ from the internet indicating in your external IP address and port xxxx in the player GUI.

    You need to set this up for all the computers, of course, giving another external port for each of them and internal IP.

    in reply to: Configuring incompatible routers #7123
    AvatarTom
    Participant

    Hello,

    You do not need UPnP and NAT-PMP to connect to your computer from the internet.
    You can configure the router to forward the connection from external IP and port 4000 to the IP and port 4000 of the local computer

    Of course, port 4000 is only an example, you can set it to a different one if you want.

    For example, you can set up port 4689 on your router so that it is redirected to the internal IP and port 4000 of your PC.

    In this case, to connect your computer form internet, you will need to set the external IP and port 4689 in nxplayer.

    Changes in the NoMachine server are not needed.

    in reply to: Could not connect to the server #6822
    AvatarTom
    Participant

    Hello,
    Can you connect to the Mac from your home network?
    Did you set port forwarding on your home router?
    On the Mac you have installed the software that can to block ports?
    Please give the name and model of router.

    Could you provide server log files form Mac?
    You can follow this guideline: https://www.nomachine.com/AR07K00677
    and send to them forum[at]nomachine[dot]com referencing your topic.

    in reply to: Error 61: Connection Refused #6706
    AvatarTom
    Participant

    Hello.

    Is this a free version of NoMachine?

    Is port 4000 open on CentOS?

    On CentOS is NoMachine server running?

    Please check the following command from console:

    sudo /usr/NX/bin/nxserver –restart

    After running this are there are any errors?

    in reply to: Connect to server from behind firewall #6680
    AvatarTom
    Participant

    Hello
    We tried to reproduce the problem in our laboratory.Unfortunately we were unable to.

    Please run the command “iptables -t nat -A PREROUTING” and paste the lines at the forum which is the end of 4000.

    Is the computer where NoMachine installed connected to another router or modem?

    If so please give the name and model.

    in reply to: Error is 61 #6639
    AvatarTom
    Participant

    Hello

    We tried to reproduce the problem in our laboratory.
    Unfortunately we were unable to.

    Could you please answer the following questions?

    On the router is UPnP enabled?

    Is port forwarding on the router set manually ?

    Is the port 20808 redirected to the server IP and 4000 port ?

    Do you see this port 20808 in the column “GW Port” on “Network Services” tab on server side ?

    Please write what router you’re using.

    in reply to: Mozilla Thunderbird does not fetch mail #6038
    AvatarTom
    Participant

    Hello, could you provide server log files?

    You can follow this guideline: https://www.nomachine.com/AR07K00677

    and send to them forum[at]nomachine[dot]com referencing your topic.

    in reply to: Mozilla Thunderbird does not fetch mail #5929
    AvatarTom
    Participant

    Hello,

    We have a few questions:

    Was the system rebooted after installing NoMachine ?

    What message is displayed when trying to download the mail in Thunderbird ?

    On which ports is your mail server running ?

    What firewall do you have installed ?

    After installing NoMachine is it possible to open any Internet page in the web browser ?

    If you are unable to load any pages, please follow the steps below.

    1) Uninstall NoMachine.

    2) Please check before installing NoMachine the “ipconfig” command ( In Search system function write cmd and press enter button.

    In the cmd window write “ipconfig” and press the enter button  )

    3) Write down this information  – Ipv4 Address and Default Gateway.

    4) Install  NoMachine

    5) Recheck by the command “ipconfig”  Ipv4 Address and Default Gateway.

    Have the Ipv4 Address or Default Gateway changed ?

    Check what the network adapters and drivers are installed on your system.

    1) Press the right mouse button on the Windows symbol

    2) From the menu, select Device Manager

    3) Expand Network Adapters

    4) Check what the network adapters are installed on your system.

    Is your network card displayed with an exclamation point?

    5) Right-click on your network card and select Properties

    6) Select the tab Drivers and check what kind of driver is installed for your network adapter.

    Has the driver for your network card changed after installing NoMachine ?

Viewing 13 posts - 16 through 28 (of 28 total)