Tor

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 416 total)
  • Author
    Posts
  • in reply to: Maximum resolution – dual monitor #28094
    AvatarTor
    Contributor

    I’m happy you solved it. πŸ™‚ I’ll forward your request to devs, so they can evaluate it.
    By the way since the video card is responsible for notifying the number of connected monitors, you could check if there is a setting allowing to report the monitor as connected also when it’s turned off. You could also configure energy saving settings, it’s not like turning the monitor completely off but it’s better than leaving it switched on.
    Lastly, if you want to hide what you’re doing while you’re connected to the desktop for privacy reasons, you can enable the display blanking option in server settings.

    AvatarTor
    Contributor

    Agreed, here it is:

    https://www.nomachine.com/FR06R03993

    It has been added to the short term release roadmap, so you can subscribe to the FR to be notified when it’ll be available. πŸ™‚

    in reply to: Maximum resolution – dual monitor #28066
    AvatarTor
    Contributor

    But I can’t tell if NoMachine is actually using portions of the RDP protocol which would limit it to 1 monitor, or not.

    The free version of NoMachine doesn’t support RDP sessions, it’s a feature available in the Linux Terminal Server products.

    Are you able to see more than 1 monitor, or are you only using 1 monitor in your setup?

    If you can correctly connect to the Windows physical desktop (the same you use at work) and both monitors are detected by the Operating System (they’re not switched off/disconnected), you’ll see all your monitors in the remote desktop session of NoMachine and you don’t need to virtualize your desktop like you’re used to do with RDP.

    AvatarTor
    Contributor

    Hi. Yes, it is currently only a command line option. We could improve the option usage by adding a key in the connection file (NXS). Would that be fine for you?

    in reply to: Maximum resolution – dual monitor #28039
    AvatarTor
    Contributor

    Hey Ranger, thank you for sending the useful information. There are many differences between NoMachine and Windows Terminal Services, and one of those is for sure the way they deal with displays on the server. When you connect with RDP, Windows Terminal Service creates a desktop with virtual displays that don’t necessarily match the actual monitors connected to the server (usually RDP clients allow to use the default display resolution or set a custom resolution). In your recent screenshot I see your machine lists a single monitor NEC 2560×1440, which is the one shown in NoMachine display settings. In order to see correctly two monitors in NoMachine you need to verify why your PC at work doesn’t show both NEC monitors in display settings.

    in reply to: Hardcoded ~/.nx/fonts #27999
    AvatarTor
    Contributor

    Hi jason. The path you see in libfontconfig.so is just the default one, but you can change it by setting the variable NX_CONFIG in the environment where you’ll start the player. It is a path representing where the client will store its data, by default ~/.nx. If you also want to move user files/folders created by the NoMachine server services you’ll have to change the key UserNXDirectoryPath in /usr/NX/etc/node.cfg.

    in reply to: Maximum resolution – dual monitor #27998
    AvatarTor
    Contributor

    Could you please clarify if the screenshot of the display settings was taken while NoMachine was connected to the desktop? I see you often talk about RDP, but I didn’t understand if you do it as a comparison or to outline that you’re connecting to the desktop while an RDP connection is active. Thank you.

    in reply to: Desktop session mistaken for virtual #27974
    AvatarTor
    Contributor

    The software update message is misleading. The remote desktop is running on a headless Linux server (where there is not an X server running), and the update process detects it as a virtual desktop. By the way in this specific configuration the software update program can’t complete its task, so you’ll have to download the newest NoMachine package from the website and install it to upgrade your version. We’ll improve it to support also headless servers.

    in reply to: Maximum resolution – dual monitor #27948
    AvatarTor
    Contributor

    Hi. We’re not currently aware of issues with detecting monitors connected to the remote desktop, you should be able to use both monitors at full resolution.
    Can you please open the menu (Ctrl + Alt + 0) and verify if you see the “Change monitor” button in the Display menu? Could you send a screenshot of the Display settings panel, so we’ll know the parameters that are being detected? Thanks.

    in reply to: Ctrl alt del from iPad #27694
    AvatarTor
    Contributor

    Hi. On mobile app you don’t need to use the menu: open the OnScreen keyboard (or press the toolbar icon if you’ve a physical keyboard) and use the extended bar to press Control, Alt and Delete. It’ll trigger the Secure Attention Sequence on the server to unlock the screen.

    in reply to: Incorrect keyboard mapping (β€˜) #27426
    AvatarTor
    Contributor

    Thanks. This looks to be an old problem popped out again after some OS changes. Please try this: enter Settings > General > Keyboard and turn off Smart Punctuation. Let me know if this fixes it.

    in reply to: Incorrect keyboard mapping (β€˜) #27404
    AvatarTor
    Contributor

    Thank you for the additional information. Can you please confirm your keyboard language on iPad and your layout on macOS?

    AvatarTor
    Contributor

    The default keys combination is Ctrl + Alt + End so it doesn’t interfere with the Ctrl + Alt + Del shortcut, and as you have noticed the same hotkey can be sent from the ‘special sequences’ menu. If both solutions didn’t help you we need to verify what is happening on the Windows server.
    Please verify that your group policy allows services to simulate a Secure Attention Sequence (SAS). To do so, verify the policy in Computer Configuration, Administrative Templates, Windows Components, Windows Logon Options. The entry “Disable or enable software Secure Attention Sequence” must be Enabled, and the software allowed to generate the Secure Attention Sequence must be set to “Services”.
    If this is not helping, please follow the instructions at https://www.nomachine.com/DT10O00162 and send gathered logs to forum[at]nomachine[dot]com.

    in reply to: Incorrect keyboard mapping (β€˜) #27346
    AvatarTor
    Contributor

    NoMachine maps virtual keyboard symbols to symbols available in the remote keyboard layout. Some symbols like the opening or closing quotation marks are typographical and not available in the layout, so the app can’t tell the server what is the correct way to type them.
    In the extended symbols you see when tapping and holding the apostrophe key, the second and the fourth symbols (attached image) will be correctly sent to the server.

    We’re dying for some features for iPad os such as scroll, switch desktop (by three fingers swiping on Mac), etc.

    Do you mean scrolling with mouse and trackpad? As for the gestures, we’ll carefully evaluate what we can do without interfering with app gestures.

    in reply to: Task manager title #27150
    AvatarTor
    Contributor

    Hi. You could do something similar by installing xdotool and by executing a script like this:

    #!/bin/bash
    
    ids=$(xdotool search --class "nxplayer.bin")
    for id in $ids; do
      name=$(xdotool getwindowname $id)
      if [[ $name == "NoMachine -"* ]]; then
        newname=${name##NoMachine -}
        xdotool set_window --name "$newname" $id
      fi
    done
Viewing 15 posts - 1 through 15 (of 416 total)