tsotne

Forum Replies Created

Viewing 15 posts - 16 through 30 (of 41 total)
  • Author
    Posts
  • in reply to: No hardware sound on server #33781
    tsotne
    Participant

    Hi Paai,
    glad to hear that your problem is solved now.

    in reply to: No hardware sound on server #33708
    tsotne
    Participant

    Hi Paai again, received your logs.

    So according to the logs you are using NoMachine virtual session and “mute server” option is only available for NoMachine physical session (there is no problem in virtual session logs).

    in reply to: No audio between two Ubuntu 18.04 machines #33707
    tsotne
    Participant

    Hi Dan,

    One PA instance which was invoked by nxserver is for virtual session, but your logs shows that you are using physical session. Are you using virtual NoMachine session on the host machine?

    According to the logs and output of pactl commands, you should have audio output, or there is something wrong on system or some PA configs are messed up.

    in reply to: No hardware sound on server #33696
    tsotne
    Participant

    Hi Paal again.

    after you enable logs on the machine, please restart nxserver (if not it miss some essential logs):
    sudo /etc/NX/nxserver --restart

    and after this connect to the machine using NM and collect logs again.

    According to pactl output our sinks/sources are loaded how it should but indeed not see hardware sink/source is weird.
    Can you give use to the same pact commands on host machine (directly on it without using NM) and can you confirm that it is happening only during the session or after NM installation it disappears?

    pavucontol screens would be helpful too.

    in reply to: No audio between two Ubuntu 18.04 machines #33695
    tsotne
    Participant

    Hi Dan,
    even they are important modules, I tested it and sound loading should still work (I used Ubuntu 18.04 too), so let’s comment them again and restart pulseaudio.

    In the previous reply where I asked you output for
    ps aux|grep pulse

    your output shows that PA is running twice for your user and probably that is the problem.
    let’s check which commands are invoking both instances:
    run again previous ps command and for both PA instance pid (second column is pid) run:
    systemctl status PID_VALUE #replace pid number

    It will get info which process started PA, one should be systemd and let’s check what is second one.

    in reply to: No audio between two Ubuntu 18.04 machines #33676
    tsotne
    Participant

    Hi Dan,
    got your email and your config file.

    Why did you disable to load module-switch-on-connect and module-switch-on-port-available?

    They are important modules.

    uncomment them and restart pulseaudio:
    pulseaudio -k

    Then try again and check, if you can see our sink/sources and if you get sound during NoMachine session.

    Hi Paai,
    so you mean that you don’t get audio in amplifier during NoMachine session, yes? or it stops working just after installing NoMachine , without using NoMachine session?

    NoMachine doesn’t “kill/stop” default sinks/source that’s why NoMachine use its own sink/sources.

    Please upload logs (instruction is the same how I advised Dan)

    Just while you will be connected to the host machine using NoMachine, please try to check/uncheck “mute audio on server” option a few times.

    Also provide output of commands of pactl on host machine before you connect using NoMachine and upload screen of pavucontrol output device tab.

    in reply to: No audio between two Ubuntu 18.04 machines #33648
    tsotne
    Participant

    Hi Dan,
    unfortunately your files still don’t help and it is still weird to me not seeing our sink/source while in logs it is shown that they are loaded without any error. Just to be sure, do you have some custom pulseadudio configuration?

    what is output of this command (again, while you are connected to host machine, using NM player) on host machine:
    ps aux|grep pulse

    also run
    pactl info

    The command pactl info should return a line (among other lines) beginning with “Server String”.

    Please run also the command
    ls -l SERVER_STRING_VALUE_FROM_PACTL_INFO_OUTPUT

    and replace SERVER_STRING_VALUE_FROM_PACTL_INFO_OUTPUT by the actual string which is appended after “Server String”, e.g.

    if it is
    Server String: /run/user/1000/pulse/

    run
    ls -l /run/user/1000/pulse/

    and send us that output, too.

    in reply to: No audio between two Ubuntu 18.04 machines #33531
    tsotne
    Participant

    Hi,

    Yes, I got it. The logs show that everything is loaded how it should and there aren’t any errors.

    So it is so weird to not see our sinks/sources in pactl command output. Did you take it during the session?
    Please again, give us the output of list sinks and sources during session from NM player (open terminal during session on server machine from NM player and run same commands there).

    Also, probably you have it already, but if not, install pavucontrol on server machine:
    sudo apt install pavucontrol

    Open it also during session from nxplayer (it will call Pulseaudio Volume control in apps) and upload screen of input and output device tabs, from show control choose all input/output devices.

    in reply to: No audio between two Ubuntu 18.04 machines #33496
    tsotne
    Participant

    Hi Dan,

    The logs are missing, if you still get an upload error you can send them directly to forum[at]nomachine[dot]com making sure to reference the title of the topic as the subject.

    in reply to: No audio between two Ubuntu 18.04 machines #33479
    tsotne
    Participant

    Hi again, to get audio on a Linux machine we use PA’s some modules but according to the logs they are not loaded. Just to be sure, did you take it during NM session yes (it will show there only during session)?

    I have to ask to upload logs again.
    On the server machine, run:
    sudo /etc/NX/nxserver --debug --enable all

    Instruction is missing in this part, but for getting all the necessary logs it needs to restart the server:
    sudo /etc/NX/nxserver --restart

    Then connect using NM to that server and collect logs:
    sudo /etc/NX/nxserver --debug --collect

    Upload those logs and while you are connected to the host machine using NM run and copy their output too:

    pactl list sinks short
    pactl list sources short

    in reply to: No audio between two Ubuntu 18.04 machines #33470
    tsotne
    Participant

    Hi again, sorry for the late reply. I just received the email for this comment.

    On the forum there is no file format restriction, if they are big files can you compress them and try to upload them?
    And if you still get upload error you can send them directly to forum[at]nomachine[dot]com making sure to reference the title of the topic as the subject.

    in reply to: No audio between two Ubuntu 18.04 machines #33461
    tsotne
    Participant

    Hi again, good to hear that it works and you get audio from it.

    Can you upload all_list1.log, all_list2.log, it’s important to understand what’s happening.

    in reply to: No audio between two Ubuntu 18.04 machines #33441
    tsotne
    Participant

    There is no all_list1.log, all_list2.log files.

    For change muting open context menu, from upper right corner, choose Audio –> Change Settings –> uncheck “mute audio on the server”.

    in reply to: No audio between two Ubuntu 18.04 machines #33442
    tsotne
    Participant

    Also do test the server that you get audio there (plug in to the Line Out jack)?

    in reply to: No audio between two Ubuntu 18.04 machines #33427
    tsotne
    Participant

    Hi again,
    client side is from where you connect and server where you connect from client. We need server side info. Do I get it right that, when you connect from same client to Windows you get audio but not when you connect to Ubuntu?

    Also can you confirm that pulseaudio path is /usr/bin/pulseaudio on your system (on server) too?

Viewing 15 posts - 16 through 30 (of 41 total)