tsotne

Forum Replies Created

Viewing 11 posts - 31 through 41 (of 41 total)
  • Author
    Posts
  • in reply to: No audio between two Ubuntu 18.04 machines #33416
    tsotne
    Participant

    Hello,
    1. Have you checked that PulseAudio is working on the server machine?
    (it is installed correctly, users have access to it and it is running, also do you have some modified configuration for it?)

    2. Check if the following /usr/NX/etc/node.cfg keys are set like this:

    AudioInterface pulseaudio
    CommandStartPulseAudio "/usr/bin/pulseaudio --high-priority=no"

    3. When you connect to that Linux machine run this command:
    pactl list > all_list1.log

    4. When you connect and if you had checked “mute server audio” option when connecting to the machine, let’s uncheck it from context menu and run again:
    pactl list > all_list2.log

    5. You can find the instructions on how to collect server side logs here: https://knowledgebase.nomachine.com/DT11R00182

    5. Upload all_list1.log, all_list2.log, server-side logs.

    in reply to: Sound not working (MacMini M1) #32997
    tsotne
    Participant

    Hi again,

    Yes, it’s on the same machine but those logs are related only when you use your Mac as a host.
    It should ask permission, we are gonna try to reproduce, but for you, you can give to NM mic permission manually:

    Open terminal and run:
    sudo sqlite3 '/Users/nomachine/Library/Application Support/com.apple.TCC/TCC.db'
    enter your password.
    insert into access VALUES('kTCCServiceMicrophone','com.nomachine.nxdock',0,2,2,1,NULL,NULL,NULL,'UNUSED',NULL,0,1610447022);

    Close sqlite with Ctrl+d

    and restart nxserver:
    sudo /etc/NX/nxserver --restart

    then please check.

    in reply to: Sound not working (MacMini M1) #32998
    tsotne
    Participant

    Before you do it manually, just checked, it definitely asks permission when trying to play something in the NM session. You should give permission and restart nxserver.

    in reply to: Sound not working (MacMini M1) #32985
    tsotne
    Participant

    Hello,

    M1 Macs audio is not supported yet if you will use it as server, but used as client audio forwarding it works.
    Those logs are from the server-side.

    Please, check if you granted mic permission to NM in settings.
    If not, grant it and restart the server from the terminal:
    /etc/NX/nxserver --restart

    in reply to: Pacmd (and others) fails on Pi 4 Buster and NoMachine #30950
    tsotne
    Participant

    Hello,
    does it give some error when try to manually start PA daemon.

    please try and give output or error message if it gives any:
    pulseaudio -D

    in reply to: Server audio not muted #30843
    tsotne
    Participant

    Hi again,
    please do:
    1. Enable logs on server side:
    sudo /etc/NX/nxserver --debug --enable all

    2. restart NM on server side:
    sudo /etc/NX/nxserver --restart

    3. Connect again to server with mute option enabled and again few times enable and disable it from context menu.

    4. When enabled mute option, check sinks again (it’s important)
    pacmd list-sinks > list_sinks.log

    5. Disconnect from server and give us:

    • list_sinks.log
    • nxserver.log from ~/.nx/nxserver.log
    in reply to: Server audio not muted #30829
    tsotne
    Participant

    Thank you for logs.

    Please also upload nxserver.log from:

    ~/.nx/nxserver.log

    or (~ refers your home directory)
    /home/$USER/.nx/nxserver.log

    in reply to: Server audio not muted #30786
    tsotne
    Participant

    Hello again,
    please for more investigation, send us logs.

    Here you can find article, how to capture logs automatically.

    Connect to server with “mute server” option and few times enable/disable “mute server” option from context menu (right upper corner, in audio section).

    And once again, please give us output of available sinks when “mute server” option is enabled.

    in reply to: Can’t get sound working on Mac #30759
    tsotne
    Participant

    It seems nxaudio loaded.

    So tell us whether:
    1.  you see NM Audio Adapter in Audio MIDI Setup? if yes, is it set as default?

    and check
    2. you have specific user microphone permission in System Preferences –> Security&Privacy?

    Please, attach screenshots of that settings.

    in reply to: Can’t get sound working on Mac #30748
    tsotne
    Participant

    Hello, for newer versions of Mac OS, nxaudio kext is located in different place.

    please, try:

    1. let’s load nxaudio kext manually:

    sudo kextutil -vvv /Library/Extensions/nxaudio.kext/

    2. if you did not approve it, do:
    Access System Preferences -> Security&Privacy -> General panel. Click on the “Allow” button

    3. if it finished without any error, check if it’s loaded properly:
    kextstat | grep nxau

    you should get similar output:
    180    0 0xffffff7f83d9c000 0x5000     0x5000
    com.nomachine.driver.nxau (4.1.b2) 78172556-B6A4-3112-BA41-E79D18108476
    <93 6 5 3 1>

    4. restart NoMachine server:
    sudo /etc/NX/nxserver --restart

    If audio still does not work, please send us the output of kextutil command (point 1) in your reply.

    in reply to: Can’t get sound working on Mac #30680
    tsotne
    Participant

    Hello,
    firstly, please check if you did approve kernel extensions (see article about it)

    if yes,
    1. let’s load nxaudio kext manually:

    sudo kextutil -vvv /System/Library/Extensions/nxaudio.kext/

    2. if you already approved, skip this step:
    Access System Preferences -> Security&Privacy -> General panel. Click on the “Allow” button

    3. if it finished without any error, check if it’s loaded properly:
    kextstat | grep nxau

    you should get similar output:
    180    0 0xffffff7f83d9c000 0x5000     0x5000     com.nomachine.driver.nxau (4.1.b2) 78172556-B6A4-3112-BA41-E79D18108476 <93 6 5 3 1>

    4. restart NoMachine server:
    sudo /etc/NX/nxserver --restart

    If audio still does not work, please send us the output of kextutil command (point 1) in your reply.

Viewing 11 posts - 31 through 41 (of 41 total)